Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Не учитывать ошибку в сумме ячеек - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Не учитывать ошибку в сумме ячеек (Формулы/Formulas)
Не учитывать ошибку в сумме ячеек
GP75 Дата: Понедельник, 09.05.2016, 20:50 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 52
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Здравствуйте снова. Подскажите, как сделать так. чтобы не учитывалась возможная ошибка в сложении результатов ячеек:
Например есть формула А1=В1+C1+D1+E1. (в ячейках В1,С1, D1, Е1 - тоже формулы) Нужно сделать так, чтобы в формуле при наличии ошибки (Н/Д) в одной из ячеек В1, С1, D1 или Е1 ячейка с ошибкой игнорировалась: то есть
Если в С1 ошибка, то А1=В1+D1+Е1.


Сообщение отредактировал GP75 - Понедельник, 09.05.2016, 20:51
 
Ответить
СообщениеЗдравствуйте снова. Подскажите, как сделать так. чтобы не учитывалась возможная ошибка в сложении результатов ячеек:
Например есть формула А1=В1+C1+D1+E1. (в ячейках В1,С1, D1, Е1 - тоже формулы) Нужно сделать так, чтобы в формуле при наличии ошибки (Н/Д) в одной из ячеек В1, С1, D1 или Е1 ячейка с ошибкой игнорировалась: то есть
Если в С1 ошибка, то А1=В1+D1+Е1.

Автор - GP75
Дата добавления - 09.05.2016 в 20:50
Nic70y Дата: Понедельник, 09.05.2016, 21:15 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4080
Репутация: 871 ±
Замечаний: 0% ±

Excel 2013
Код
=СУММЕСЛИ(B1:E1;">-9E+307")


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=СУММЕСЛИ(B1:E1;">-9E+307")

Автор - Nic70y
Дата добавления - 09.05.2016 в 21:15
GP75 Дата: Понедельник, 09.05.2016, 21:38 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 52
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Не работаеет
 
Ответить
СообщениеНе работаеет

Автор - GP75
Дата добавления - 09.05.2016 в 21:38
buchlotnik Дата: Понедельник, 09.05.2016, 21:41 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2995
Репутация: 839 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
Не работаеет
а в файле показать религия не позволяет? deal
можно массивкой
Код
=СУММ(ЕСЛИ(ЕЧИСЛО(B1:E1);B1:E1;0))

с 2010 версии можно вообще так:
Код
=АГРЕГАТ(9;6;B1:E1)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Понедельник, 09.05.2016, 21:47
 
Ответить
Сообщение
Цитата
Не работаеет
а в файле показать религия не позволяет? deal
можно массивкой
Код
=СУММ(ЕСЛИ(ЕЧИСЛО(B1:E1);B1:E1;0))

с 2010 версии можно вообще так:
Код
=АГРЕГАТ(9;6;B1:E1)

Автор - buchlotnik
Дата добавления - 09.05.2016 в 21:41
GP75 Дата: Понедельник, 09.05.2016, 22:10 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 52
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Спасибо!
 
Ответить
СообщениеСпасибо!

Автор - GP75
Дата добавления - 09.05.2016 в 22:10
jakim Дата: Вторник, 10.05.2016, 15:22 | Сообщение № 6
Группа: Друзья
Ранг: Ветеран
Сообщений: 801
Репутация: 206 ±
Замечаний: 0% ±

Можно воспользоваться и такой формулой:

Код
=SUMIF(A1:E1;"<1E100")
 
Ответить
Сообщение
Можно воспользоваться и такой формулой:

Код
=SUMIF(A1:E1;"<1E100")

Автор - jakim
Дата добавления - 10.05.2016 в 15:22
GP75 Дата: Вторник, 10.05.2016, 15:32 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 52
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Попробую. Спасибо!
 
Ответить
СообщениеПопробую. Спасибо!

Автор - GP75
Дата добавления - 10.05.2016 в 15:32
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Не учитывать ошибку в сумме ячеек (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!