Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вычисление итога из массива - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вычисление итога из массива (Формулы/Formulas)
Вычисление итога из массива
Meissen Дата: Среда, 11.05.2016, 07:27 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 52
Репутация: 0 ±
Замечаний: 40% ±

Excel 2010
Добрый день. Друзья, помогите решить задачу, последняя из задач осталась, голову сломал уже, ничего не получается........ :( всё условие в файле.....
К сообщению приложен файл: _Microsoft_Exce.xls(50Kb)
 
Ответить
СообщениеДобрый день. Друзья, помогите решить задачу, последняя из задач осталась, голову сломал уже, ничего не получается........ :( всё условие в файле.....

Автор - Meissen
Дата добавления - 11.05.2016 в 07:27
китин Дата: Среда, 11.05.2016, 07:42 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4121
Репутация: 637 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
В.1 форматирование при помощи ТЕКСТ
Код
=ТЕКСТ((СУММЕСЛИМН($B$5:$B$1004;$B$5:$B$1004;">9999";$B$5:$B$1004;"<11111")/СЧЁТЕСЛИМН($B$5:$B$1004;">9999";$B$5:$B$1004;"<11111")-38,35)*4;"ДД/ММММ/ГГГГ")

В.2 форматирование форматом ячейки (желтенькая)
Код
=(СУММЕСЛИМН($B$5:$B$1004;$B$5:$B$1004;">9999";$B$5:$B$1004;"<11111")/СЧЁТЕСЛИМН($B$5:$B$1004;">9999";$B$5:$B$1004;"<11111")-38,35)*4

В.3 для 2003 (зелененькая)
Код
=(СУММПРОИЗВ($B$5:$B$1004*($B$5:$B$1004>9999)*($B$5:$B$1004<11111))/СУММПРОИЗВ(ЕЧИСЛО($B$5:$B$1004)*($B$5:$B$1004>9999)*($B$5:$B$1004<11111))-38,35)*4
К сообщению приложен файл: 12345.xlsx(22Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Среда, 11.05.2016, 07:55
 
Ответить
СообщениеВ.1 форматирование при помощи ТЕКСТ
Код
=ТЕКСТ((СУММЕСЛИМН($B$5:$B$1004;$B$5:$B$1004;">9999";$B$5:$B$1004;"<11111")/СЧЁТЕСЛИМН($B$5:$B$1004;">9999";$B$5:$B$1004;"<11111")-38,35)*4;"ДД/ММММ/ГГГГ")

В.2 форматирование форматом ячейки (желтенькая)
Код
=(СУММЕСЛИМН($B$5:$B$1004;$B$5:$B$1004;">9999";$B$5:$B$1004;"<11111")/СЧЁТЕСЛИМН($B$5:$B$1004;">9999";$B$5:$B$1004;"<11111")-38,35)*4

В.3 для 2003 (зелененькая)
Код
=(СУММПРОИЗВ($B$5:$B$1004*($B$5:$B$1004>9999)*($B$5:$B$1004<11111))/СУММПРОИЗВ(ЕЧИСЛО($B$5:$B$1004)*($B$5:$B$1004>9999)*($B$5:$B$1004<11111))-38,35)*4

Автор - китин
Дата добавления - 11.05.2016 в 07:42
Meissen Дата: Среда, 11.05.2016, 07:50 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 52
Репутация: 0 ±
Замечаний: 40% ±

Excel 2010
Спасибо !!!
 
Ответить
СообщениеСпасибо !!!

Автор - Meissen
Дата добавления - 11.05.2016 в 07:50
Nic70y Дата: Среда, 11.05.2016, 07:52 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3925
Репутация: 832 ±
Замечаний: 0% ±

Excel 2013
еще
Код
=(СУММПРОИЗВ((B5:B1004>9999)*(B5:B1004<11111)*B5:B1004)/СУММПРОИЗВ((B5:B1004>9999)*(B5:B1004<11111))-38,35)*4
Код
=(СРЗНАЧЕСЛИМН(B5:B994;B5:B994;">9999";B5:B994;"<11111")-38,35)*4
Игорь, опечатка
К сообщению приложен файл: 2922958.xls(64Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениееще
Код
=(СУММПРОИЗВ((B5:B1004>9999)*(B5:B1004<11111)*B5:B1004)/СУММПРОИЗВ((B5:B1004>9999)*(B5:B1004<11111))-38,35)*4
Код
=(СРЗНАЧЕСЛИМН(B5:B994;B5:B994;">9999";B5:B994;"<11111")-38,35)*4
Игорь, опечатка

Автор - Nic70y
Дата добавления - 11.05.2016 в 07:52
китин Дата: Среда, 11.05.2016, 07:55 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4121
Репутация: 637 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Игорь, опечатка

точно, спасибо!
Исправил, файл перевложил


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Среда, 11.05.2016, 07:56
 
Ответить
Сообщение
Игорь, опечатка

точно, спасибо!
Исправил, файл перевложил

Автор - китин
Дата добавления - 11.05.2016 в 07:55
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вычисление итога из массива (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!