Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Копирование ячеек с заданным интервалом строк с другог листа - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Копирование ячеек с заданным интервалом строк с другог листа (Формулы/Formulas)
Копирование ячеек с заданным интервалом строк с другог листа
troi37 Дата: Среда, 11.05.2016, 10:57 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте, уважаемые форумчане!
С освоением экселя, возникают некоторые проблемы. Некоторые получается решить самому, некоторые с помощью различных настроек дополнительных, но вот с смещением по строкам с выводом данных в определенные ячейки возникли проблемы. Буду очень благодарен, если не за решение данной проблемы, а за информацию где можно посмотреть варианты решения.
К сообщению приложен файл: 5646613.xlsx(10Kb)


Сообщение отредактировал troi37 - Среда, 11.05.2016, 10:58
 
Ответить
СообщениеЗдравствуйте, уважаемые форумчане!
С освоением экселя, возникают некоторые проблемы. Некоторые получается решить самому, некоторые с помощью различных настроек дополнительных, но вот с смещением по строкам с выводом данных в определенные ячейки возникли проблемы. Буду очень благодарен, если не за решение данной проблемы, а за информацию где можно посмотреть варианты решения.

Автор - troi37
Дата добавления - 11.05.2016 в 10:57
китин Дата: Среда, 11.05.2016, 10:58 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
формула массива
Код
=ИНДЕКС(Лист2!$C$2:$C$18;НАИМЕНЬШИЙ(ЕСЛИ(Лист2!$D$2:$D$18=Лист1!C$8;СТРОКА(Лист2!$C$2:$C$18)-1);СТРОКА(A1)))
К сообщению приложен файл: 646613.xlsx(11Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Среда, 11.05.2016, 11:05
 
Ответить
Сообщениеформула массива
Код
=ИНДЕКС(Лист2!$C$2:$C$18;НАИМЕНЬШИЙ(ЕСЛИ(Лист2!$D$2:$D$18=Лист1!C$8;СТРОКА(Лист2!$C$2:$C$18)-1);СТРОКА(A1)))

Автор - китин
Дата добавления - 11.05.2016 в 10:58
lebensvoll Дата: Среда, 11.05.2016, 11:07 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 645
Репутация: 2 ±
Замечаний: 60% ±

Excel 2010
Вы бы хоть в примере помимо пояснения набросали данные (значения) пример что ли. Пустые ячейки с заголовками столбцов и строк + пояснение И ВСЕ (((( так вам тут ни кто не поможет
 
Ответить
СообщениеВы бы хоть в примере помимо пояснения набросали данные (значения) пример что ли. Пустые ячейки с заголовками столбцов и строк + пояснение И ВСЕ (((( так вам тут ни кто не поможет

Автор - lebensvoll
Дата добавления - 11.05.2016 в 11:07
troi37 Дата: Среда, 11.05.2016, 11:12 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
китин, Спасибо за ответ. Сейчас опробую. Неожиданно быстро! Еще раз спасибо!


Сообщение отредактировал troi37 - Среда, 11.05.2016, 11:12
 
Ответить
Сообщениекитин, Спасибо за ответ. Сейчас опробую. Неожиданно быстро! Еще раз спасибо!

Автор - troi37
Дата добавления - 11.05.2016 в 11:12
troi37 Дата: Среда, 11.05.2016, 12:18 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
И небольшой вопросик. Вот при использовании формулы, указанной для решения данной проблемы, достаточно сильно будет нагрузка на ПК? Потому что при использовании VLOOKUP3, для решения этой проблемы ПК вообще вылетает. ( в таблице более 300 столбцов и 1000 строк)
 
Ответить
СообщениеИ небольшой вопросик. Вот при использовании формулы, указанной для решения данной проблемы, достаточно сильно будет нагрузка на ПК? Потому что при использовании VLOOKUP3, для решения этой проблемы ПК вообще вылетает. ( в таблице более 300 столбцов и 1000 строк)

Автор - troi37
Дата добавления - 11.05.2016 в 12:18
китин Дата: Среда, 11.05.2016, 12:21 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
в таблице более 300 столбцов и 1000 строк

тормозить будет жутко


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
в таблице более 300 столбцов и 1000 строк

тормозить будет жутко

Автор - китин
Дата добавления - 11.05.2016 в 12:21
troi37 Дата: Среда, 11.05.2016, 12:28 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Можно сделать копирование ячейки, через определенный интервал строк? ( интервал постоянен), как бы вот так например в ячейку С9 копируется с Лист2С2 и дальше просто с шагом 6 строк?
 
Ответить
СообщениеМожно сделать копирование ячейки, через определенный интервал строк? ( интервал постоянен), как бы вот так например в ячейку С9 копируется с Лист2С2 и дальше просто с шагом 6 строк?

Автор - troi37
Дата добавления - 11.05.2016 в 12:28
Manyasha Дата: Среда, 11.05.2016, 12:39 | Сообщение № 8
Группа: Модераторы
Ранг: Старожил
Сообщений: 1589
Репутация: 669 ±
Замечаний: 0% ±

Excel 2007, 2010
troi37, тогда можно так
Код
=ИНДЕКС(Лист2!$C$2:$C$18;ПОИСКПОЗ(C$8;Лист2!$D$2:$D$18;0)+6*(СТРОКА(A1)-1))
К сообщению приложен файл: 5646613-2.xlsx(11Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
Сообщениеtroi37, тогда можно так
Код
=ИНДЕКС(Лист2!$C$2:$C$18;ПОИСКПОЗ(C$8;Лист2!$D$2:$D$18;0)+6*(СТРОКА(A1)-1))

Автор - Manyasha
Дата добавления - 11.05.2016 в 12:39
troi37 Дата: Среда, 11.05.2016, 12:52 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Manyasha, спасибо!
 
Ответить
СообщениеManyasha, спасибо!

Автор - troi37
Дата добавления - 11.05.2016 в 12:52
_Boroda_ Дата: Среда, 11.05.2016, 13:14 | Сообщение № 10
Группа: Модераторы
Ранг: Экселист
Сообщений: 9377
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Более того, если расположение текста в обоих листах по порядку одинаково (прогул-работа-половина дня-...), то можно так
Код
=ИНДЕКС(Лист2!$C$2:$C$18;СТОЛБЕЦ(A9)+6*(СТРОКА(A1)-1))
К сообщению приложен файл: 5646613-2_1.xlsx(11Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеБолее того, если расположение текста в обоих листах по порядку одинаково (прогул-работа-половина дня-...), то можно так
Код
=ИНДЕКС(Лист2!$C$2:$C$18;СТОЛБЕЦ(A9)+6*(СТРОКА(A1)-1))

Автор - _Boroda_
Дата добавления - 11.05.2016 в 13:14
troi37 Дата: Среда, 11.05.2016, 13:16 | Сообщение № 11
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Огромное спасибо ВСЕМ! Проблема решена! specool respect


Сообщение отредактировал troi37 - Среда, 11.05.2016, 13:19
 
Ответить
СообщениеОгромное спасибо ВСЕМ! Проблема решена! specool respect

Автор - troi37
Дата добавления - 11.05.2016 в 13:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Копирование ячеек с заданным интервалом строк с другог листа (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!