Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Округление числа - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Округление числа (Формулы/Formulas)
Округление числа
andron359 Дата: Суббота, 14.05.2016, 16:43 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 75
Репутация: 0 ±
Замечаний: 0% ±

Добрый день, суть проблемы в том , что почему то не находит данных в формуле ОКРВНИЗ на некоторых значениях , не понимаю ничего , где ошибка ?
К сообщению приложен файл: _Microsoft_Exce.xlsx(10Kb)
 
Ответить
СообщениеДобрый день, суть проблемы в том , что почему то не находит данных в формуле ОКРВНИЗ на некоторых значениях , не понимаю ничего , где ошибка ?

Автор - andron359
Дата добавления - 14.05.2016 в 16:43
Nic70y Дата: Суббота, 14.05.2016, 16:53 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3918
Репутация: 829 ±
Замечаний: 0% ±

Excel 2013
Код
=ОКРУГЛВНИЗ(B3;3)
устроит?


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=ОКРУГЛВНИЗ(B3;3)
устроит?

Автор - Nic70y
Дата добавления - 14.05.2016 в 16:53
andron359 Дата: Суббота, 14.05.2016, 17:24 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 75
Репутация: 0 ±
Замечаний: 0% ±

НЕ , так не получается, мне нужно чтобы было округление до 0,3 ; 0.00/0.3/006/0.9/1.2/1.5/1.8
т.е. если в ячейке B3=0.5 то в С3 должно быть 0,3 если в В3=0,2 то в С3 должно быть 0,0
 
Ответить
СообщениеНЕ , так не получается, мне нужно чтобы было округление до 0,3 ; 0.00/0.3/006/0.9/1.2/1.5/1.8
т.е. если в ячейке B3=0.5 то в С3 должно быть 0,3 если в В3=0,2 то в С3 должно быть 0,0

Автор - andron359
Дата добавления - 14.05.2016 в 17:24
Pelena Дата: Суббота, 14.05.2016, 18:22 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11007
Репутация: 2459 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
А так?
Код
=ВПР(ОКРУГЛ($C$3;3);$A$7:$K$14;2;ЛОЖЬ)

или в С3 изменить формулу
Код
=ОКРУГЛ(ОКРВНИЗ(B3;0,3);3)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеА так?
Код
=ВПР(ОКРУГЛ($C$3;3);$A$7:$K$14;2;ЛОЖЬ)

или в С3 изменить формулу
Код
=ОКРУГЛ(ОКРВНИЗ(B3;0,3);3)

Автор - Pelena
Дата добавления - 14.05.2016 в 18:22
andron359 Дата: Суббота, 14.05.2016, 18:58 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 75
Репутация: 0 ±
Замечаний: 0% ±

Pelena , почти получилось , всё правильно считает ,но когда в ячейке B3=0,3 то в С3 должно быть тоже 0,3 , а не 0,0
а всё другое считает .
 
Ответить
СообщениеPelena , почти получилось , всё правильно считает ,но когда в ячейке B3=0,3 то в С3 должно быть тоже 0,3 , а не 0,0
а всё другое считает .

Автор - andron359
Дата добавления - 14.05.2016 в 18:58
Pelena Дата: Суббота, 14.05.2016, 19:25 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11007
Репутация: 2459 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Ну, округлите ещё в В3
Код
=ОКРУГЛ(B2-B1;3)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеНу, округлите ещё в В3
Код
=ОКРУГЛ(B2-B1;3)

Автор - Pelena
Дата добавления - 14.05.2016 в 19:25
jakim Дата: Суббота, 14.05.2016, 21:58 | Сообщение № 7
Группа: Друзья
Ранг: Ветеран
Сообщений: 763
Репутация: 196 ±
Замечаний: 0% ±

Если правильно понял, то можно сделать так.
К сообщению приложен файл: of-Microsoft_Ex.xlsx(10Kb)
 
Ответить
СообщениеЕсли правильно понял, то можно сделать так.

Автор - jakim
Дата добавления - 14.05.2016 в 21:58
AlexM Дата: Суббота, 14.05.2016, 22:12 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 874 ±
Замечаний: 0% ±

Формула для С3
Код
=ОКРВНИЗ(B3*10;3)/10


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеФормула для С3
Код
=ОКРВНИЗ(B3*10;3)/10

Автор - AlexM
Дата добавления - 14.05.2016 в 22:12
andron359 Дата: Воскресенье, 15.05.2016, 00:46 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 75
Репутация: 0 ±
Замечаний: 0% ±

Спасибо друзья за помощь , всё получилось , Pelena ,AlexM благодарю !!!!!!!! hands
 
Ответить
СообщениеСпасибо друзья за помощь , всё получилось , Pelena ,AlexM благодарю !!!!!!!! hands

Автор - andron359
Дата добавления - 15.05.2016 в 00:46
AlexM Дата: Воскресенье, 15.05.2016, 09:39 | Сообщение № 10
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 874 ±
Замечаний: 0% ±

Так лучше
Код
=ОКРВНИЗ(ОТБР(B3*10);3)/10


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеТак лучше
Код
=ОКРВНИЗ(ОТБР(B3*10);3)/10

Автор - AlexM
Дата добавления - 15.05.2016 в 09:39
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Округление числа (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!