Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сколько мероприятий на определенный период - Страница 2 - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 2 из 2«12
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сколько мероприятий на определенный период (Формулы/Formulas)
Сколько мероприятий на определенный период
mostinger Дата: Среда, 18.05.2016, 12:01 | Сообщение № 21
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Модератор:
Что не вышло в файле Руслана?

G3 и G10 показывают общее количество в текущем месяце, т.е. они равны друг другу. ТРЕБУЕТСЯ чтобы G3 показывал только прошедшие в этом месяце, а G10 предстоящие в этом месяце.
Таким образом в текущем месяце мероприятий = G3+G6+G10.
[moder]А Вам не кажется, что было бы значительно проще, если бы Вы вручную заполнили прямо в файле все нужные ячейки нужными числами?


Сообщение отредактировал _Boroda_ - Среда, 18.05.2016, 12:19
 
Ответить
Сообщение
Модератор:
Что не вышло в файле Руслана?

G3 и G10 показывают общее количество в текущем месяце, т.е. они равны друг другу. ТРЕБУЕТСЯ чтобы G3 показывал только прошедшие в этом месяце, а G10 предстоящие в этом месяце.
Таким образом в текущем месяце мероприятий = G3+G6+G10.
[moder]А Вам не кажется, что было бы значительно проще, если бы Вы вручную заполнили прямо в файле все нужные ячейки нужными числами?

Автор - mostinger
Дата добавления - 18.05.2016 в 12:01
mostinger Дата: Среда, 18.05.2016, 12:49 | Сообщение № 22
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Код
[code]=_xlfn.COUNTIFS(A1:A30;"<"&СЕГОДНЯ();A1:A30;">"&КОНМЕСЯЦА(СЕГОДНЯ();-1))
[/code] выдает #имя?

У меня 2003


Сообщение отредактировал mostinger - Среда, 18.05.2016, 12:52
 
Ответить
Сообщение
Код
[code]=_xlfn.COUNTIFS(A1:A30;"<"&СЕГОДНЯ();A1:A30;">"&КОНМЕСЯЦА(СЕГОДНЯ();-1))
[/code] выдает #имя?

У меня 2003

Автор - mostinger
Дата добавления - 18.05.2016 в 12:49
Russel Дата: Среда, 18.05.2016, 15:42 | Сообщение № 23
Группа: Друзья
Ранг: Старожил
Сообщений: 1252
Репутация: 284 ±
Замечаний: 0% ±

Excel 2010
mostinger, Мои формулы в столбце Н (большие красные цифры).
Для G3:
Код
=СУММПРОИЗВ((A1:A30<СЕГОДНЯ())*(A1:A30>СЕГОДНЯ()-ДЕНЬ(СЕГОДНЯ())))

Для G4:
Код
=СУММПРОИЗВ((A1:A30<СЕГОДНЯ())*(A1:A30>СЕГОДНЯ()-ДЕНЬНЕД(СЕГОДНЯ();2)))

Для G9:
Код
=СУММПРОИЗВ((A1:A30>СЕГОДНЯ())*(A1:A30<СЕГОДНЯ()+8-ДЕНЬНЕД(СЕГОДНЯ();2)))

Для G10:
Код
=СУММПРОИЗВ((A1:A30>СЕГОДНЯ())*(A1:A30<ДАТА(ГОД(СЕГОДНЯ());МЕСЯЦ(СЕГОДНЯ())+1;1)))


PS Вроде все должно работать в 2003м


QIWI 9173973973

Сообщение отредактировал Russel - Среда, 18.05.2016, 15:43
 
Ответить
Сообщениеmostinger, Мои формулы в столбце Н (большие красные цифры).
Для G3:
Код
=СУММПРОИЗВ((A1:A30<СЕГОДНЯ())*(A1:A30>СЕГОДНЯ()-ДЕНЬ(СЕГОДНЯ())))

Для G4:
Код
=СУММПРОИЗВ((A1:A30<СЕГОДНЯ())*(A1:A30>СЕГОДНЯ()-ДЕНЬНЕД(СЕГОДНЯ();2)))

Для G9:
Код
=СУММПРОИЗВ((A1:A30>СЕГОДНЯ())*(A1:A30<СЕГОДНЯ()+8-ДЕНЬНЕД(СЕГОДНЯ();2)))

Для G10:
Код
=СУММПРОИЗВ((A1:A30>СЕГОДНЯ())*(A1:A30<ДАТА(ГОД(СЕГОДНЯ());МЕСЯЦ(СЕГОДНЯ())+1;1)))


PS Вроде все должно работать в 2003м

Автор - Russel
Дата добавления - 18.05.2016 в 15:42
mostinger Дата: Четверг, 19.05.2016, 14:14 | Сообщение № 24
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
ребята ВСЕ МОЛОДЦЫ!!! красава... спасибо!
 
Ответить
Сообщениеребята ВСЕ МОЛОДЦЫ!!! красава... спасибо!

Автор - mostinger
Дата добавления - 19.05.2016 в 14:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сколько мероприятий на определенный период (Формулы/Formulas)
Страница 2 из 2«12
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!