Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сколько мероприятий на определенный период - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 212»
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сколько мероприятий на определенный период (Формулы/Formulas)
Сколько мероприятий на определенный период
mostinger Дата: Понедельник, 16.05.2016, 10:37 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
есть список мероприятий с датами, нужно вычислить сколько прошло относительно СЕГОДНЯ, и сколько НАМЕЧАЕТСЯ относительно сегодня.

количество мероприятий на сегодня нашел выход =
Код
СЧЁТЕСЛИ(диапозон;СЕГОДНЯ())
pray
К сообщению приложен файл: 5101956.xls(28Kb)


Сообщение отредактировал _Boroda_ - Понедельник, 16.05.2016, 12:20
 
Ответить
Сообщениеесть список мероприятий с датами, нужно вычислить сколько прошло относительно СЕГОДНЯ, и сколько НАМЕЧАЕТСЯ относительно сегодня.

количество мероприятий на сегодня нашел выход =
Код
СЧЁТЕСЛИ(диапозон;СЕГОДНЯ())
pray

Автор - mostinger
Дата добавления - 16.05.2016 в 10:37
buchlotnik Дата: Понедельник, 16.05.2016, 10:41 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
mostinger, чем капсом писать лучше бы правила почитали - название темы должно отражать суть задачи и где файл с примером?


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениеmostinger, чем капсом писать лучше бы правила почитали - название темы должно отражать суть задачи и где файл с примером?

Автор - buchlotnik
Дата добавления - 16.05.2016 в 10:41
mostinger Дата: Понедельник, 16.05.2016, 10:42 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Код
=СЧЁТЕСЛИ(диапозон;СЕГОДНЯ())

мне нужно что то вроде
Код
=СЧЁТЕСЛИ(диапозон;">СЕГОДНЯ")

Код
=СЧЁТЕСЛИ(диапозон;"<СЕГОДНЯ")

но эти формулы не работают
[moder]Оформите формулы тегами (в режиме правки выделить и нажать кнопку fx)[/moder]


Сообщение отредактировал _Boroda_ - Понедельник, 16.05.2016, 12:20
 
Ответить
Сообщение
Код
=СЧЁТЕСЛИ(диапозон;СЕГОДНЯ())

мне нужно что то вроде
Код
=СЧЁТЕСЛИ(диапозон;">СЕГОДНЯ")

Код
=СЧЁТЕСЛИ(диапозон;"<СЕГОДНЯ")

но эти формулы не работают
[moder]Оформите формулы тегами (в режиме правки выделить и нажать кнопку fx)[/moder]

Автор - mostinger
Дата добавления - 16.05.2016 в 10:42
mostinger Дата: Понедельник, 16.05.2016, 10:43 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
пример
[moder]Причем ВСЕ формулы. И в первом посте тоже.
У нас тут с Правилами строго, поэтому почитайте их, это недолго -
http://www.excelworld.ru/forum/2-20-1
К сообщению приложен файл: 6410451.xls(28Kb)


Сообщение отредактировал _Boroda_ - Понедельник, 16.05.2016, 10:47
 
Ответить
Сообщениепример
[moder]Причем ВСЕ формулы. И в первом посте тоже.
У нас тут с Правилами строго, поэтому почитайте их, это недолго -
http://www.excelworld.ru/forum/2-20-1

Автор - mostinger
Дата добавления - 16.05.2016 в 10:43
mostinger Дата: Понедельник, 16.05.2016, 10:45 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
я очень извиняюсь, просто уже пару дней не могу найти ответ...
меня уже начальство напрягает этой задачкой...
[moder]Да там элементарно всё. Просто оформите свои посты согласно Правилам форума (в посте 3 написано как) и через минуту у Вас будет решение.


Сообщение отредактировал _Boroda_ - Понедельник, 16.05.2016, 10:50
 
Ответить
Сообщениея очень извиняюсь, просто уже пару дней не могу найти ответ...
меня уже начальство напрягает этой задачкой...
[moder]Да там элементарно всё. Просто оформите свои посты согласно Правилам форума (в посте 3 написано как) и через минуту у Вас будет решение.

Автор - mostinger
Дата добавления - 16.05.2016 в 10:45
buchlotnik Дата: Понедельник, 16.05.2016, 10:46 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
удалено администрацией
жаль...
[moder]А мне-то как жаль! Похоже, что из этой темы кто-то вынес только один вывод - что наказывать не будут.


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал _Boroda_ - Понедельник, 16.05.2016, 11:13
 
Ответить
Сообщениеудалено администрацией
жаль...
[moder]А мне-то как жаль! Похоже, что из этой темы кто-то вынес только один вывод - что наказывать не будут.

Автор - buchlotnik
Дата добавления - 16.05.2016 в 10:46
mostinger Дата: Понедельник, 16.05.2016, 10:49 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
а как на счет помесячного отчета?
 
Ответить
Сообщениеа как на счет помесячного отчета?

Автор - mostinger
Дата добавления - 16.05.2016 в 10:49
AlexM Дата: Понедельник, 16.05.2016, 11:11 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3053
Репутация: 740 ±
Замечаний: 0% ±

[offtop]На форуме не хватает светофора. Модератор делает замечание и включает красный. Нарушение исправлено - включает зеленый.
[moder]А кстати - прекрасная мысль. Правда, не уверен, что легко реализуемая технически. Но это к админам.[/moder]
[offtop]Для простоты реализации зеленным сигналом может быть сообщение модератора об устранении нарушения в том же поле, где писалось замечание.


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Понедельник, 16.05.2016, 12:00
 
Ответить
Сообщение[offtop]На форуме не хватает светофора. Модератор делает замечание и включает красный. Нарушение исправлено - включает зеленый.
[moder]А кстати - прекрасная мысль. Правда, не уверен, что легко реализуемая технически. Но это к админам.[/moder]
[offtop]Для простоты реализации зеленным сигналом может быть сообщение модератора об устранении нарушения в том же поле, где писалось замечание.

Автор - AlexM
Дата добавления - 16.05.2016 в 11:11
mostinger Дата: Понедельник, 16.05.2016, 12:10 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
AlexM, исправил тему, так правильно?
[moder]Нет, не правильно. Я сейчас Вам поправлю на первый раз, а Вы посмотрите принцип


Сообщение отредактировал _Boroda_ - Понедельник, 16.05.2016, 12:19
 
Ответить
СообщениеAlexM, исправил тему, так правильно?
[moder]Нет, не правильно. Я сейчас Вам поправлю на первый раз, а Вы посмотрите принцип

Автор - mostinger
Дата добавления - 16.05.2016 в 12:10
mostinger Дата: Понедельник, 16.05.2016, 12:17 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
buchlotnik, можно ли подсчитать это же но относительно текущего месяца,
 
Ответить
Сообщениеbuchlotnik, можно ли подсчитать это же но относительно текущего месяца,

Автор - mostinger
Дата добавления - 16.05.2016 в 12:17
buchlotnik Дата: Понедельник, 16.05.2016, 12:19 | Сообщение № 11
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
mostinger, можно:
Код
=СУММПРОИЗВ(--(ТЕКСТ(СЕГОДНЯ();"ММГГ")=ТЕКСТ(A1:A12;"ММГГ")))
К сообщению приложен файл: 7105222.xls(24Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Понедельник, 16.05.2016, 12:27
 
Ответить
Сообщениеmostinger, можно:
Код
=СУММПРОИЗВ(--(ТЕКСТ(СЕГОДНЯ();"ММГГ")=ТЕКСТ(A1:A12;"ММГГ")))

Автор - buchlotnik
Дата добавления - 16.05.2016 в 12:19
_Boroda_ Дата: Понедельник, 16.05.2016, 12:37 | Сообщение № 12
Группа: Модераторы
Ранг: Экселист
Сообщений: 9374
Репутация: 3947 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
За месяц у меня аналогично (только буквы "МГ"), а за неделю вариант такой для 2003 Excel
Код
=СУММПРОИЗВ(--ТЕКСТ(A1:A12-СЕГОДНЯ()-ДЕНЬНЕД(СЕГОДНЯ();2)+1;"[<0]\0;[<7]1;\0"))
К сообщению приложен файл: 6410451_1.xls(25Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЗа месяц у меня аналогично (только буквы "МГ"), а за неделю вариант такой для 2003 Excel
Код
=СУММПРОИЗВ(--ТЕКСТ(A1:A12-СЕГОДНЯ()-ДЕНЬНЕД(СЕГОДНЯ();2)+1;"[<0]\0;[<7]1;\0"))

Автор - _Boroda_
Дата добавления - 16.05.2016 в 12:37
mostinger Дата: Вторник, 17.05.2016, 15:59 | Сообщение № 13
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
РЕБЯТА огромное спасибо за помощь.

теперь нужна более усложненная версия пример ниже
К сообщению приложен файл: 6763763.xls(26Kb)
 
Ответить
СообщениеРЕБЯТА огромное спасибо за помощь.

теперь нужна более усложненная версия пример ниже

Автор - mostinger
Дата добавления - 17.05.2016 в 15:59
mostinger Дата: Вторник, 17.05.2016, 16:00 | Сообщение № 14
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
_Boroda_, все круто, вот только неделю берет относительно "сегодня" т.е. со среды до среды, а нужно от ПН до ВС...
 
Ответить
Сообщение_Boroda_, все круто, вот только неделю берет относительно "сегодня" т.е. со среды до среды, а нужно от ПН до ВС...

Автор - mostinger
Дата добавления - 17.05.2016 в 16:00
_Boroda_ Дата: Вторник, 17.05.2016, 16:19 | Сообщение № 15
Группа: Модераторы
Ранг: Экселист
Сообщений: 9374
Репутация: 3947 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
вот только неделю берет относительно "сегодня" т

Ну да, знаки перепутал. Вот так нужно
Код
=СУММПРОИЗВ(--ТЕКСТ(A1:A12-СЕГОДНЯ()+ДЕНЬНЕД(СЕГОДНЯ();2)-1;"[<0]\0;[<7]1;\0"))

С остальным потом. Если время будет.
К сообщению приложен файл: 6410451_2.xls(25Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
вот только неделю берет относительно "сегодня" т

Ну да, знаки перепутал. Вот так нужно
Код
=СУММПРОИЗВ(--ТЕКСТ(A1:A12-СЕГОДНЯ()+ДЕНЬНЕД(СЕГОДНЯ();2)-1;"[<0]\0;[<7]1;\0"))

С остальным потом. Если время будет.

Автор - _Boroda_
Дата добавления - 17.05.2016 в 16:19
mostinger Дата: Вторник, 17.05.2016, 17:50 | Сообщение № 16
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
пример
К сообщению приложен файл: 6982569.xls(32Kb)
 
Ответить
Сообщениепример

Автор - mostinger
Дата добавления - 17.05.2016 в 17:50
Russel Дата: Вторник, 17.05.2016, 18:37 | Сообщение № 17
Группа: Друзья
Ранг: Старожил
Сообщений: 1252
Репутация: 284 ±
Замечаний: 0% ±

Excel 2010
Как вариант
К сообщению приложен файл: 4666896.xls(32Kb)


QIWI 9173973973
 
Ответить
СообщениеКак вариант

Автор - Russel
Дата добавления - 17.05.2016 в 18:37
mostinger Дата: Среда, 18.05.2016, 07:10 | Сообщение № 18
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Russel, неа, не вышло. блин тут что то вроде календаря нужно...
 
Ответить
СообщениеRussel, неа, не вышло. блин тут что то вроде календаря нужно...

Автор - mostinger
Дата добавления - 18.05.2016 в 07:10
Russel Дата: Среда, 18.05.2016, 07:51 | Сообщение № 19
Группа: Друзья
Ранг: Старожил
Сообщений: 1252
Репутация: 284 ±
Замечаний: 0% ±

Excel 2010
mostinger, что именно не вышло?
Для простоты решения задачи создайте дополнительные столбцы Неделя, Месяц, Год. Тогда все подсчеты будет легко делать элементарным СУММПРОИЗВ.


QIWI 9173973973
 
Ответить
Сообщениеmostinger, что именно не вышло?
Для простоты решения задачи создайте дополнительные столбцы Неделя, Месяц, Год. Тогда все подсчеты будет легко делать элементарным СУММПРОИЗВ.

Автор - Russel
Дата добавления - 18.05.2016 в 07:51
mostinger Дата: Среда, 18.05.2016, 10:06 | Сообщение № 20
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Russel, ну я на примере показал, так же в файле точно указал
[moder]Что не вышло в файле Руслана?


Сообщение отредактировал _Boroda_ - Среда, 18.05.2016, 10:10
 
Ответить
СообщениеRussel, ну я на примере показал, так же в файле точно указал
[moder]Что не вышло в файле Руслана?

Автор - mostinger
Дата добавления - 18.05.2016 в 10:06
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сколько мероприятий на определенный период (Формулы/Formulas)
Страница 1 из 212»
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!