Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Найти артикулы и подставит цену в списке из ключевых фраз - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти артикулы и подставит цену в списке из ключевых фраз (Формулы/Formulas)
Найти артикулы и подставит цену в списке из ключевых фраз
goloburdov Дата: Понедельник, 16.05.2016, 15:04 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Дано:
1. ключевые фразы, во многих из них есть артикулы.
2. список артикулов и стоимсоть товара с этим артикулом
Что нужно сделать:
справа от ключевой фразы поставить цену этого товара, если артикул есть в ней.

Проблема: нельзя отсортировать по артикулу, если бы можно было - то формулой
Код
=ЕСЛИ(И(ЕОШ(НАЙТИ(B3;A3)));0;C3)

можно было решить эту проблему.

Прикрепил пример
К сообщению приложен файл: 8145529.xlsx(10Kb)
 
Ответить
СообщениеДано:
1. ключевые фразы, во многих из них есть артикулы.
2. список артикулов и стоимсоть товара с этим артикулом
Что нужно сделать:
справа от ключевой фразы поставить цену этого товара, если артикул есть в ней.

Проблема: нельзя отсортировать по артикулу, если бы можно было - то формулой
Код
=ЕСЛИ(И(ЕОШ(НАЙТИ(B3;A3)));0;C3)

можно было решить эту проблему.

Прикрепил пример

Автор - goloburdov
Дата добавления - 16.05.2016 в 15:04
Pelena Дата: Понедельник, 16.05.2016, 15:13 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9873
Репутация: 2263 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
И Вам здравствуйте.
Например, так можно
Код
=ЕСЛИОШИБКА(ПРОСМОТР(9^9;НАЙТИ($B$2:$B$5;A2);$C$2:$C$5);"-")
К сообщению приложен файл: 8238694.xlsx(10Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеИ Вам здравствуйте.
Например, так можно
Код
=ЕСЛИОШИБКА(ПРОСМОТР(9^9;НАЙТИ($B$2:$B$5;A2);$C$2:$C$5);"-")

Автор - Pelena
Дата добавления - 16.05.2016 в 15:13
goloburdov Дата: Вторник, 17.05.2016, 12:20 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
=ЕСЛИОШИБКА(ПРОСМОТР(9^9;НАЙТИ($B$2:$B$5;A2);$C$2:$C$5);"-")

Спасибо огромное, помогло :)
 
Ответить
Сообщение
=ЕСЛИОШИБКА(ПРОСМОТР(9^9;НАЙТИ($B$2:$B$5;A2);$C$2:$C$5);"-")

Спасибо огромное, помогло :)

Автор - goloburdov
Дата добавления - 17.05.2016 в 12:20
goloburdov Дата: Суббота, 27.08.2016, 11:51 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Pelena, ещё одна похожая задачка появилась:
есть 2 столбца со значениями
В столбце A 10000 значений от 1 до 10000 по порядку
В столбце B 3000 значений от 1 до 10000 в разнобой (т.е. всего 1/3 значений от столбца A)
В столбец C1 нужно написать формулу, которая будет проверять: если значение в A1 есть в ячейках B1:B3000, тогда написать "да", а если нет, то "нет"
Ну и что бы эту формулу растянуть можно было
 
Ответить
СообщениеPelena, ещё одна похожая задачка появилась:
есть 2 столбца со значениями
В столбце A 10000 значений от 1 до 10000 по порядку
В столбце B 3000 значений от 1 до 10000 в разнобой (т.е. всего 1/3 значений от столбца A)
В столбец C1 нужно написать формулу, которая будет проверять: если значение в A1 есть в ячейках B1:B3000, тогда написать "да", а если нет, то "нет"
Ну и что бы эту формулу растянуть можно было

Автор - goloburdov
Дата добавления - 27.08.2016 в 11:51
Pelena Дата: Суббота, 27.08.2016, 11:57 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9873
Репутация: 2263 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Используйте СЧЁТЕСЛИ().
Если не получится, создайте новую тему, т.к к артикулам и ценам этот вопрос отношения не имеет


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеИспользуйте СЧЁТЕСЛИ().
Если не получится, создайте новую тему, т.к к артикулам и ценам этот вопрос отношения не имеет

Автор - Pelena
Дата добавления - 27.08.2016 в 11:57
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти артикулы и подставит цену в списке из ключевых фраз (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!