Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автосуммирование в зависимости от - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автосуммирование в зависимости от (Формулы/Formulas)
Автосуммирование в зависимости от
Arkanzas Дата: Понедельник, 16.05.2016, 20:11 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
Очень хочу облегчить себе повседневную жизнь на рабочем месте, для этого мне нужна помощь профессионала., сам не справлюсь.
Еденевно сталкиваюсь с задачей отмечать монтаж элементов, а именно балок и накладок к этим балкам, трудность в том, что разновидностей балок много, а вот накладок несколько типов и они монтируются с каждым типом балок но в разном количестве к каждой балке (Итальянский проект, ничего типового, мы тут все стонем от них, от итальянцев и от их методики проектирования и работы, но это лирика)
В общем я задумал такую хитрую штуку, чтобы я ставил количество балок (пример во вложении) а напротив накладок автоматически выводилось их количество соответствующее каджой конкретной балке в виде общей суммы.
Надеюсь в примере все будет понятно.
Я пробовал смотреть примеры по функции ИНДЕКС + ПОИСКПОЗ, это удобно, но в моем случае эту комбинацию нужно еще надстроить какими-нибудь интересными функциями, с которыми я еще не знаком, но надеюсь с Вашей помощью познакомлюсь.
Заранее благодарю за уделенное мне время и надеюсь на Вашу помощь
К сообщению приложен файл: 4835526.xlsx(12Kb)


Сообщение отредактировал Arkanzas - Понедельник, 16.05.2016, 20:15
 
Ответить
СообщениеДобрый день!
Очень хочу облегчить себе повседневную жизнь на рабочем месте, для этого мне нужна помощь профессионала., сам не справлюсь.
Еденевно сталкиваюсь с задачей отмечать монтаж элементов, а именно балок и накладок к этим балкам, трудность в том, что разновидностей балок много, а вот накладок несколько типов и они монтируются с каждым типом балок но в разном количестве к каждой балке (Итальянский проект, ничего типового, мы тут все стонем от них, от итальянцев и от их методики проектирования и работы, но это лирика)
В общем я задумал такую хитрую штуку, чтобы я ставил количество балок (пример во вложении) а напротив накладок автоматически выводилось их количество соответствующее каджой конкретной балке в виде общей суммы.
Надеюсь в примере все будет понятно.
Я пробовал смотреть примеры по функции ИНДЕКС + ПОИСКПОЗ, это удобно, но в моем случае эту комбинацию нужно еще надстроить какими-нибудь интересными функциями, с которыми я еще не знаком, но надеюсь с Вашей помощью познакомлюсь.
Заранее благодарю за уделенное мне время и надеюсь на Вашу помощь

Автор - Arkanzas
Дата добавления - 16.05.2016 в 20:11
Nic70y Дата: Понедельник, 16.05.2016, 21:24 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3483
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Не очень понятно, что Вы хотите.
Может это?
Код
=СУММПРОИЗВ(ИНДЕКС(I$7:N$16;;ПОИСКПОЗ(A16;I$6:N$6;));B$6:B$15)
К сообщению приложен файл: 4619266.xlsx(12Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
СообщениеНе очень понятно, что Вы хотите.
Может это?
Код
=СУММПРОИЗВ(ИНДЕКС(I$7:N$16;;ПОИСКПОЗ(A16;I$6:N$6;));B$6:B$15)

Автор - Nic70y
Дата добавления - 16.05.2016 в 21:24
gling Дата: Понедельник, 16.05.2016, 22:19 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1351
Репутация: 325 ±
Замечаний: 0% ±

2010
[offtop]
Не очень понятно, что Вы хотите.
Очень хочу облегчить себе повседневную жизнь
[/offtop]
Может это надо, для облегчения?
Код
=СУММПРОИЗВ(ИНДЕКС($I$7:$N$16;;СТРОКА(A1))*($C$6:$C$15>0)*C6:C15)
К сообщению приложен файл: 1684365.xlsx(13Kb)


Сообщение отредактировал gling - Понедельник, 16.05.2016, 23:12
 
Ответить
Сообщение[offtop]
Не очень понятно, что Вы хотите.
Очень хочу облегчить себе повседневную жизнь
[/offtop]
Может это надо, для облегчения?
Код
=СУММПРОИЗВ(ИНДЕКС($I$7:$N$16;;СТРОКА(A1))*($C$6:$C$15>0)*C6:C15)

Автор - gling
Дата добавления - 16.05.2016 в 22:19
Arkanzas Дата: Вторник, 17.05.2016, 14:48 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо, Ваш ответ близок к сути)
Не очень понятно, что Вы хотите.


Суть такая - Например я ввел, что смонтировали наименование: "Балка1" - 1шт (столбец "С") и напротив накладок, соответсвующих ей, появилось их количество из "таблицы исходных данных" и далее, когда я ввел, что смонтировали наименование "балка3", к уже имеющимуся кол-ву накладок прибавилось количество накладок, соответствующих "балке3" и т.д.
Спасибо за внимание, надеюсь, что объяснил понятнее=)
 
Ответить
СообщениеСпасибо, Ваш ответ близок к сути)
Не очень понятно, что Вы хотите.


Суть такая - Например я ввел, что смонтировали наименование: "Балка1" - 1шт (столбец "С") и напротив накладок, соответсвующих ей, появилось их количество из "таблицы исходных данных" и далее, когда я ввел, что смонтировали наименование "балка3", к уже имеющимуся кол-ву накладок прибавилось количество накладок, соответствующих "балке3" и т.д.
Спасибо за внимание, надеюсь, что объяснил понятнее=)

Автор - Arkanzas
Дата добавления - 17.05.2016 в 14:48
gling Дата: Вторник, 17.05.2016, 21:14 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1351
Репутация: 325 ±
Замечаний: 0% ±

2010
Да опять чуть не досмотрел не закрепил диапазон C6:C15 надо так
Код
=СУММПРОИЗВ(ИНДЕКС($I$7:$N$16;;СТРОКА(A1))*($C$6:$C$15>0)*$C$6:$C$15)
Поленился всё пересчитывать, если был бы пример с ответом, типа должно быть так, то ошибку заметил бы раньше. А так первое значение проверил и подумал что все дальше тоже правильно. Честно сказать и сейчас все накладки не пересчитывал, проверяйте.
К сообщению приложен файл: 1307909.xlsx(13Kb)


Сообщение отредактировал gling - Вторник, 17.05.2016, 21:23
 
Ответить
СообщениеДа опять чуть не досмотрел не закрепил диапазон C6:C15 надо так
Код
=СУММПРОИЗВ(ИНДЕКС($I$7:$N$16;;СТРОКА(A1))*($C$6:$C$15>0)*$C$6:$C$15)
Поленился всё пересчитывать, если был бы пример с ответом, типа должно быть так, то ошибку заметил бы раньше. А так первое значение проверил и подумал что все дальше тоже правильно. Честно сказать и сейчас все накладки не пересчитывал, проверяйте.

Автор - gling
Дата добавления - 17.05.2016 в 21:14
Arkanzas Дата: Среда, 18.05.2016, 17:48 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
gling, gling,
надо так

Все работает, надеюсь в будущем проблем не возникнет. Большое спасибо
У меня есть вытекающий вопрос, не могли бы вы пояснить данную формулу, что для чего служит?)
 
Ответить
Сообщениеgling, gling,
надо так

Все работает, надеюсь в будущем проблем не возникнет. Большое спасибо
У меня есть вытекающий вопрос, не могли бы вы пояснить данную формулу, что для чего служит?)

Автор - Arkanzas
Дата добавления - 18.05.2016 в 17:48
_Boroda_ Дата: Среда, 18.05.2016, 17:57 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9374
Репутация: 3947 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант формулы
Код
=СУММПРОИЗВ(C$6:C$15*I$7:N$16*(I$6:N$6=A16))

И чуть переделанная формула Владимира
Код
=СУММПРОИЗВ(ИНДЕКС($I$7:$N$16;;СТРОКА(A1))*$C$6:$C$15)
К сообщению приложен файл: 1307909_1.xlsx(13Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант формулы
Код
=СУММПРОИЗВ(C$6:C$15*I$7:N$16*(I$6:N$6=A16))

И чуть переделанная формула Владимира
Код
=СУММПРОИЗВ(ИНДЕКС($I$7:$N$16;;СТРОКА(A1))*$C$6:$C$15)

Автор - _Boroda_
Дата добавления - 18.05.2016 в 17:57
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автосуммирование в зависимости от (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!