Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Индекс+поискпоз при смещении диапазона - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Индекс+поискпоз при смещении диапазона (Формулы/Formulas)
Индекс+поискпоз при смещении диапазона
VIDEO56 Дата: Вторник, 17.05.2016, 09:26 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 262
Репутация: 23 ±
Замечаний: 0% ±

Excel 2010
Добрый день. Прошу помощи, есть прайсы которые регулярно изменяются и импортируются в спецификацию для дальнейшего извлечения из них данных. Использую формулу Индекс+поискпоз. Все работает замечательно при точном определении строки заголовка. Иногда строки заголовка меняются, как заставить формулу жестко не привязываться к номеру строки?
К сообщению приложен файл: 6208088.xlsm(20Kb)


Всем удачного дня!
 
Ответить
СообщениеДобрый день. Прошу помощи, есть прайсы которые регулярно изменяются и импортируются в спецификацию для дальнейшего извлечения из них данных. Использую формулу Индекс+поискпоз. Все работает замечательно при точном определении строки заголовка. Иногда строки заголовка меняются, как заставить формулу жестко не привязываться к номеру строки?

Автор - VIDEO56
Дата добавления - 17.05.2016 в 09:26
_Boroda_ Дата: Вторник, 17.05.2016, 10:48 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ИНДЕКС(A:K;ПОИСКПОЗ(M5;A:A;0);ПОИСКПОЗ(N5;ИНДЕКС(A1:AA5;ПОИСКПОЗ("Наименование";A1:A5;););0))

Кстати, зря Вы ПОИСКПОЗите по целиковому столбцу. Если у Вас таких формул много, то может тормозить
К сообщению приложен файл: 6208088_11.xlsm(20Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ИНДЕКС(A:K;ПОИСКПОЗ(M5;A:A;0);ПОИСКПОЗ(N5;ИНДЕКС(A1:AA5;ПОИСКПОЗ("Наименование";A1:A5;););0))

Кстати, зря Вы ПОИСКПОЗите по целиковому столбцу. Если у Вас таких формул много, то может тормозить

Автор - _Boroda_
Дата добавления - 17.05.2016 в 10:48
VIDEO56 Дата: Вторник, 17.05.2016, 11:59 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 262
Репутация: 23 ±
Замечаний: 0% ±

Excel 2010
Александр, спасибо. Именно так. hands hands hands


Всем удачного дня!
 
Ответить
СообщениеАлександр, спасибо. Именно так. hands hands hands

Автор - VIDEO56
Дата добавления - 17.05.2016 в 11:59
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Индекс+поискпоз при смещении диапазона (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!