Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет кол-ва совпадений в диапазоне - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет кол-ва совпадений в диапазоне (Формулы/Formulas)
Подсчет кол-ва совпадений в диапазоне
WR82 Дата: Вторник, 17.05.2016, 18:57 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Кол-во совпадений Кз., Км., Кд. с цифрами

c Кз., Км., Кд. все понятно

Код
=счетесли()


а вот с остальным не очень

Код
=мумнож()


возможно подходит, но правильно составить формулу у меня не получилось.

Можно ли объединить поиск и подсчет в массиве в одну формулу?
К сообщению приложен файл: _3.xlsx.xls(28Kb)
 
Ответить
СообщениеКол-во совпадений Кз., Км., Кд. с цифрами

c Кз., Км., Кд. все понятно

Код
=счетесли()


а вот с остальным не очень

Код
=мумнож()


возможно подходит, но правильно составить формулу у меня не получилось.

Можно ли объединить поиск и подсчет в массиве в одну формулу?

Автор - WR82
Дата добавления - 17.05.2016 в 18:57
buchlotnik Дата: Вторник, 17.05.2016, 19:14 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
а вот с остальным не очень
а чего нужно-то?


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщение
Цитата
а вот с остальным не очень
а чего нужно-то?

Автор - buchlotnik
Дата добавления - 17.05.2016 в 19:14
WR82 Дата: Вторник, 17.05.2016, 22:01 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
подсчитать сколько раз в массиве совпадают значения в строке:

например: Кз. и 1, или 1 и 1, или 2 и 1.

И заполнить таблицу.
 
Ответить
Сообщениеподсчитать сколько раз в массиве совпадают значения в строке:

например: Кз. и 1, или 1 и 1, или 2 и 1.

И заполнить таблицу.

Автор - WR82
Дата добавления - 17.05.2016 в 22:01
buchlotnik Дата: Вторник, 17.05.2016, 22:29 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
с текстовыми понятно, а вот с числовыми - мы с каким столбцом сравниваем? и, например, 1 и 1 - это 1 в каком столбце с 1 в каком?


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениес текстовыми понятно, а вот с числовыми - мы с каким столбцом сравниваем? и, например, 1 и 1 - это 1 в каком столбце с 1 в каком?

Автор - buchlotnik
Дата добавления - 17.05.2016 в 22:29
WR82 Дата: Среда, 18.05.2016, 16:41 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
с каждой ячейкой в строке массива A1:D38

A1 -> B1, C1, D1
B1 -> A1, C1, D1
C1 -> B1, A1, D1
D1 -> B1, C1, A1

И так в каждой строке массива, количество свести в таблицу.
Например:
в строках содержащих "-" в массиве 6ть "2"
в строках содержащих "2" 2ве "1"
[moder]Вы бы руками в файле несколько значений заполнили. Так понятнее будет.

прикрепил файл
К сообщению приложен файл: 2731149.xls(29Kb)


Сообщение отредактировал WR82 - Среда, 18.05.2016, 17:19
 
Ответить
Сообщениес каждой ячейкой в строке массива A1:D38

A1 -> B1, C1, D1
B1 -> A1, C1, D1
C1 -> B1, A1, D1
D1 -> B1, C1, A1

И так в каждой строке массива, количество свести в таблицу.
Например:
в строках содержащих "-" в массиве 6ть "2"
в строках содержащих "2" 2ве "1"
[moder]Вы бы руками в файле несколько значений заполнили. Так понятнее будет.

прикрепил файл

Автор - WR82
Дата добавления - 18.05.2016 в 16:41
Manyasha Дата: Среда, 18.05.2016, 19:02 | Сообщение № 6
Группа: Модераторы
Ранг: Старожил
Сообщений: 1586
Репутация: 661 ±
Замечаний: 0% ±

Excel 2007, 2010
WR82, вдруг угадала:
Код
=СУММ(--(МУМНОЖ(--($A$2:$D$39=$I3);{1:1:1:1})*МУМНОЖ(--($A$2:$D$39=J$2);{1:1:1:1})>0))

массивная, вводить через ctrl+shift+enter
К сообщению приложен файл: 2731149-1.xls(54Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеWR82, вдруг угадала:
Код
=СУММ(--(МУМНОЖ(--($A$2:$D$39=$I3);{1:1:1:1})*МУМНОЖ(--($A$2:$D$39=J$2);{1:1:1:1})>0))

массивная, вводить через ctrl+shift+enter

Автор - Manyasha
Дата добавления - 18.05.2016 в 19:02
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет кол-ва совпадений в диапазоне (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!