Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/поиск нескольких текстовых значений в одной ячейке - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » поиск нескольких текстовых значений в одной ячейке (Формулы/Formulas)
поиск нескольких текстовых значений в одной ячейке
MUZOBOZ Дата: Пятница, 20.05.2016, 18:31 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Всем добрый день
Помогите со следующей задачей, пожалуйста.
В столбце "А" нужно найти текст из любого значения из столбца "В" и напротив в столбце "С" должно быть отображено ОТП/1, а при ненаходжении значения - отображалась пустая ячейка.
СПАСИБО
К сообщению приложен файл: 7277566.xlsx(9Kb)
 
Ответить
СообщениеВсем добрый день
Помогите со следующей задачей, пожалуйста.
В столбце "А" нужно найти текст из любого значения из столбца "В" и напротив в столбце "С" должно быть отображено ОТП/1, а при ненаходжении значения - отображалась пустая ячейка.
СПАСИБО

Автор - MUZOBOZ
Дата добавления - 20.05.2016 в 18:31
abtextime Дата: Пятница, 20.05.2016, 18:50 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 427
Репутация: 60 ±
Замечаний: 0% ±

Excel 2010
Если правильно понял -

Код
=ЕСЛИ(И(B2<>"";СЧЁТЕСЛИ($A$2:$A$10;"*"&B2&"*")>0);"ОТП/1";"")
К сообщению приложен файл: _7277566.xlsx(10Kb)
 
Ответить
СообщениеЕсли правильно понял -

Код
=ЕСЛИ(И(B2<>"";СЧЁТЕСЛИ($A$2:$A$10;"*"&B2&"*")>0);"ОТП/1";"")

Автор - abtextime
Дата добавления - 20.05.2016 в 18:50
buchlotnik Дата: Пятница, 20.05.2016, 18:51 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3117
Репутация: 853 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так?
Код
=ЕСЛИ(СУММПРОИЗВ(1-ЕОШ(ПОИСК($B$2:$B$4;A2)));"ОТП/1";"")

или массивка
Код
=ЕСЛИ(СУММ(1-ЕОШ(ПОИСК($B$2:$B$4;A2)));"ОТП/1";"")

или так
Код
=ЕСЛИ(И(ЕОШ(ПОИСК($B$2:$B$4;A2)));"";"ОТП/1")
К сообщению приложен файл: 1054014.xlsx(10Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Пятница, 20.05.2016, 19:29
 
Ответить
Сообщениетак?
Код
=ЕСЛИ(СУММПРОИЗВ(1-ЕОШ(ПОИСК($B$2:$B$4;A2)));"ОТП/1";"")

или массивка
Код
=ЕСЛИ(СУММ(1-ЕОШ(ПОИСК($B$2:$B$4;A2)));"ОТП/1";"")

или так
Код
=ЕСЛИ(И(ЕОШ(ПОИСК($B$2:$B$4;A2)));"";"ОТП/1")

Автор - buchlotnik
Дата добавления - 20.05.2016 в 18:51
abtextime Дата: Пятница, 20.05.2016, 18:54 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 427
Репутация: 60 ±
Замечаний: 0% ±

Excel 2010
Судя по ответу buchlotnik, понял неправильно :) ... Наверное :)
 
Ответить
СообщениеСудя по ответу buchlotnik, понял неправильно :) ... Наверное :)

Автор - abtextime
Дата добавления - 20.05.2016 в 18:54
MUZOBOZ Дата: Пятница, 20.05.2016, 19:16 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
buchlotnik, спасибо большое все получилось
Буду сидеть разбираться только что в формуле что ))))
 
Ответить
Сообщениеbuchlotnik, спасибо большое все получилось
Буду сидеть разбираться только что в формуле что ))))

Автор - MUZOBOZ
Дата добавления - 20.05.2016 в 19:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » поиск нескольких текстовых значений в одной ячейке (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!