Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/как обойтись без многоуровенного ЕСЛИ - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » как обойтись без многоуровенного ЕСЛИ (Формулы/Formulas)
как обойтись без многоуровенного ЕСЛИ
nikitan95 Дата: Воскресенье, 22.05.2016, 07:55 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 176
Репутация: 0 ±
Замечаний: 0% ±

2013
Доброго всем!
Как при склейке нескольких ячеек обойти пустые? Притом не пользуясь многоуровневым ЕСЛИ?
К сообщению приложен файл: 8356288.xlsx(12Kb)
 
Ответить
СообщениеДоброго всем!
Как при склейке нескольких ячеек обойти пустые? Притом не пользуясь многоуровневым ЕСЛИ?

Автор - nikitan95
Дата добавления - 22.05.2016 в 07:55
Pelena Дата: Воскресенье, 22.05.2016, 09:04 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9852
Репутация: 2254 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Код
=ЕСЛИ(D2="";"";C2&D2&" от "&E2&", ")&ЕСЛИ(G2="";"";F2&G2&" от "&H2&", ")&ЕСЛИ(D3="";"";C3&D3&" от "&E3&", ")&ЕСЛИ(G3="";"";F3&G3&" от "&H3)
К сообщению приложен файл: 5090561.xlsx(12Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=ЕСЛИ(D2="";"";C2&D2&" от "&E2&", ")&ЕСЛИ(G2="";"";F2&G2&" от "&H2&", ")&ЕСЛИ(D3="";"";C3&D3&" от "&E3&", ")&ЕСЛИ(G3="";"";F3&G3&" от "&H3)

Автор - Pelena
Дата добавления - 22.05.2016 в 09:04
AlexM Дата: Воскресенье, 22.05.2016, 09:40 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3053
Репутация: 740 ±
Замечаний: 0% ±

Чтобы запятых лишних не было
Код
=ПОДСТАВИТЬ(ЕСЛИ(D2="";"";C2&D2&" от "&E2&" ")&ЕСЛИ(G2="";"";" "&F2&G2&" от "&H2&" ")&ЕСЛИ(D3="";"";" "&C3&D3&" от "&E3&" ")&ЕСЛИ(G3="";"";" "&F3&G3&" от "&H3);"  ";", ")

С датами так лучше
Код
=ПОДСТАВИТЬ(ЕСЛИ(D2="";"";C2&D2&" от "&ТЕКСТ(E2;"ДД.ММ.ГГГ")&" ")&ЕСЛИ(G2="";"";" "&F2&G2&" от "&ТЕКСТ(H2;"ДД.ММ.ГГГ")&" ")&ЕСЛИ(D3="";"";" "&C3&D3&" от "&ТЕКСТ(E3;"ДД.ММ.ГГГ")&" ")&ЕСЛИ(G3="";"";" "&F3&G3&" от "&ТЕКСТ(H3;"ДД.ММ.ГГГ"));"  ";", ")


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Воскресенье, 22.05.2016, 09:49
 
Ответить
СообщениеЧтобы запятых лишних не было
Код
=ПОДСТАВИТЬ(ЕСЛИ(D2="";"";C2&D2&" от "&E2&" ")&ЕСЛИ(G2="";"";" "&F2&G2&" от "&H2&" ")&ЕСЛИ(D3="";"";" "&C3&D3&" от "&E3&" ")&ЕСЛИ(G3="";"";" "&F3&G3&" от "&H3);"  ";", ")

С датами так лучше
Код
=ПОДСТАВИТЬ(ЕСЛИ(D2="";"";C2&D2&" от "&ТЕКСТ(E2;"ДД.ММ.ГГГ")&" ")&ЕСЛИ(G2="";"";" "&F2&G2&" от "&ТЕКСТ(H2;"ДД.ММ.ГГГ")&" ")&ЕСЛИ(D3="";"";" "&C3&D3&" от "&ТЕКСТ(E3;"ДД.ММ.ГГГ")&" ")&ЕСЛИ(G3="";"";" "&F3&G3&" от "&ТЕКСТ(H3;"ДД.ММ.ГГГ"));"  ";", ")

Автор - AlexM
Дата добавления - 22.05.2016 в 09:40
nikitan95 Дата: Воскресенье, 22.05.2016, 11:00 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 176
Репутация: 0 ±
Замечаний: 0% ±

2013
спасибо, оба варианта хороши
 
Ответить
Сообщениеспасибо, оба варианта хороши

Автор - nikitan95
Дата добавления - 22.05.2016 в 11:00
Мир MS Excel » Вопросы и решения » Вопросы по Excel » как обойтись без многоуровенного ЕСЛИ (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!