Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование текстовых значений - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование текстовых значений (Формулы/Formulas)
Суммирование текстовых значений
gringos Дата: Понедельник, 23.05.2016, 16:37 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Подскажите пожалуйста как получить итог по данным в текстовом формате как в примере....?
К сообщению приложен файл: 3610383.xlsx(9Kb)
 
Ответить
СообщениеПодскажите пожалуйста как получить итог по данным в текстовом формате как в примере....?

Автор - gringos
Дата добавления - 23.05.2016 в 16:37
_Boroda_ Дата: Понедельник, 23.05.2016, 16:43 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9379
Репутация: 3951 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММПРОИЗВ(--ПОДСТАВИТЬ(ПОДСТАВИТЬ(D3:D23;" кв.м.";);" ";))

Во вторых кавычках неразрывный пробел (символ 160), скопированный из ячейки D18
К сообщению приложен файл: 3610383_1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММПРОИЗВ(--ПОДСТАВИТЬ(ПОДСТАВИТЬ(D3:D23;" кв.м.";);" ";))

Во вторых кавычках неразрывный пробел (символ 160), скопированный из ячейки D18

Автор - _Boroda_
Дата добавления - 23.05.2016 в 16:43
buchlotnik Дата: Понедельник, 23.05.2016, 16:46 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
так нужно?
Код
=СУММПРОИЗВ(--ПОДСТАВИТЬ(ЛЕВСИМВ(D3:D23;ДЛСТР(D3:D23)-6);" ";""))
К сообщению приложен файл: 2506471.xlsx(10Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениетак нужно?
Код
=СУММПРОИЗВ(--ПОДСТАВИТЬ(ЛЕВСИМВ(D3:D23;ДЛСТР(D3:D23)-6);" ";""))

Автор - buchlotnik
Дата добавления - 23.05.2016 в 16:46
krosav4ig Дата: Понедельник, 23.05.2016, 16:48 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1362
Репутация: 548 ±
Замечаний: 0% ±

Excel 2007, 2013
Код
=СУММПРОИЗВ(--ПОДСТАВИТЬ(ПОДСТАВИТЬ(D3:D23;" ";);"кв.м.";))
К сообщению приложен файл: 1137290.xlsx(10Kb)


(_)Õvõ(_)

Сообщение отредактировал krosav4ig - Понедельник, 23.05.2016, 16:49
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(--ПОДСТАВИТЬ(ПОДСТАВИТЬ(D3:D23;" ";);"кв.м.";))

Автор - krosav4ig
Дата добавления - 23.05.2016 в 16:48
pabchek Дата: Понедельник, 23.05.2016, 16:55 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 646
Репутация: 146 ±
Замечаний: 0% ±

Excel 2007
Остается только поизвращаться на длину формулы))) Правда массивная, в основе формула krosav4ig
Код
=СУММ(--ПОДСТАВИТЬ(ПОДСТАВИТЬ(D3:D23;" ";);"кв.м.";))
К сообщению приложен файл: 4314357.xlsx(12Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Понедельник, 23.05.2016, 16:57
 
Ответить
СообщениеОстается только поизвращаться на длину формулы))) Правда массивная, в основе формула krosav4ig
Код
=СУММ(--ПОДСТАВИТЬ(ПОДСТАВИТЬ(D3:D23;" ";);"кв.м.";))

Автор - pabchek
Дата добавления - 23.05.2016 в 16:55
gringos Дата: Понедельник, 23.05.2016, 17:28 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Всем большое спасибо, за оперативную отзывчивость!!!))
 
Ответить
СообщениеВсем большое спасибо, за оперативную отзывчивость!!!))

Автор - gringos
Дата добавления - 23.05.2016 в 17:28
китин Дата: Вторник, 24.05.2016, 10:03 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а СИМВОЛ(160) никто не извращался?
Код
=СУММПРОИЗВ(--ПОДСТАВИТЬ(ПОДСТАВИТЬ(D3:D23;" кв.м.";"");СИМВОЛ(160);""))

или так
Код
=СУММПРОИЗВ(--ПОДСТАВИТЬ(ЛЕВБ(D3:D23;ПОИСК(" к";D3:D23));СИМВОЛ(160);""))


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Вторник, 24.05.2016, 10:06
 
Ответить
Сообщениеа СИМВОЛ(160) никто не извращался?
Код
=СУММПРОИЗВ(--ПОДСТАВИТЬ(ПОДСТАВИТЬ(D3:D23;" кв.м.";"");СИМВОЛ(160);""))

или так
Код
=СУММПРОИЗВ(--ПОДСТАВИТЬ(ЛЕВБ(D3:D23;ПОИСК(" к";D3:D23));СИМВОЛ(160);""))

Автор - китин
Дата добавления - 24.05.2016 в 10:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование текстовых значений (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!