Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Заполнить таблицу ВПР по значению первой строки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнить таблицу ВПР по значению первой строки (Формулы/Formulas)
Заполнить таблицу ВПР по значению первой строки
Sapphira Дата: Понедельник, 30.05.2016, 11:33 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте! помогите, пожалуйста с синтаксисом формулы для заполнения таблицы. файл прикреплен. Заранее благодарю!
К сообщению приложен файл: 3353622.xlsx(9Kb)
 
Ответить
СообщениеЗдравствуйте! помогите, пожалуйста с синтаксисом формулы для заполнения таблицы. файл прикреплен. Заранее благодарю!

Автор - Sapphira
Дата добавления - 30.05.2016 в 11:33
_Boroda_ Дата: Понедельник, 30.05.2016, 11:45 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9380
Репутация: 3951 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ИНДЕКС($B$2:$E$13;ПОИСКПОЗ($K2;$A$2:$A$13;);ПОИСКПОЗ(L$1;$B$1:$E$1;))

Только АВС должны быть одинаковыми - или все русские, или все латинские. Поскольку присутствует еще и D, то, скорее всего, латинские. В файле исправил.

Еще
Код
=СУММПРОИЗВ($B$2:$E$13*($A$2:$A$13=$K2)*($B$1:$E$1=L$1))

Код
=ВПР($K2;$A$2:$E$13;ПОИСКПОЗ(L$1;$A$1:$E$1;);)

Код
=ГПР(L$1;$B$1:$E$13;ПОИСКПОЗ($K2;$A$1:$A$13;);)
К сообщению приложен файл: 3353622_1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ИНДЕКС($B$2:$E$13;ПОИСКПОЗ($K2;$A$2:$A$13;);ПОИСКПОЗ(L$1;$B$1:$E$1;))

Только АВС должны быть одинаковыми - или все русские, или все латинские. Поскольку присутствует еще и D, то, скорее всего, латинские. В файле исправил.

Еще
Код
=СУММПРОИЗВ($B$2:$E$13*($A$2:$A$13=$K2)*($B$1:$E$1=L$1))

Код
=ВПР($K2;$A$2:$E$13;ПОИСКПОЗ(L$1;$A$1:$E$1;);)

Код
=ГПР(L$1;$B$1:$E$13;ПОИСКПОЗ($K2;$A$1:$A$13;);)

Автор - _Boroda_
Дата добавления - 30.05.2016 в 11:45
Sapphira Дата: Понедельник, 30.05.2016, 11:50 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Это именно то, что нужно! Благодаря Вам поняла , что такое ИНДЕКС, и с чем его едят)) Благодарствую!
 
Ответить
СообщениеЭто именно то, что нужно! Благодаря Вам поняла , что такое ИНДЕКС, и с чем его едят)) Благодарствую!

Автор - Sapphira
Дата добавления - 30.05.2016 в 11:50
китин Дата: Понедельник, 30.05.2016, 11:55 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
еще вариант
Код
=ПРОСМОТР(1;1/(($A$2:$A$13=$K2));ИНДЕКС($B$2:$E$13;;ПОИСКПОЗ(L$1;$B$1:$E$1;0)))
К сообщению приложен файл: _3353622.xlsx(10Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Понедельник, 30.05.2016, 11:55
 
Ответить
Сообщениееще вариант
Код
=ПРОСМОТР(1;1/(($A$2:$A$13=$K2));ИНДЕКС($B$2:$E$13;;ПОИСКПОЗ(L$1;$B$1:$E$1;0)))

Автор - китин
Дата добавления - 30.05.2016 в 11:55
Sapphira Дата: Четверг, 02.06.2016, 16:21 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
китин, спасибо, опробую и этот вариант
 
Ответить
Сообщениекитин, спасибо, опробую и этот вариант

Автор - Sapphira
Дата добавления - 02.06.2016 в 16:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнить таблицу ВПР по значению первой строки (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!