Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Нумерация по месяцу - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Нумерация по месяцу (Формулы/Formulas)
Нумерация по месяцу
Yamakaka Дата: Вторник, 31.05.2016, 05:53 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте! Необходимо пронумеровать строки, для которых в дате идёт общий месяц.
Например, для строк с датами вида:
01.01.1990
11.01.1990
13.02.2005
23.04.2005
25.02.2005
Должно вывестись
1
2
1
1
2
Как это можно реализовать? Спасибо.
 
Ответить
СообщениеЗдравствуйте! Необходимо пронумеровать строки, для которых в дате идёт общий месяц.
Например, для строк с датами вида:
01.01.1990
11.01.1990
13.02.2005
23.04.2005
25.02.2005
Должно вывестись
1
2
1
1
2
Как это можно реализовать? Спасибо.

Автор - Yamakaka
Дата добавления - 31.05.2016 в 05:53
Pelena Дата: Вторник, 31.05.2016, 06:27 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 10996
Репутация: 2454 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Здравствуйте.
Если только месяц, то
Код
=СУММПРОИЗВ(--(МЕСЯЦ($B$1:B1)=МЕСЯЦ(B1)))

но я думаю, что и год надо учитывать, тогда
Код
=СУММПРОИЗВ(--(ТЕКСТ($B$1:B1;"ММГГ")=ТЕКСТ(B1;"ММГГ")))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Если только месяц, то
Код
=СУММПРОИЗВ(--(МЕСЯЦ($B$1:B1)=МЕСЯЦ(B1)))

но я думаю, что и год надо учитывать, тогда
Код
=СУММПРОИЗВ(--(ТЕКСТ($B$1:B1;"ММГГ")=ТЕКСТ(B1;"ММГГ")))

Автор - Pelena
Дата добавления - 31.05.2016 в 06:27
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Нумерация по месяцу (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!