Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как переместить данные из столбца B в A - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как переместить данные из столбца B в A (Формулы/Formulas)
Как переместить данные из столбца B в A
arti81 Дата: Четверг, 02.06.2016, 07:46 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Как переместить данные из столбца B в пустые параллельные строки столбца A, при этом данные в заполненных строках столбца A не изменились.
 
Ответить
СообщениеКак переместить данные из столбца B в пустые параллельные строки столбца A, при этом данные в заполненных строках столбца A не изменились.

Автор - arti81
Дата добавления - 02.06.2016 в 07:46
Pelena Дата: Четверг, 02.06.2016, 07:49 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9871
Репутация: 2263 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
В доп. столбец формулу
Код
=ЕСЛИ(A1="";B1;A1)

Затем Копировать/Специальная вставка -- значения в столбец А


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВ доп. столбец формулу
Код
=ЕСЛИ(A1="";B1;A1)

Затем Копировать/Специальная вставка -- значения в столбец А

Автор - Pelena
Дата добавления - 02.06.2016 в 07:49
Nic70y Дата: Четверг, 02.06.2016, 07:50 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3485
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Выделяем столбец A, жмем F5, выделить пустые ячейки, ОК,
ПКМ - удалить со сдвигом влево.
Так нужно?


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
СообщениеВыделяем столбец A, жмем F5, выделить пустые ячейки, ОК,
ПКМ - удалить со сдвигом влево.
Так нужно?

Автор - Nic70y
Дата добавления - 02.06.2016 в 07:50
_Boroda_ Дата: Четверг, 02.06.2016, 10:10 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9375
Репутация: 3948 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Можно еще наоборот - из А вставить в В так, что вставятся только те А, которые заполнены, а где А пустое, там В останется нетронутым
Копируем А, переходим в В, прав. кн. мыши - спецвставка - галка "Пропускать пустые ячейки" - ОК


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеМожно еще наоборот - из А вставить в В так, что вставятся только те А, которые заполнены, а где А пустое, там В останется нетронутым
Копируем А, переходим в В, прав. кн. мыши - спецвставка - галка "Пропускать пустые ячейки" - ОК

Автор - _Boroda_
Дата добавления - 02.06.2016 в 10:10
arti81 Дата: Четверг, 02.06.2016, 13:59 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

спасибо помогло
 
Ответить
Сообщениеспасибо помогло

Автор - arti81
Дата добавления - 02.06.2016 в 13:59
Nic70y Дата: Четверг, 02.06.2016, 14:57 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3485
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
[offtop]Суда по + в репу рулит Nic70y,
пойду в спорттовары за медалью :)[/offtop]


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение[offtop]Суда по + в репу рулит Nic70y,
пойду в спорттовары за медалью :)[/offtop]

Автор - Nic70y
Дата добавления - 02.06.2016 в 14:57
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как переместить данные из столбца B в A (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!