Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск третьего значения по двум заданным - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск третьего значения по двум заданным (Формулы/Formulas)
Поиск третьего значения по двум заданным
olenka1990 Дата: Воскресенье, 05.06.2016, 12:14 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте знатоки excel. Возможно ли в данном примере при помощи excel решить следующую задачу, если да, то подскажите какой именно функцией. Суть задачи в следующем:в столбце А значения, необходимо при вводе значений в ячейки В1 и С1, в ячейках D1:D15 должны отображаться значения, которые следуют за значением С1 столбца А, в данном примере выделены красным цветом. Пробовала функциями сцепить и впр, но впр находит только первое найденное значение. Зашла в тупик.Спасибо
К сообщению приложен файл: 2627968.xls(26Kb)
 
Ответить
СообщениеЗдравствуйте знатоки excel. Возможно ли в данном примере при помощи excel решить следующую задачу, если да, то подскажите какой именно функцией. Суть задачи в следующем:в столбце А значения, необходимо при вводе значений в ячейки В1 и С1, в ячейках D1:D15 должны отображаться значения, которые следуют за значением С1 столбца А, в данном примере выделены красным цветом. Пробовала функциями сцепить и впр, но впр находит только первое найденное значение. Зашла в тупик.Спасибо

Автор - olenka1990
Дата добавления - 05.06.2016 в 12:14
Pelena Дата: Воскресенье, 05.06.2016, 12:37 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9889
Репутация: 2269 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Здравствуйте. Формула массива вводится нажатием сочетания клавиш Ctrl+Shift+Enter
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$A$19;НАИМЕНЬШИЙ(ЕСЛИ($A$1:$A$19=$C$1;СТРОКА($A$2:$A$20));СТРОКА(A1)));"")
К сообщению приложен файл: 9791079.xls(27Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте. Формула массива вводится нажатием сочетания клавиш Ctrl+Shift+Enter
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$1:$A$19;НАИМЕНЬШИЙ(ЕСЛИ($A$1:$A$19=$C$1;СТРОКА($A$2:$A$20));СТРОКА(A1)));"")

Автор - Pelena
Дата добавления - 05.06.2016 в 12:37
jakim Дата: Воскресенье, 05.06.2016, 14:45 | Сообщение № 3
Группа: Друзья
Ранг: Ветеран
Сообщений: 683
Репутация: 172 ±
Замечаний: 0% ±

Для Вашего офиса обычная формула

Код
=INDEX(A$1:A$17;AGGREGATE(15;6;ROW($1:$19)/(A$1:A$17=C$1);ROW(1:1))+1)
 
Ответить
Сообщение
Для Вашего офиса обычная формула

Код
=INDEX(A$1:A$17;AGGREGATE(15;6;ROW($1:$19)/(A$1:A$17=C$1);ROW(1:1))+1)

Автор - jakim
Дата добавления - 05.06.2016 в 14:45
olenka1990 Дата: Воскресенье, 05.06.2016, 21:24 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Pelena и jakim извините за позднее спасибо, вернулась только с дачи, сейчас буду разбираться. Ещё вам огромное спасибо. hands
 
Ответить
СообщениеPelena и jakim извините за позднее спасибо, вернулась только с дачи, сейчас буду разбираться. Ещё вам огромное спасибо. hands

Автор - olenka1990
Дата добавления - 05.06.2016 в 21:24
olenka1990 Дата: Воскресенье, 05.06.2016, 22:12 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Pelena и jakim посмотрела ваши решения, может я плохо объяснила суть задачи, но формулы находят значения только при вводе в С1, но не учитывают В1, а необходимо, чтобы в ячейках D1:D15 ,были значения соответствующие двум условиям B1 и C1, затем выводиться в ячейки D1:D15. Спасибо
 
Ответить
СообщениеPelena и jakim посмотрела ваши решения, может я плохо объяснила суть задачи, но формулы находят значения только при вводе в С1, но не учитывают В1, а необходимо, чтобы в ячейках D1:D15 ,были значения соответствующие двум условиям B1 и C1, затем выводиться в ячейки D1:D15. Спасибо

Автор - olenka1990
Дата добавления - 05.06.2016 в 22:12
_Boroda_ Дата: Воскресенье, 05.06.2016, 22:13 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9380
Репутация: 3951 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Оленька, а разве не нужно еще и с В1 сверять? Если нужно, то формула Лены
Код
=ЕСЛИОШИБКА(ИНДЕКС(A$3:A$19;НАИМЕНЬШИЙ(ЕСЛИ((A$1:A$17=B$1)*(A$2:A$18=C$1);СТРОКА(A$1:A$17));СТРОКА(A1)));"")

или почти формула Вячеслава
Код
=ЕСЛИОШИБКА(ИНДЕКС(A$3:A$19;АГРЕГАТ(15;6;СТРОКА($1:$19)/(A$1:A$17=B$1)/(A$2:A$18=C$1);СТРОКА(H1)));"")


Добавлено
Как в воду глядел!
К сообщению приложен файл: 2627968_1.xls(35Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеОленька, а разве не нужно еще и с В1 сверять? Если нужно, то формула Лены
Код
=ЕСЛИОШИБКА(ИНДЕКС(A$3:A$19;НАИМЕНЬШИЙ(ЕСЛИ((A$1:A$17=B$1)*(A$2:A$18=C$1);СТРОКА(A$1:A$17));СТРОКА(A1)));"")

или почти формула Вячеслава
Код
=ЕСЛИОШИБКА(ИНДЕКС(A$3:A$19;АГРЕГАТ(15;6;СТРОКА($1:$19)/(A$1:A$17=B$1)/(A$2:A$18=C$1);СТРОКА(H1)));"")


Добавлено
Как в воду глядел!

Автор - _Boroda_
Дата добавления - 05.06.2016 в 22:13
olenka1990 Дата: Воскресенье, 05.06.2016, 22:31 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, здравствуйте. Вы правильно всё поняли, наверно плохо объяснила суть задания. Огромное вам спасибо за быстрый ответ. Всё прекрасно работает. hands
 
Ответить
Сообщение_Boroda_, здравствуйте. Вы правильно всё поняли, наверно плохо объяснила суть задания. Огромное вам спасибо за быстрый ответ. Всё прекрасно работает. hands

Автор - olenka1990
Дата добавления - 05.06.2016 в 22:31
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск третьего значения по двум заданным (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!