Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Разброс номеров случайным образом - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Разброс номеров случайным образом (Формулы/Formulas)
Разброс номеров случайным образом
UniWar Дата: Воскресенье, 05.06.2016, 23:38 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый вечер, форумчане! Снова взываю о помощи =)

Имеется список товарных позиций, каждая имеет свой айди. Мне нужно проставить к каждой позиции, рекомендованные товары (В отдельной, одной ячейке, через запятую, три рандомных АйДи). Должно быть просто, но никак не разберусь с формулой.


Сообщение отредактировал UniWar - Понедельник, 06.06.2016, 15:36
 
Ответить
СообщениеДобрый вечер, форумчане! Снова взываю о помощи =)

Имеется список товарных позиций, каждая имеет свой айди. Мне нужно проставить к каждой позиции, рекомендованные товары (В отдельной, одной ячейке, через запятую, три рандомных АйДи). Должно быть просто, но никак не разберусь с формулой.

Автор - UniWar
Дата добавления - 05.06.2016 в 23:38
gling Дата: Воскресенье, 05.06.2016, 23:42 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1351
Репутация: 325 ±
Замечаний: 0% ±

2010
никак не разберусь с формулой.
Похоже она отстала от сообщения или спряталась, чтобы с ней никто не смог разобраться.
 
Ответить
Сообщение
никак не разберусь с формулой.
Похоже она отстала от сообщения или спряталась, чтобы с ней никто не смог разобраться.

Автор - gling
Дата добавления - 05.06.2016 в 23:42
UniWar Дата: Воскресенье, 05.06.2016, 23:54 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Если бы она была, я бы сюда не обращался
[moder]Исправьте название темы - см. п.2 Правил форума


Сообщение отредактировал _Boroda_ - Понедельник, 06.06.2016, 00:40
 
Ответить
СообщениеЕсли бы она была, я бы сюда не обращался
[moder]Исправьте название темы - см. п.2 Правил форума

Автор - UniWar
Дата добавления - 05.06.2016 в 23:54
buchlotnik Дата: Понедельник, 06.06.2016, 00:17 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Цитата
я бы сюда не обращался
ваше обращение не будет иметь смысла, пока вы не покажете в файле чего надо. И какое отношение суть задачи имеет к пересортировке?


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщение
Цитата
я бы сюда не обращался
ваше обращение не будет иметь смысла, пока вы не покажете в файле чего надо. И какое отношение суть задачи имеет к пересортировке?

Автор - buchlotnik
Дата добавления - 06.06.2016 в 00:17
UniWar Дата: Понедельник, 06.06.2016, 00:54 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
В приложении
[moder]До исправления Вами замечания модератора ответы все равно будут удалены.
Исправлено[/moder]
К сообщению приложен файл: 7380622.xls(20Kb)


Сообщение отредактировал Pelena - Понедельник, 06.06.2016, 22:01
 
Ответить
СообщениеВ приложении
[moder]До исправления Вами замечания модератора ответы все равно будут удалены.
Исправлено[/moder]

Автор - UniWar
Дата добавления - 06.06.2016 в 00:54
UniWar Дата: Понедельник, 06.06.2016, 21:46 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
В приложении
К сообщению приложен файл: 3692806.xls(20Kb)
 
Ответить
СообщениеВ приложении

Автор - UniWar
Дата добавления - 06.06.2016 в 21:46
Michael_S Дата: Вторник, 07.06.2016, 07:21 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1687
Репутация: 327 ±
Замечаний: 0% ±

Excel2016
Код
=ИНДЕКС($A$2:$A$8;СЛУЧМЕЖДУ(1;ЧСТРОК($A$2:$A$8)))&","&ИНДЕКС($A$2:$A$8;СЛУЧМЕЖДУ(1;ЧСТРОК($A$2:$A$8)))&","&ИНДЕКС($A$2:$A$8;СЛУЧМЕЖДУ(1;ЧСТРОК($A$2:$A$8)))
эта формула не исключает повторы в одной строке.


ЯД: 41001136675053
WM: R389613894253
 
Ответить
Сообщение
Код
=ИНДЕКС($A$2:$A$8;СЛУЧМЕЖДУ(1;ЧСТРОК($A$2:$A$8)))&","&ИНДЕКС($A$2:$A$8;СЛУЧМЕЖДУ(1;ЧСТРОК($A$2:$A$8)))&","&ИНДЕКС($A$2:$A$8;СЛУЧМЕЖДУ(1;ЧСТРОК($A$2:$A$8)))
эта формула не исключает повторы в одной строке.

Автор - Michael_S
Дата добавления - 07.06.2016 в 07:21
UniWar Дата: Вторник, 07.06.2016, 13:55 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Повторов к сожалению, быть не должно. Так же как и ИД позиции, к которой применяют три АйДи от других позиций
 
Ответить
СообщениеПовторов к сожалению, быть не должно. Так же как и ИД позиции, к которой применяют три АйДи от других позиций

Автор - UniWar
Дата добавления - 07.06.2016 в 13:55
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Разброс номеров случайным образом (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!