Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование разного кол-ва ячеек - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование разного кол-ва ячеек (Формулы/Formulas)
Суммирование разного кол-ва ячеек
12345tn Дата: Понедельник, 06.06.2016, 10:11 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 76
Репутация: 0 ±
Замечаний: 20% ±

2007
Здравствуйте .Подскажите пожалуйста как сделать так, что бы в ячейке Итого (В20) коректно считалась сумма при условии что количество суммируемых (жёлтых) ячеек в столбце В часто меняется(то больше их то меньше).т.е.что бы при удалении например строки11 сумма уменьшилась бы на 100 .Заранее спасибо .
К сообщению приложен файл: 8225167.xlsx(17Kb)
 
Ответить
СообщениеЗдравствуйте .Подскажите пожалуйста как сделать так, что бы в ячейке Итого (В20) коректно считалась сумма при условии что количество суммируемых (жёлтых) ячеек в столбце В часто меняется(то больше их то меньше).т.е.что бы при удалении например строки11 сумма уменьшилась бы на 100 .Заранее спасибо .

Автор - 12345tn
Дата добавления - 06.06.2016 в 10:11
китин Дата: Понедельник, 06.06.2016, 10:14 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3751
Репутация: 594 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а как определить какие ячейки надо суммировать? по цвету?


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеа как определить какие ячейки надо суммировать? по цвету?

Автор - китин
Дата добавления - 06.06.2016 в 10:14
pabchek Дата: Понедельник, 06.06.2016, 10:19 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 668
Репутация: 147 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте! В общем случае, когда суммируются ячейки и со значениями 1 и 2, прекрасно работает формула
Код
=СУММ(B1:B18)
. Если же надо выбирать "цветные" ячейки, нужно смотреть на условие их появления. Можно написать формулу для этого конкретного примера, но, что-то мне подсказывает, что условие будет другое и формула, соответственно. Резюме: реальный пример в студию!


"Учиться, учиться и еще раз учиться!"
WM: R399923528092
 
Ответить
СообщениеЗдравствуйте! В общем случае, когда суммируются ячейки и со значениями 1 и 2, прекрасно работает формула
Код
=СУММ(B1:B18)
. Если же надо выбирать "цветные" ячейки, нужно смотреть на условие их появления. Можно написать формулу для этого конкретного примера, но, что-то мне подсказывает, что условие будет другое и формула, соответственно. Резюме: реальный пример в студию!

Автор - pabchek
Дата добавления - 06.06.2016 в 10:19
12345tn Дата: Понедельник, 06.06.2016, 10:20 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 76
Репутация: 0 ±
Замечаний: 20% ±

2007
китин, Да ,нужно суммировать только жёлтые ячейки(как в примере).Вся загвоздка в том что иногда надо удалить полностью строку с жёлтой ячейкой.
[moder]Еще раз:
нужно смотреть на условие их появления
Другими словами - опишите логику покраски в желтый. Почему Вы покрасили именно эти ячейки. Иначе - только макросом.[/moder]
 
Ответить
Сообщениекитин, Да ,нужно суммировать только жёлтые ячейки(как в примере).Вся загвоздка в том что иногда надо удалить полностью строку с жёлтой ячейкой.
[moder]Еще раз:
нужно смотреть на условие их появления
Другими словами - опишите логику покраски в желтый. Почему Вы покрасили именно эти ячейки. Иначе - только макросом.[/moder]

Автор - 12345tn
Дата добавления - 06.06.2016 в 10:20
12345tn Дата: Понедельник, 06.06.2016, 10:31 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 76
Репутация: 0 ±
Замечаний: 20% ±

2007
Нет никакого реального примера.Я просто хотела узнать как считать сумму если одно из суммированых удаляется вместе со строкой.Извините если вас запутала.
 
Ответить
СообщениеНет никакого реального примера.Я просто хотела узнать как считать сумму если одно из суммированых удаляется вместе со строкой.Извините если вас запутала.

Автор - 12345tn
Дата добавления - 06.06.2016 в 10:31
TimSha Дата: Понедельник, 06.06.2016, 10:37 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 492
Репутация: 76 ±
Замечаний: 0% ±

Excel 2013 Pro +
как считать сумму если одно из суммированых удаляется вместе со строкой

Поясните детальное - что не получается?


"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Ответить
Сообщение
как считать сумму если одно из суммированых удаляется вместе со строкой

Поясните детальное - что не получается?

Автор - TimSha
Дата добавления - 06.06.2016 в 10:37
_Boroda_ Дата: Понедельник, 06.06.2016, 10:41 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9857
Репутация: 4171 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А, теперь понятно. Тогда все равно придется вводить какой-то критерий и писать что-то типа
Код
=СУММЕСЛИ(C1:C19;1;B1:B19)

Но я предположу, что критерий уже есть (или его можно выявить) в Вашем файле, просто Вы не хотите показать его (файл)
К сообщению приложен файл: 8225167_1.xlsx(11Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА, теперь понятно. Тогда все равно придется вводить какой-то критерий и писать что-то типа
Код
=СУММЕСЛИ(C1:C19;1;B1:B19)

Но я предположу, что критерий уже есть (или его можно выявить) в Вашем файле, просто Вы не хотите показать его (файл)

Автор - _Boroda_
Дата добавления - 06.06.2016 в 10:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование разного кол-ва ячеек (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!