Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование массивов через поиск (но объединенные ячейки) - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование массивов через поиск (но объединенные ячейки) (Формулы/Formulas)
Суммирование массивов через поиск (но объединенные ячейки)
lebensvoll Дата: Понедельник, 06.06.2016, 14:51 | Сообщение № 1
Группа: Проверенные
Ранг: Ветеран
Сообщений: 645
Репутация: 2 ±
Замечаний: 60% ±

Excel 2010
Добрый день уважаемые форумчане!!!
В приложенном файле имеется таблица [img][img=http://i9.pixs.ru/storage/8/1/3/SnimokJPG_1907019_22233813.jpg][/img]
Нужно подсчитать сумму гравия 5-20; и 3-10 в тоннах [img][img=http://i9.pixs.ru/storage/8/4/9/SnimokJPG_7432326_22233849.jpg][/img]
Проблема моя сложилась именно в том что наименование щебня "гравия 5-20" имеет объединенные ячейки (((( и то что нужно суммировать "нужные значения" получаются через одну ((((
Возможно ли произвести данное суммирование???
В дальнейшем данные значения будут находиться в одном файле а суммирование будет находится в другом...
К сообщению приложен файл: 7932851.xlsx(13Kb)


Кто бы ты ни был, мир в твоих руках
 
Ответить
СообщениеДобрый день уважаемые форумчане!!!
В приложенном файле имеется таблица [img][img=http://i9.pixs.ru/storage/8/1/3/SnimokJPG_1907019_22233813.jpg][/img]
Нужно подсчитать сумму гравия 5-20; и 3-10 в тоннах [img][img=http://i9.pixs.ru/storage/8/4/9/SnimokJPG_7432326_22233849.jpg][/img]
Проблема моя сложилась именно в том что наименование щебня "гравия 5-20" имеет объединенные ячейки (((( и то что нужно суммировать "нужные значения" получаются через одну ((((
Возможно ли произвести данное суммирование???
В дальнейшем данные значения будут находиться в одном файле а суммирование будет находится в другом...

Автор - lebensvoll
Дата добавления - 06.06.2016 в 14:51
_Boroda_ Дата: Понедельник, 06.06.2016, 14:59 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9381
Репутация: 3951 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Самое простое (на мой взгляд)
Код
=СУММЕСЛИ(B$12:B$42;M12;I$12:I$42)+СУММЕСЛИ(B$12:B$42;M12;I$13:I$43)

Еще
Код
=СУММПРОИЗВ((B$12:B$42=M12)*(I$12:I$42+I$13:I$43))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеСамое простое (на мой взгляд)
Код
=СУММЕСЛИ(B$12:B$42;M12;I$12:I$42)+СУММЕСЛИ(B$12:B$42;M12;I$13:I$43)

Еще
Код
=СУММПРОИЗВ((B$12:B$42=M12)*(I$12:I$42+I$13:I$43))

Автор - _Boroda_
Дата добавления - 06.06.2016 в 14:59
ArkaIIIa Дата: Понедельник, 06.06.2016, 15:00 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 858
Репутация: 114 ±
Замечаний: 0% ±

2010
Добрый день!

А чем вас СУММЕСЛИ не устроило?

Код
=СУММЕСЛИ($B$12:$B$43;M12;$I$12:$I$43)


Upd. Борода на сверхзвуке обошел :-)


Сообщение отредактировал ArkaIIIa - Понедельник, 06.06.2016, 15:01
 
Ответить
СообщениеДобрый день!

А чем вас СУММЕСЛИ не устроило?

Код
=СУММЕСЛИ($B$12:$B$43;M12;$I$12:$I$43)


Upd. Борода на сверхзвуке обошел :-)

Автор - ArkaIIIa
Дата добавления - 06.06.2016 в 15:00
китин Дата: Понедельник, 06.06.2016, 15:01 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3454
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Саша
Нужно подсчитать сумму гравия 5-20; и 3-10 в тоннах

а у тебя тонны с кубометрами суммируются.
может так?
Код
=СУММПРОИЗВ($I$12:$I$43*($B$12:$B$43=$M12)*($D$12:$D$43="тн"))
К сообщению приложен файл: 8757358.xlsx(14Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Понедельник, 06.06.2016, 15:02
 
Ответить
СообщениеСаша
Нужно подсчитать сумму гравия 5-20; и 3-10 в тоннах

а у тебя тонны с кубометрами суммируются.
может так?
Код
=СУММПРОИЗВ($I$12:$I$43*($B$12:$B$43=$M12)*($D$12:$D$43="тн"))

Автор - китин
Дата добавления - 06.06.2016 в 15:01
_Boroda_ Дата: Понедельник, 06.06.2016, 15:04 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9381
Репутация: 3951 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
у тебя тонны с кубометрами суммируются.
Подумаешь! Получатся тонно-кубометры, все нормально.

Ну ладно, если только тонны, тогда просто первый кусок от формулы
Код
=СУММЕСЛИ(B$12:B$42;M12;I$12:I$42)

Код
=СУММПРОИЗВ((B$12:B$42=M12)*I$12:I$42)

Александр, когда ячейка объединена, то в 99,99% это означает, что значение находится в левом верхнем углу объединенной ячейки, а все остальные объединенные пусты. То есть В В12 текст есть, а в В13 - пусто. Поэтому можно рассматривать диапазон В12:В43 как разъединенные ячейки, заполненные через одну.


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
у тебя тонны с кубометрами суммируются.
Подумаешь! Получатся тонно-кубометры, все нормально.

Ну ладно, если только тонны, тогда просто первый кусок от формулы
Код
=СУММЕСЛИ(B$12:B$42;M12;I$12:I$42)

Код
=СУММПРОИЗВ((B$12:B$42=M12)*I$12:I$42)

Александр, когда ячейка объединена, то в 99,99% это означает, что значение находится в левом верхнем углу объединенной ячейки, а все остальные объединенные пусты. То есть В В12 текст есть, а в В13 - пусто. Поэтому можно рассматривать диапазон В12:В43 как разъединенные ячейки, заполненные через одну.

Автор - _Boroda_
Дата добавления - 06.06.2016 в 15:04
lebensvoll Дата: Понедельник, 06.06.2016, 15:54 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 645
Репутация: 2 ±
Замечаний: 60% ±

Excel 2010
_Boroda_, китин, ArkaIIIa, Спасибо вам огромное за помощь и разъяснения
Цитата
Александр, когда ячейка объединена, то в 99,99% это означает, что значение находится в левом верхнем углу объединенной ячейки, а все остальные объединенные пусты. То есть В В12 текст есть, а в В13 - пусто. Поэтому можно рассматривать диапазон В12:В43 как разъединенные ячейки, заполненные через одну.

Все формулы сработали. И как всегда сохраняю их в свой архив с пояснениями для себя чтоб не забывать наставления!!!!


Кто бы ты ни был, мир в твоих руках
 
Ответить
Сообщение_Boroda_, китин, ArkaIIIa, Спасибо вам огромное за помощь и разъяснения
Цитата
Александр, когда ячейка объединена, то в 99,99% это означает, что значение находится в левом верхнем углу объединенной ячейки, а все остальные объединенные пусты. То есть В В12 текст есть, а в В13 - пусто. Поэтому можно рассматривать диапазон В12:В43 как разъединенные ячейки, заполненные через одну.

Все формулы сработали. И как всегда сохраняю их в свой архив с пояснениями для себя чтоб не забывать наставления!!!!

Автор - lebensvoll
Дата добавления - 06.06.2016 в 15:54
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование массивов через поиск (но объединенные ячейки) (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!