Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Табель учета рабочего времени - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Табель учета рабочего времени (Формулы/Formulas)
Табель учета рабочего времени
Sem1970 Дата: Вторник, 07.06.2016, 12:59 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 75
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте знатоки!
Прошу Вас оказать помощь, есть табель в нем прописаны формулы автоматического заполнения ячеек. Сегодня бухгалтерия "обрадовала" меня и сказала чтобы отсутствия работников необходимо заполнять 8,15 час. с понедельника по четверг включительно, в пятницу 7 час. В приложенном файле написано как должно быть, и как сейчас считает.

У большим уважением,

Семен.
К сообщению приложен файл: 8801429.xlsx(59Kb)
 
Ответить
СообщениеЗдравствуйте знатоки!
Прошу Вас оказать помощь, есть табель в нем прописаны формулы автоматического заполнения ячеек. Сегодня бухгалтерия "обрадовала" меня и сказала чтобы отсутствия работников необходимо заполнять 8,15 час. с понедельника по четверг включительно, в пятницу 7 час. В приложенном файле написано как должно быть, и как сейчас считает.

У большим уважением,

Семен.

Автор - Sem1970
Дата добавления - 07.06.2016 в 12:59
_Boroda_ Дата: Вторник, 07.06.2016, 13:14 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Везде, где в формуле написано 8,15, вместо этого 8,15 напишите вот так
Код
ЕСЛИ(ДЕНЬНЕД(AH$11;2)=5;7;8,15)

В формулу не вдумывался, хотя что-то знакомое. В итоге после тупой замены получится вот так
Код
=ЕСЛИ(AH22="О";(ЕСЛИ(AH$11="";"";ЕСЛИ(И(AH$11>=$AG9;AH$11<=FQ14);"Б";ЕСЛИ(НЕ(ЕОШИБКА(ВПР(AH$11;предпр;1;0)=AH$11));$FP14*8-1;ЕСЛИ(НЕ(ЕОШИБКА(ВПР(AH$11;выхрабд;1;0)=AH$11));$AG9*ЕСЛИ(ДЕНЬНЕД(AH$11;2)=5;7;8,15);ЕСЛИ(ИЛИ(ДЕНЬНЕД(AH$11;2)>5;ЕЧИСЛО(ПОИСКПОЗ(AH$11;празд;0));СУММПРОИЗВ(1*(AH$11=допнер)));"";ЕСЛИ(ДЕНЬНЕД(AH$11;2)<6;$AG9*ЕСЛИ(ДЕНЬНЕД(AH$11;2)=5;7;8,15))))))));ЕСЛИ(AH22="Б";ЕСЛИ(ДЕНЬНЕД(AH$11;2)=5;7;8,15);""))
К сообщению приложен файл: 8801429_1.xlsx(60Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВезде, где в формуле написано 8,15, вместо этого 8,15 напишите вот так
Код
ЕСЛИ(ДЕНЬНЕД(AH$11;2)=5;7;8,15)

В формулу не вдумывался, хотя что-то знакомое. В итоге после тупой замены получится вот так
Код
=ЕСЛИ(AH22="О";(ЕСЛИ(AH$11="";"";ЕСЛИ(И(AH$11>=$AG9;AH$11<=FQ14);"Б";ЕСЛИ(НЕ(ЕОШИБКА(ВПР(AH$11;предпр;1;0)=AH$11));$FP14*8-1;ЕСЛИ(НЕ(ЕОШИБКА(ВПР(AH$11;выхрабд;1;0)=AH$11));$AG9*ЕСЛИ(ДЕНЬНЕД(AH$11;2)=5;7;8,15);ЕСЛИ(ИЛИ(ДЕНЬНЕД(AH$11;2)>5;ЕЧИСЛО(ПОИСКПОЗ(AH$11;празд;0));СУММПРОИЗВ(1*(AH$11=допнер)));"";ЕСЛИ(ДЕНЬНЕД(AH$11;2)<6;$AG9*ЕСЛИ(ДЕНЬНЕД(AH$11;2)=5;7;8,15))))))));ЕСЛИ(AH22="Б";ЕСЛИ(ДЕНЬНЕД(AH$11;2)=5;7;8,15);""))

Автор - _Boroda_
Дата добавления - 07.06.2016 в 13:14
Sem1970 Дата: Вторник, 07.06.2016, 13:20 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 75
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
СПАСИБО!!! hands
Сейчас все проверю и отпишусь.
С уважением,
Семен.
 
Ответить
СообщениеСПАСИБО!!! hands
Сейчас все проверю и отпишусь.
С уважением,
Семен.

Автор - Sem1970
Дата добавления - 07.06.2016 в 13:20
Sem1970 Дата: Вторник, 07.06.2016, 13:22 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 75
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Все так как надо!
Очередной раз Вам благодарен за помощь!

С большим уважением,
Семен. :D
 
Ответить
СообщениеВсе так как надо!
Очередной раз Вам благодарен за помощь!

С большим уважением,
Семен. :D

Автор - Sem1970
Дата добавления - 07.06.2016 в 13:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Табель учета рабочего времени (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!