Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сопоставить суммы по разным спискам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сопоставить суммы по разным спискам (Формулы/Formulas)
Сопоставить суммы по разным спискам
vermut Дата: Пятница, 10.06.2016, 10:06 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 88
Репутация: 0 ±
Замечаний: 60% ±

Excel 2013
Всем привет! Tcnm 2 списка по 2 столбца в каждом с контрагентами и кол-вом, причем в одном списке контрагенты повторяются, надо сопоставить суммы по каждому контрагенту. Файлик приложила :D
К сообщению приложен файл: 3028049.xlsx(15Kb)
 
Ответить
СообщениеВсем привет! Tcnm 2 списка по 2 столбца в каждом с контрагентами и кол-вом, причем в одном списке контрагенты повторяются, надо сопоставить суммы по каждому контрагенту. Файлик приложила :D

Автор - vermut
Дата добавления - 10.06.2016 в 10:06
pabchek Дата: Пятница, 10.06.2016, 10:14 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 646
Репутация: 146 ±
Замечаний: 0% ±

Excel 2007
Здрасте!
Так надо?
Код
=СУММЕСЛИ(E$2:E$12;B2;F$2:F$12)

Код
=СУММПРОИЗВ((E$2:E$12=B2)*F$2:F$12)

ну и массивная
Код
=СУММ((E$2:E$12=B2)*F$2:F$12)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Пятница, 10.06.2016, 10:17
 
Ответить
СообщениеЗдрасте!
Так надо?
Код
=СУММЕСЛИ(E$2:E$12;B2;F$2:F$12)

Код
=СУММПРОИЗВ((E$2:E$12=B2)*F$2:F$12)

ну и массивная
Код
=СУММ((E$2:E$12=B2)*F$2:F$12)

Автор - pabchek
Дата добавления - 10.06.2016 в 10:14
_Boroda_ Дата: Пятница, 10.06.2016, 10:19 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9377
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Если сразу нужно для обоих списков и/или в обоих списках возможны повторы, то можно так
Код
=СУММЕСЛИ(B$2:E$99;B2;C$2:F$99)
К сообщению приложен файл: 3028049_1.xlsx(11Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕсли сразу нужно для обоих списков и/или в обоих списках возможны повторы, то можно так
Код
=СУММЕСЛИ(B$2:E$99;B2;C$2:F$99)

Автор - _Boroda_
Дата добавления - 10.06.2016 в 10:19
vermut Дата: Пятница, 10.06.2016, 10:23 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 88
Репутация: 0 ±
Замечаний: 60% ±

Excel 2013
Спасибо! Очень выручили :D
 
Ответить
СообщениеСпасибо! Очень выручили :D

Автор - vermut
Дата добавления - 10.06.2016 в 10:23
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сопоставить суммы по разным спискам (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!