Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет количества ячеек по 3-м критериям одной формулой. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет количества ячеек по 3-м критериям одной формулой. (Формулы/Formulas)
Подсчет количества ячеек по 3-м критериям одной формулой.
champ Дата: Понедельник, 13.06.2016, 19:24 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте,
прошу помочь с вопросом по подсчету, можно ли в прилагаемом файле обойтись без вычисления столбца С1:С10 и обойтись одной формулой.
Необходимо подсчитать количество ячеек по 3 критериям A>B, A<B, A=B
[moder]Дайте теме более конкретное название а соответствии с Правилами форума. Исправлено[/moder]
К сообщению приложен файл: 2482853.xlsx(8Kb)


Сообщение отредактировал champ - Понедельник, 13.06.2016, 19:46
 
Ответить
СообщениеЗдравствуйте,
прошу помочь с вопросом по подсчету, можно ли в прилагаемом файле обойтись без вычисления столбца С1:С10 и обойтись одной формулой.
Необходимо подсчитать количество ячеек по 3 критериям A>B, A<B, A=B
[moder]Дайте теме более конкретное название а соответствии с Правилами форума. Исправлено[/moder]

Автор - champ
Дата добавления - 13.06.2016 в 19:24
Pelena Дата: Понедельник, 13.06.2016, 19:51 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 11033
Репутация: 2462 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Если правильно поняла
Код
=СУММПРОИЗВ(--(A1:A10>B1:B10))
К сообщению приложен файл: 3699341.xlsx(9Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЕсли правильно поняла
Код
=СУММПРОИЗВ(--(A1:A10>B1:B10))

Автор - Pelena
Дата добавления - 13.06.2016 в 19:51
champ Дата: Понедельник, 13.06.2016, 20:37 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо, все так как надо
 
Ответить
СообщениеСпасибо, все так как надо

Автор - champ
Дата добавления - 13.06.2016 в 20:37
KOLLIAK Дата: Среда, 15.06.2016, 12:53 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Прошу прощения за врыв в чужую тему,

обьясните пожалуйста, что дает "--" в формуле
суммпроизв находит значение Истина или Ложь, истина это 1, ложь это 0,

"--" = "2-"??
 
Ответить
СообщениеПрошу прощения за врыв в чужую тему,

обьясните пожалуйста, что дает "--" в формуле
суммпроизв находит значение Истина или Ложь, истина это 1, ложь это 0,

"--" = "2-"??

Автор - KOLLIAK
Дата добавления - 15.06.2016 в 12:53
_Boroda_ Дата: Среда, 15.06.2016, 12:55 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 10334
Репутация: 4357 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Читали вот это?
http://www.excelworld.ru/publ/hacks/tricks/17-1-0-9

ИСТИНА вовсе не всегда равна 1, а ЛОЖЬ - 0. Для многих функций ИСТИНА и ЛОЖЬ - воспринимаются как текст, а вот двойная смена знака преобразует их в 1 и 0
Код
=СУММПРОИЗВ({ИСТИНА:ЛОЖЬ:ИСТИНА:ЛОЖЬ:ИСТИНА})
- сумма текстовых значений = 0
Код
=СУММПРОИЗВ({1:0:1:0:1})
- сумма чисел = 3


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЧитали вот это?
http://www.excelworld.ru/publ/hacks/tricks/17-1-0-9

ИСТИНА вовсе не всегда равна 1, а ЛОЖЬ - 0. Для многих функций ИСТИНА и ЛОЖЬ - воспринимаются как текст, а вот двойная смена знака преобразует их в 1 и 0
Код
=СУММПРОИЗВ({ИСТИНА:ЛОЖЬ:ИСТИНА:ЛОЖЬ:ИСТИНА})
- сумма текстовых значений = 0
Код
=СУММПРОИЗВ({1:0:1:0:1})
- сумма чисел = 3

Автор - _Boroda_
Дата добавления - 15.06.2016 в 12:55
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет количества ячеек по 3-м критериям одной формулой. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!