Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перечень номеров строк с не верными данными - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перечень номеров строк с не верными данными (Формулы/Formulas)
Перечень номеров строк с не верными данными
Leprotto Дата: Вторник, 14.06.2016, 12:52 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 75
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Добрый день всем!
Уважаемые знатоки, подскажите пожалуйста можно ли формульно решить задачку формирования списка с номерами строк, в которых введены не корректные данные.
Выпадающий список не всегда спасает. Особые товарищи копи-пастом вносят что хотят <_<
Пример во вложении
К сообщению приложен файл: poisk_oshibok.xlsx(9Kb)
 
Ответить
СообщениеДобрый день всем!
Уважаемые знатоки, подскажите пожалуйста можно ли формульно решить задачку формирования списка с номерами строк, в которых введены не корректные данные.
Выпадающий список не всегда спасает. Особые товарищи копи-пастом вносят что хотят <_<
Пример во вложении

Автор - Leprotto
Дата добавления - 14.06.2016 в 12:52
Pelena Дата: Вторник, 14.06.2016, 13:07 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9846
Репутация: 2253 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Здравствуйте.
Например, так
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(($D$2:$D$8<>"")*ЕНД(ПОИСКПОЗ($D$2:$D$8;$B$2:$B$13;0));СТРОКА($D$2:$D$8));СТРОКА(A1));"")
К сообщению приложен файл: 7320843.xlsx(10Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Например, так
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(($D$2:$D$8<>"")*ЕНД(ПОИСКПОЗ($D$2:$D$8;$B$2:$B$13;0));СТРОКА($D$2:$D$8));СТРОКА(A1));"")

Автор - Pelena
Дата добавления - 14.06.2016 в 13:07
Manyasha Дата: Вторник, 14.06.2016, 13:15 | Сообщение № 3
Группа: Модераторы
Ранг: Старожил
Сообщений: 1586
Репутация: 662 ±
Замечаний: 0% ±

Excel 2007, 2010
Leprotto, еще вариант:
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ((СЧЁТЕСЛИ($B$2:$B$13;$D$2:$D$8)=0)*ЕТЕКСТ($D$2:$D$8);СТРОКА($D$2:$D$8));СТРОКА(A1));"")
К сообщению приложен файл: poisk_oshibok-1.xlsx(11Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
СообщениеLeprotto, еще вариант:
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ((СЧЁТЕСЛИ($B$2:$B$13;$D$2:$D$8)=0)*ЕТЕКСТ($D$2:$D$8);СТРОКА($D$2:$D$8));СТРОКА(A1));"")

Автор - Manyasha
Дата добавления - 14.06.2016 в 13:15
Leprotto Дата: Вторник, 14.06.2016, 13:40 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 75
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Pelena и Manyasha, благодарю сердечно! Воспользуюсь вариантом от Pelena, т.к. он мне более понятен.
Спасибо еще раз, сам бы я не справился!
 
Ответить
СообщениеPelena и Manyasha, благодарю сердечно! Воспользуюсь вариантом от Pelena, т.к. он мне более понятен.
Спасибо еще раз, сам бы я не справился!

Автор - Leprotto
Дата добавления - 14.06.2016 в 13:40
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перечень номеров строк с не верными данными (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!