Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Если в А2-словом Один,и в Е1 прописать-Один,то в Е2-д.б.1 - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Если в А2-словом Один,и в Е1 прописать-Один,то в Е2-д.б.1 (Формулы/Formulas)
Если в А2-словом Один,и в Е1 прописать-Один,то в Е2-д.б.1
blayd2007 Дата: Суббота, 18.06.2016, 12:10 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 47
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Дорогие специалисты, появилась нужда в решении задачки:

Если в ячейке А2 написано Один, и в ячейку Е1 прописать-Один, то в ячейке Е2, должно быть-1, Если в ячейке А3 написано-Два, и в ячейку Е1 написать-Два, то в ячейке Е2, должно быть 2 и т.д. Если ячейка А4, к примеру пуста, а в ячейке Е1, стоит Три , то пусть ячейка Е2 останется пустой и красной. Если ячейки В-будут пустыми, то пусть также Е2 останется пустой и красной. Ячейки А и Е1 будут выпадающим списком. Спасибо за помощь!
К сообщению приложен файл: 1474705.zip(7Kb)
 
Ответить
СообщениеДорогие специалисты, появилась нужда в решении задачки:

Если в ячейке А2 написано Один, и в ячейку Е1 прописать-Один, то в ячейке Е2, должно быть-1, Если в ячейке А3 написано-Два, и в ячейку Е1 написать-Два, то в ячейке Е2, должно быть 2 и т.д. Если ячейка А4, к примеру пуста, а в ячейке Е1, стоит Три , то пусть ячейка Е2 останется пустой и красной. Если ячейки В-будут пустыми, то пусть также Е2 останется пустой и красной. Ячейки А и Е1 будут выпадающим списком. Спасибо за помощь!

Автор - blayd2007
Дата добавления - 18.06.2016 в 12:10
Serge_007 Дата: Суббота, 18.06.2016, 12:59 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13075
Репутация: ±
Замечаний: ±

Excel 2010
Здравствуйте

Код
=СУММПРОИЗВ((A2:A6=E1)*B2:B6)


Нули скрываем форматом:[vba]
Код
0;;""
[/vba]
Ячейку красим УФ

[p.s.]Зачем Вы файл в архиве приложили?[/p.s.]
К сообщению приложен файл: blayd2007.xls(34Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Код
=СУММПРОИЗВ((A2:A6=E1)*B2:B6)


Нули скрываем форматом:[vba]
Код
0;;""
[/vba]
Ячейку красим УФ

[p.s.]Зачем Вы файл в архиве приложили?[/p.s.]

Автор - Serge_007
Дата добавления - 18.06.2016 в 12:59
blayd2007 Дата: Суббота, 18.06.2016, 13:20 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 47
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Спасибо Serge_007, а если ячейка Е1 и Е2, это Е1 и Е14, разделенных другими ячейками?
 
Ответить
СообщениеСпасибо Serge_007, а если ячейка Е1 и Е2, это Е1 и Е14, разделенных другими ячейками?

Автор - blayd2007
Дата добавления - 18.06.2016 в 13:20
Serge_007 Дата: Суббота, 18.06.2016, 13:23 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 13075
Репутация: ±
Замечаний: ±

Excel 2010
То ничего не изменится


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеТо ничего не изменится

Автор - Serge_007
Дата добавления - 18.06.2016 в 13:23
blayd2007 Дата: Суббота, 18.06.2016, 13:40 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 47
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
У меня при нажатие на формулу, она сбивается?
К сообщению приложен файл: blayd2007.2.xls(30Kb)
 
Ответить
СообщениеУ меня при нажатие на формулу, она сбивается?

Автор - blayd2007
Дата добавления - 18.06.2016 в 13:40
Serge_007 Дата: Суббота, 18.06.2016, 13:47 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 13075
Репутация: ±
Замечаний: ±

Excel 2010
при нажатие на формулу, она сбивается
Не надо на неё нажимать - она пугается, поэтому и сбивается :)

Формулу я Вам написал:
Код
=СУММПРОИЗВ((A2:A6=E1)*B2:B6)

Самостоятельно сможете её скопировать с форума и вставить в файл?


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
при нажатие на формулу, она сбивается
Не надо на неё нажимать - она пугается, поэтому и сбивается :)

Формулу я Вам написал:
Код
=СУММПРОИЗВ((A2:A6=E1)*B2:B6)

Самостоятельно сможете её скопировать с форума и вставить в файл?

Автор - Serge_007
Дата добавления - 18.06.2016 в 13:47
blayd2007 Дата: Суббота, 18.06.2016, 13:50 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 47
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Извиняюсь, туплю, копировал без
Код
СУММПРОИЗВ

а просто
Код
СУММ
, теперь все работает!!!

Спасибо огромное Вам за терпение и помощь!!!

Я сначала вообще хотел все исполнить через
Код
=ЕСЛИ

Но очень сложным для меня оказалось, не понял как продолжить ряд
 
Ответить
СообщениеИзвиняюсь, туплю, копировал без
Код
СУММПРОИЗВ

а просто
Код
СУММ
, теперь все работает!!!

Спасибо огромное Вам за терпение и помощь!!!

Я сначала вообще хотел все исполнить через
Код
=ЕСЛИ

Но очень сложным для меня оказалось, не понял как продолжить ряд

Автор - blayd2007
Дата добавления - 18.06.2016 в 13:50
Serge_007 Дата: Суббота, 18.06.2016, 15:03 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 13075
Репутация: ±
Замечаний: ±

Excel 2010
копировал без
СУММПРОИЗВ
а просто
СУММ
И так тоже можно, но тогда формулу вводите нажатием Ctrl+Shift+Enter


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
копировал без
СУММПРОИЗВ
а просто
СУММ
И так тоже можно, но тогда формулу вводите нажатием Ctrl+Shift+Enter

Автор - Serge_007
Дата добавления - 18.06.2016 в 15:03
blayd2007 Дата: Воскресенье, 19.06.2016, 11:08 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 47
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Добрый день!
Скажите, а был ли у меня шанс вот с такой попыткой решения?
Код
=ЕСЛИ(A2="Один";ЕСЛИ(E1="Один";B2;))


Спасибо!
К сообщению приложен файл: blayd2007.3.xls(28Kb)
 
Ответить
СообщениеДобрый день!
Скажите, а был ли у меня шанс вот с такой попыткой решения?
Код
=ЕСЛИ(A2="Один";ЕСЛИ(E1="Один";B2;))


Спасибо!

Автор - blayd2007
Дата добавления - 19.06.2016 в 11:08
ShAM Дата: Воскресенье, 19.06.2016, 14:42 | Сообщение № 10
Группа: Друзья
Ранг: Старожил
Сообщений: 1233
Репутация: 209 ±
Замечаний: 0% ±

Excel 2010
Тогда, может, так:
Код
=ЕСЛИ(E1="Один";B2;ЕСЛИ(E1="Два";B3;ЕСЛИ(E1="Три";B4;ЕСЛИ(E1="Четыре";B5;ЕСЛИ(E1="Пять";B6;)))))

Или так:
Код
=ЕСЛИ(E1=A2;B2;ЕСЛИ(E1=A3;B3;ЕСЛИ(E1=A4;B4;ЕСЛИ(E1=A5;B5;ЕСЛИ(E1=A6;B6;)))))

А можно и так:
Код
=ИНДЕКС(B2:B6;ПОИСКПОЗ(E1;A2:A6;))
К сообщению приложен файл: blayd2007.5.xls(30Kb)


Сообщение отредактировал ShAM - Понедельник, 20.06.2016, 02:02
 
Ответить
СообщениеТогда, может, так:
Код
=ЕСЛИ(E1="Один";B2;ЕСЛИ(E1="Два";B3;ЕСЛИ(E1="Три";B4;ЕСЛИ(E1="Четыре";B5;ЕСЛИ(E1="Пять";B6;)))))

Или так:
Код
=ЕСЛИ(E1=A2;B2;ЕСЛИ(E1=A3;B3;ЕСЛИ(E1=A4;B4;ЕСЛИ(E1=A5;B5;ЕСЛИ(E1=A6;B6;)))))

А можно и так:
Код
=ИНДЕКС(B2:B6;ПОИСКПОЗ(E1;A2:A6;))

Автор - ShAM
Дата добавления - 19.06.2016 в 14:42
blayd2007 Дата: Воскресенье, 19.06.2016, 21:51 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 47
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Спасибо большое, очень исчерпывающе и познавательно!
Спасибо!
 
Ответить
СообщениеСпасибо большое, очень исчерпывающе и познавательно!
Спасибо!

Автор - blayd2007
Дата добавления - 19.06.2016 в 21:51
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Если в А2-словом Один,и в Е1 прописать-Один,то в Е2-д.б.1 (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!