Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подтягивание последних данных в ячейки с адресами - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подтягивание последних данных в ячейки с адресами (Формулы/Formulas)
Подтягивание последних данных в ячейки с адресами
IvanK0 Дата: Воскресенье, 19.06.2016, 21:17 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Доброго времени знатоки Excel! надеюсь на Вашу помощь . Во вложении нах-ся файл с размещением деталей на складе. Все дело в том , что адрес на складе динамический , т.е. как только деталь номер №1 уходит с ячейки на ее место может встать другая деталь №2 , к примеру . Необходимо вести учет строго по ячейкам с адресами хранения для понимания , что за конкретная деталь стоит и сколько ее на этом адресе осталось. Как задать правильно условие , чтобы под конкретный адрес ячейки склада происходил поиск данных по приходу и расходу , но с учетом последней информации потому какая последняя деталь была учтена на этом адресе (на примере деталь №2 на адресе B03-01-02-0 автоматически должно быть 150 в случае прихода).
К сообщению приложен файл: ___.xlsx(14Kb)
 
Ответить
СообщениеДоброго времени знатоки Excel! надеюсь на Вашу помощь . Во вложении нах-ся файл с размещением деталей на складе. Все дело в том , что адрес на складе динамический , т.е. как только деталь номер №1 уходит с ячейки на ее место может встать другая деталь №2 , к примеру . Необходимо вести учет строго по ячейкам с адресами хранения для понимания , что за конкретная деталь стоит и сколько ее на этом адресе осталось. Как задать правильно условие , чтобы под конкретный адрес ячейки склада происходил поиск данных по приходу и расходу , но с учетом последней информации потому какая последняя деталь была учтена на этом адресе (на примере деталь №2 на адресе B03-01-02-0 автоматически должно быть 150 в случае прихода).

Автор - IvanK0
Дата добавления - 19.06.2016 в 21:17
Nic70y Дата: Воскресенье, 19.06.2016, 21:34 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3484
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
так что ли?
Код
=СУММЕСЛИМН('история приход'!D$8:D$18;'история приход'!B$8:B$18;A6;'история приход'!C$8:C$18;C6)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениетак что ли?
Код
=СУММЕСЛИМН('история приход'!D$8:D$18;'история приход'!B$8:B$18;A6;'история приход'!C$8:C$18;C6)

Автор - Nic70y
Дата добавления - 19.06.2016 в 21:34
Pelena Дата: Воскресенье, 19.06.2016, 21:38 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9871
Репутация: 2263 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Или что-то вроде
Код
=ЕСЛИОШИБКА(ПРОСМОТР(2;1/('история приход'!$B$8:$B$18=A2);'история приход'!$D$8:$D$18);"")


Перевложила файл
К сообщению приложен файл: 5663969.xlsx(15Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816


Сообщение отредактировал Pelena - Воскресенье, 19.06.2016, 21:40
 
Ответить
СообщениеИли что-то вроде
Код
=ЕСЛИОШИБКА(ПРОСМОТР(2;1/('история приход'!$B$8:$B$18=A2);'история приход'!$D$8:$D$18);"")


Перевложила файл

Автор - Pelena
Дата добавления - 19.06.2016 в 21:38
китин Дата: Понедельник, 20.06.2016, 07:32 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3450
Репутация: 549 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
или ВПР
Код
=ЕСЛИОШИБКА(ВПР($A2;'история приход'!$B$8:$D$18;3;0);"")

неа не пойдет
так наверно лучше: массивная
Код
=СУММ(ЕСЛИ((A2&C2='история приход'!$B$8:$B$18&'история приход'!$C$8:$C$18);'история приход'!$D$8:$D$18))

файл перевложил
К сообщению приложен файл: 123.xlsx(15Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Понедельник, 20.06.2016, 07:47
 
Ответить
Сообщениеили ВПР
Код
=ЕСЛИОШИБКА(ВПР($A2;'история приход'!$B$8:$D$18;3;0);"")

неа не пойдет
так наверно лучше: массивная
Код
=СУММ(ЕСЛИ((A2&C2='история приход'!$B$8:$B$18&'история приход'!$C$8:$C$18);'история приход'!$D$8:$D$18))

файл перевложил

Автор - китин
Дата добавления - 20.06.2016 в 07:32
IvanK0 Дата: Вторник, 30.08.2016, 21:03 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Извиняюсь, что не отписался . Спасибо, Все работает.
 
Ответить
СообщениеИзвиняюсь, что не отписался . Спасибо, Все работает.

Автор - IvanK0
Дата добавления - 30.08.2016 в 21:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подтягивание последних данных в ячейки с адресами (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!