Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбор текстовых и числовых значений по заполненной строке. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор текстовых и числовых значений по заполненной строке. (Формулы/Formulas)
Выбор текстовых и числовых значений по заполненной строке.
serakuz Дата: Вторник, 21.06.2016, 16:24 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Очень нужна помощь, уже 2-е недели бьюсь над проблемой, но в силу отсутствия опыта не получается. О главном:
Из таблицы “Ввод” (вкладка) автоматически переносятся данные в таблицу “Брак”(вкладка), по столбцам (A,B,C,D,E) – проблем не возникла, не получается правильно заполнить столбцы (F,G) соответствующие строке так, как нет критерия в названии для сопоставления, желательно обойтись без добавления лишних столбцов.
%)
К сообщению приложен файл: 01.06.1610.xlsx(69Kb)


Ищущий, да найдет…
 
Ответить
СообщениеОчень нужна помощь, уже 2-е недели бьюсь над проблемой, но в силу отсутствия опыта не получается. О главном:
Из таблицы “Ввод” (вкладка) автоматически переносятся данные в таблицу “Брак”(вкладка), по столбцам (A,B,C,D,E) – проблем не возникла, не получается правильно заполнить столбцы (F,G) соответствующие строке так, как нет критерия в названии для сопоставления, желательно обойтись без добавления лишних столбцов.
%)

Автор - serakuz
Дата добавления - 21.06.2016 в 16:24
Nic70y Дата: Вторник, 21.06.2016, 20:07 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3469
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Код
=ИНДЕКС(Таблица2[[#Заголовки];[Дата]:[Н.П.]];ОКРУГЛ(ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(1/ЕСЛИ([@Станок]=Таблица2[Станок];Таблица2[[Нал.]:[Н.П.]]));СТРОКА(Таблица2[Дата])+СТОЛБЕЦ(Таблица2[[#Заголовки];[Нал.]:[Н.П.]])/100);СЧЁТЕСЛИ(B$3:B3;B3));1)*100;))
Код
=ИНДЕКС(Таблица2[[Дата]:[Н.П.]];НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(1/ЕСЛИ([@Станок]=Таблица2[Станок];Таблица2[[Нал.]:[Н.П.]]));СТРОКА(Таблица2[Дата]));СЧЁТЕСЛИ(B$3:B3;B3))-2;ОКРУГЛ(ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(1/ЕСЛИ([@Станок]=Таблица2[Станок];Таблица2[[Нал.]:[Н.П.]]));СТРОКА(Таблица2[Дата])+СТОЛБЕЦ(Таблица2[[#Заголовки];[Нал.]:[Н.П.]])/100);СЧЁТЕСЛИ(B$3:B3;B3));1)*100;))
К сообщению приложен файл: 2988438.xlsx(67Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=ИНДЕКС(Таблица2[[#Заголовки];[Дата]:[Н.П.]];ОКРУГЛ(ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(1/ЕСЛИ([@Станок]=Таблица2[Станок];Таблица2[[Нал.]:[Н.П.]]));СТРОКА(Таблица2[Дата])+СТОЛБЕЦ(Таблица2[[#Заголовки];[Нал.]:[Н.П.]])/100);СЧЁТЕСЛИ(B$3:B3;B3));1)*100;))
Код
=ИНДЕКС(Таблица2[[Дата]:[Н.П.]];НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(1/ЕСЛИ([@Станок]=Таблица2[Станок];Таблица2[[Нал.]:[Н.П.]]));СТРОКА(Таблица2[Дата]));СЧЁТЕСЛИ(B$3:B3;B3))-2;ОКРУГЛ(ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(1/ЕСЛИ([@Станок]=Таблица2[Станок];Таблица2[[Нал.]:[Н.П.]]));СТРОКА(Таблица2[Дата])+СТОЛБЕЦ(Таблица2[[#Заголовки];[Нал.]:[Н.П.]])/100);СЧЁТЕСЛИ(B$3:B3;B3));1)*100;))

Автор - Nic70y
Дата добавления - 21.06.2016 в 20:07
serakuz Дата: Вторник, 21.06.2016, 22:37 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Nic70y_

Огромное Вам спасибо, за помощь!!!
Вряд ли пойму, как это работает, но попробую разобраться.
Нет предела совершенству!!! yes
Постараюсь отблагодарить со временем.
Работает отлично, хотя файл открывает с глюком. hands
Тема закрыта. :D


Ищущий, да найдет…
 
Ответить
Сообщение_Nic70y_

Огромное Вам спасибо, за помощь!!!
Вряд ли пойму, как это работает, но попробую разобраться.
Нет предела совершенству!!! yes
Постараюсь отблагодарить со временем.
Работает отлично, хотя файл открывает с глюком. hands
Тема закрыта. :D

Автор - serakuz
Дата добавления - 21.06.2016 в 22:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор текстовых и числовых значений по заполненной строке. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!