Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Необходимо затянуть данные по критерию! - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Необходимо затянуть данные по критерию! (Формулы/Formulas)
Необходимо затянуть данные по критерию!
andreyyuryev Дата: Среда, 22.06.2016, 17:47 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте, уважаемые форумчане!

Пожалуйста, смотрите приложенный файл.
Необходимо со страницы Stock_report затянуть на страницу Matrix данные по складским остаткам по каждой товарной позиции по всем складам. Зацепка для отбора склада весьма скудная (отметил желтым на странице Stock_report) - так настроена ERP система.
Можно ли сделать?

Заранее признателен а помощь!
К сообщению приложен файл: 4778575.xlsx(82Kb)
 
Ответить
СообщениеЗдравствуйте, уважаемые форумчане!

Пожалуйста, смотрите приложенный файл.
Необходимо со страницы Stock_report затянуть на страницу Matrix данные по складским остаткам по каждой товарной позиции по всем складам. Зацепка для отбора склада весьма скудная (отметил желтым на странице Stock_report) - так настроена ERP система.
Можно ли сделать?

Заранее признателен а помощь!

Автор - andreyyuryev
Дата добавления - 22.06.2016 в 17:47
abtextime Дата: Среда, 22.06.2016, 18:03 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 427
Репутация: 60 ±
Замечаний: 0% ±

Excel 2010
Дополнительный столбец в Stock_report - допускается?
 
Ответить
СообщениеДополнительный столбец в Stock_report - допускается?

Автор - abtextime
Дата добавления - 22.06.2016 в 18:03
andreyyuryev Дата: Среда, 22.06.2016, 18:09 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
abtextime, Это вытяжка из ERP системы. В таком формате формируется отчет. В любом случае, предлагайте, пожалуйста, свой способ. Спасибо!
 
Ответить
Сообщениеabtextime, Это вытяжка из ERP системы. В таком формате формируется отчет. В любом случае, предлагайте, пожалуйста, свой способ. Спасибо!

Автор - andreyyuryev
Дата добавления - 22.06.2016 в 18:09
abtextime Дата: Среда, 22.06.2016, 18:48 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 427
Репутация: 60 ±
Замечаний: 0% ±

Excel 2010
В доп столбец J листа Stock_report
Код
=ЕСЛИ(ЛЕВБ(G4;5)="Итого";"";ПОДСТАВИТЬ(ИНДЕКС(G4:G$404;ПОИСКПОЗ("Итого по W*";G4:G$404;0));"Итого по ";""))


в столбец H листа Matrix
Код
=СУММЕСЛИМН(Stock_Report!$I$4:$I$405;Stock_Report!$B$4:$B$405;$B6;Stock_Report!$J$4:$J$405;ПОДСТАВИТЬ($H$1;"Stock ";""))


в столбец I листа Matrix
Код
=СУММЕСЛИМН(Stock_Report!$H$4:$H$405;Stock_Report!$B$4:$B$405;$B6;Stock_Report!$J$4:$J$405;ПОДСТАВИТЬ($I$1;"Free ";""))


Столбцы J...Q по аналогии

Можно от допстолбца избавиться, но что-то уже "закипаю"

UPD. Для копирования вправо лучше вместо $H$1 и $I$1 использовать H$1 и I$1
К сообщению приложен файл: 1703096.xlsx(96Kb)


Сообщение отредактировал abtextime - Среда, 22.06.2016, 18:50
 
Ответить
СообщениеВ доп столбец J листа Stock_report
Код
=ЕСЛИ(ЛЕВБ(G4;5)="Итого";"";ПОДСТАВИТЬ(ИНДЕКС(G4:G$404;ПОИСКПОЗ("Итого по W*";G4:G$404;0));"Итого по ";""))


в столбец H листа Matrix
Код
=СУММЕСЛИМН(Stock_Report!$I$4:$I$405;Stock_Report!$B$4:$B$405;$B6;Stock_Report!$J$4:$J$405;ПОДСТАВИТЬ($H$1;"Stock ";""))


в столбец I листа Matrix
Код
=СУММЕСЛИМН(Stock_Report!$H$4:$H$405;Stock_Report!$B$4:$B$405;$B6;Stock_Report!$J$4:$J$405;ПОДСТАВИТЬ($I$1;"Free ";""))


Столбцы J...Q по аналогии

Можно от допстолбца избавиться, но что-то уже "закипаю"

UPD. Для копирования вправо лучше вместо $H$1 и $I$1 использовать H$1 и I$1

Автор - abtextime
Дата добавления - 22.06.2016 в 18:48
_Boroda_ Дата: Среда, 22.06.2016, 21:58 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9371
Репутация: 3947 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Без допстолбцов. Одинаковая формула на весь диапазон. Как ни странно - немассивная формула
Код
=ЕСЛИОШИБКА(СУММПРОИЗВ((Stock_Report!$A$4:$A$405=$A6)*(Stock_Report!$B$4:$B$405=$B6)*(Stock_Report!$C$4:$C$405=$C6)*(Stock_Report!$F$4:$F$405=СЖПРОБЕЛЫ($F6))*(Stock_Report!$G$4:$G$405=СЖПРОБЕЛЫ($G6))*(СТРОКА(Stock_Report!$A$4:$A$405)<ПОИСКПОЗ("*"&ПРАВБ(H$1;4);Stock_Report!$G$1:$G$405;))*(СТРОКА(Stock_Report!$A$4:$A$405)>ИНДЕКС(ПРОСМОТР(СТРОКА(Stock_Report!$A$3:$A$405);СТРОКА(Stock_Report!$A$3:$A$405)/ЕПУСТО(Stock_Report!$A$3:$A$405);СТРОКА(Stock_Report!$A$3:$A$405));ПОИСКПОЗ("*"&ПРАВБ(Matrix!H$1;4);Stock_Report!$G$4:$G$405;);))*Stock_Report!$H$4:$I$405*(Stock_Report!$H$1:$I$1=ЛЕВБ(H$1;ПОИСК(" ";H$1)-1)));)

andreyyuryev, в листе Stock_Report красным в столбце В выделил тех, у кого в листе Matrix в столбцах F и G лишние пробелы. Это только для информации, формула их все равно считает
Вот так наверное лучше
Код
=ЕСЛИОШИБКА(СУММПРОИЗВ((Stock_Report!$A$4:$A$405=$A6)*(Stock_Report!$B$4:$B$405=$B6)*(Stock_Report!$C$4:$C$405=$C6)*(Stock_Report!$F$4:$F$405=СЖПРОБЕЛЫ($F6))*(Stock_Report!$G$4:$G$405=СЖПРОБЕЛЫ($G6))*(СТРОКА(Stock_Report!$A$4:$A$405)<ПОИСКПОЗ("*"&ПСТР(H$1;ПОИСК(" ";H$1)+1;9);Stock_Report!$G$1:$G$405;))*(СТРОКА(Stock_Report!$A$4:$A$405)>ИНДЕКС(ПРОСМОТР(СТРОКА(Stock_Report!$A$3:$A$405);СТРОКА(Stock_Report!$A$3:$A$405)/ЕПУСТО(Stock_Report!$A$3:$A$405);СТРОКА(Stock_Report!$A$3:$A$405));ПОИСКПОЗ("*"&ПРАВБ(Matrix!H$1;4);Stock_Report!$G$4:$G$405;);))*Stock_Report!$H$4:$I$405*(Stock_Report!$H$1:$I$1=ЛЕВБ(H$1;ПОИСК(" ";H$1)-1)));)

Файл перевложил
К сообщению приложен файл: 4778575_2.xlsb(60Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеБез допстолбцов. Одинаковая формула на весь диапазон. Как ни странно - немассивная формула
Код
=ЕСЛИОШИБКА(СУММПРОИЗВ((Stock_Report!$A$4:$A$405=$A6)*(Stock_Report!$B$4:$B$405=$B6)*(Stock_Report!$C$4:$C$405=$C6)*(Stock_Report!$F$4:$F$405=СЖПРОБЕЛЫ($F6))*(Stock_Report!$G$4:$G$405=СЖПРОБЕЛЫ($G6))*(СТРОКА(Stock_Report!$A$4:$A$405)<ПОИСКПОЗ("*"&ПРАВБ(H$1;4);Stock_Report!$G$1:$G$405;))*(СТРОКА(Stock_Report!$A$4:$A$405)>ИНДЕКС(ПРОСМОТР(СТРОКА(Stock_Report!$A$3:$A$405);СТРОКА(Stock_Report!$A$3:$A$405)/ЕПУСТО(Stock_Report!$A$3:$A$405);СТРОКА(Stock_Report!$A$3:$A$405));ПОИСКПОЗ("*"&ПРАВБ(Matrix!H$1;4);Stock_Report!$G$4:$G$405;);))*Stock_Report!$H$4:$I$405*(Stock_Report!$H$1:$I$1=ЛЕВБ(H$1;ПОИСК(" ";H$1)-1)));)

andreyyuryev, в листе Stock_Report красным в столбце В выделил тех, у кого в листе Matrix в столбцах F и G лишние пробелы. Это только для информации, формула их все равно считает
Вот так наверное лучше
Код
=ЕСЛИОШИБКА(СУММПРОИЗВ((Stock_Report!$A$4:$A$405=$A6)*(Stock_Report!$B$4:$B$405=$B6)*(Stock_Report!$C$4:$C$405=$C6)*(Stock_Report!$F$4:$F$405=СЖПРОБЕЛЫ($F6))*(Stock_Report!$G$4:$G$405=СЖПРОБЕЛЫ($G6))*(СТРОКА(Stock_Report!$A$4:$A$405)<ПОИСКПОЗ("*"&ПСТР(H$1;ПОИСК(" ";H$1)+1;9);Stock_Report!$G$1:$G$405;))*(СТРОКА(Stock_Report!$A$4:$A$405)>ИНДЕКС(ПРОСМОТР(СТРОКА(Stock_Report!$A$3:$A$405);СТРОКА(Stock_Report!$A$3:$A$405)/ЕПУСТО(Stock_Report!$A$3:$A$405);СТРОКА(Stock_Report!$A$3:$A$405));ПОИСКПОЗ("*"&ПРАВБ(Matrix!H$1;4);Stock_Report!$G$4:$G$405;);))*Stock_Report!$H$4:$I$405*(Stock_Report!$H$1:$I$1=ЛЕВБ(H$1;ПОИСК(" ";H$1)-1)));)

Файл перевложил

Автор - _Boroda_
Дата добавления - 22.06.2016 в 21:58
andreyyuryev Дата: Пятница, 24.06.2016, 12:48 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
abtextime, СПАСИБО!
 
Ответить
Сообщениеabtextime, СПАСИБО!

Автор - andreyyuryev
Дата добавления - 24.06.2016 в 12:48
andreyyuryev Дата: Пятница, 24.06.2016, 12:49 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
_Boroda_, СПАСИБО! Фантастическая формула получилась!)
 
Ответить
Сообщение_Boroda_, СПАСИБО! Фантастическая формула получилась!)

Автор - andreyyuryev
Дата добавления - 24.06.2016 в 12:49
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Необходимо затянуть данные по критерию! (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!