Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет значений по условию из массива - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет значений по условию из массива (Формулы/Formulas)
Подсчет значений по условию из массива
VadimVV Дата: Четверг, 23.06.2016, 18:12 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 79
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Добрый день.

Есть повторяющийся список товаров на одном листе, на втором листе есть данные о кол-ве реализации товара по магазинам.
Необходимо на первом листе проставить сумму реализованных товаров исходя из данных второго листа.

Вроде бы несложно, я при суммировании использую ИНДЕКС и ПОИСКПОЗ, но корректно считает только те позиции, у которых в первой ячейке стоит 1, т.е. сумму по товару 1 не считает.

Прошу помочь. Пример прикладываю.
К сообщению приложен файл: 5701182.xlsx(9Kb)


Сообщение отредактировал VadimVV - Четверг, 23.06.2016, 18:33
 
Ответить
СообщениеДобрый день.

Есть повторяющийся список товаров на одном листе, на втором листе есть данные о кол-ве реализации товара по магазинам.
Необходимо на первом листе проставить сумму реализованных товаров исходя из данных второго листа.

Вроде бы несложно, я при суммировании использую ИНДЕКС и ПОИСКПОЗ, но корректно считает только те позиции, у которых в первой ячейке стоит 1, т.е. сумму по товару 1 не считает.

Прошу помочь. Пример прикладываю.

Автор - VadimVV
Дата добавления - 23.06.2016 в 18:12
abtextime Дата: Четверг, 23.06.2016, 18:14 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 427
Репутация: 60 ±
Замечаний: 0% ±

Excel 2010
проверьте - тот ли файл прицепили к сообщению?
 
Ответить
Сообщениепроверьте - тот ли файл прицепили к сообщению?

Автор - abtextime
Дата добавления - 23.06.2016 в 18:14
VadimVV Дата: Четверг, 23.06.2016, 18:32 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 79
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Сначала не тот, но теперь вроде тот
 
Ответить
СообщениеСначала не тот, но теперь вроде тот

Автор - VadimVV
Дата добавления - 23.06.2016 в 18:32
abtextime Дата: Четверг, 23.06.2016, 18:59 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 427
Репутация: 60 ±
Замечаний: 0% ±

Excel 2010
Чтобы понять, что реально Вам нужно - напишите - вот такой вариант чем не устраивает?

С суммами на Листе 2

Код
=ИНДЕКС(Лист2!$B$13:$E$13;1;ПОИСКПОЗ(A2;Лист2!$B$1:$E$1))
К сообщению приложен файл: 9462144.xlsx(10Kb)
 
Ответить
СообщениеЧтобы понять, что реально Вам нужно - напишите - вот такой вариант чем не устраивает?

С суммами на Листе 2

Код
=ИНДЕКС(Лист2!$B$13:$E$13;1;ПОИСКПОЗ(A2;Лист2!$B$1:$E$1))

Автор - abtextime
Дата добавления - 23.06.2016 в 18:59
Nic70y Дата: Четверг, 23.06.2016, 19:03 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3908
Репутация: 827 ±
Замечаний: 0% ±

Excel 2013
Код
=СУММ(ИНДЕКС(Лист2!$B$2:$E$12;;ПОИСКПОЗ(A2;Лист2!B$1:E$1;)))


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Четверг, 23.06.2016, 19:03
 
Ответить
Сообщение
Код
=СУММ(ИНДЕКС(Лист2!$B$2:$E$12;;ПОИСКПОЗ(A2;Лист2!B$1:E$1;)))

Автор - Nic70y
Дата добавления - 23.06.2016 в 19:03
китин Дата: Пятница, 24.06.2016, 07:36 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4094
Репутация: 632 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Код
=СУММПРОИЗВ(Лист2!$B$2:$E$13*(Лист2!$B$1:$E$1=Лист3!$A2))
К сообщению приложен файл: 456.xlsx(10Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(Лист2!$B$2:$E$13*(Лист2!$B$1:$E$1=Лист3!$A2))

Автор - китин
Дата добавления - 24.06.2016 в 07:36
VadimVV Дата: Пятница, 24.06.2016, 09:48 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 79
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Спасибо. Всё достаточно просто оказалось...
 
Ответить
СообщениеСпасибо. Всё достаточно просто оказалось...

Автор - VadimVV
Дата добавления - 24.06.2016 в 09:48
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет значений по условию из массива (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!