Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет кол-ва значений по условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет кол-ва значений по условию (Формулы/Formulas)
Подсчет кол-ва значений по условию
VadimVV Дата: Суббота, 25.06.2016, 02:32 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 79
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Добрый день.
С очередным вопросом....

Есть кусок сводной таблицы с некоторыми параметрами, есть перечень объектов, есть кол-во приходов.
На Листе2 проставлены значения напротив каждого объекта.
На листе 3 я посчитал общее кол-во приходов для каждого объекта.

Но не могу теперь посчитать для каждого объекта кол-во приходов, если их было больше 1. Т.е., если напротив какого-то объекта на листе2 стоит кол-во приходов 2, 3, 7, 4 то на листе 3 напротив этого объекта должно стоять значение 4 (т.е. подсчет кол-ва приходов более 1 раза).

Могу, конечно, решить задачу сводной таблицей, но бьюсь с формулами, разные вариации перепробовал. Не могу сообразить, как изогнуть СЧЁТЕСЛИ, чтобы она из столбца А на листе2 выбирала наименования объектов из столбца А на листе3 и считала кол-во приходов >1 из столбца В на листе2.

Пример прилагаю.
К сообщению приложен файл: _Microsoft_Exce.xlsx(33Kb)
 
Ответить
СообщениеДобрый день.
С очередным вопросом....

Есть кусок сводной таблицы с некоторыми параметрами, есть перечень объектов, есть кол-во приходов.
На Листе2 проставлены значения напротив каждого объекта.
На листе 3 я посчитал общее кол-во приходов для каждого объекта.

Но не могу теперь посчитать для каждого объекта кол-во приходов, если их было больше 1. Т.е., если напротив какого-то объекта на листе2 стоит кол-во приходов 2, 3, 7, 4 то на листе 3 напротив этого объекта должно стоять значение 4 (т.е. подсчет кол-ва приходов более 1 раза).

Могу, конечно, решить задачу сводной таблицей, но бьюсь с формулами, разные вариации перепробовал. Не могу сообразить, как изогнуть СЧЁТЕСЛИ, чтобы она из столбца А на листе2 выбирала наименования объектов из столбца А на листе3 и считала кол-во приходов >1 из столбца В на листе2.

Пример прилагаю.

Автор - VadimVV
Дата добавления - 25.06.2016 в 02:32
китин Дата: Суббота, 25.06.2016, 07:51 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3720
Репутация: 573 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а вот как понял. формула массива
Код
=СЧЁТ(ЕСЛИ((A2=Лист2!$A$2:$A$1831)*(Лист2!$B$2:$B$1831>1);Лист2!$B$2:$B$1831))
К сообщению приложен файл: 567.xlsx(35Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеа вот как понял. формула массива
Код
=СЧЁТ(ЕСЛИ((A2=Лист2!$A$2:$A$1831)*(Лист2!$B$2:$B$1831>1);Лист2!$B$2:$B$1831))

Автор - китин
Дата добавления - 25.06.2016 в 07:51
buchlotnik Дата: Суббота, 25.06.2016, 13:12 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2205
Репутация: 659 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
вот такая немассивка вышла:
Код
=СУММПРОИЗВ((Лист2!$A$2:$A$1831=A2)*(Лист2!$B$2:$B$1831>1))
К сообщению приложен файл: 7469986.xlsx(33Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениевот такая немассивка вышла:
Код
=СУММПРОИЗВ((Лист2!$A$2:$A$1831=A2)*(Лист2!$B$2:$B$1831>1))

Автор - buchlotnik
Дата добавления - 25.06.2016 в 13:12
VadimVV Дата: Суббота, 25.06.2016, 13:49 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 79
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
спасибо, помогли. А я сложное решение искал, через поиск в каждой строке наименования объекта и счёта ячеек, если значение >1. А тут вот как просто.
 
Ответить
Сообщениеспасибо, помогли. А я сложное решение искал, через поиск в каждой строке наименования объекта и счёта ячеек, если значение >1. А тут вот как просто.

Автор - VadimVV
Дата добавления - 25.06.2016 в 13:49
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет кол-ва значений по условию (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!