Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет клиентов по строкам и без учета итоговой ячейки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет клиентов по строкам и без учета итоговой ячейки (Формулы/Formulas)
Подсчет клиентов по строкам и без учета итоговой ячейки
NotAllowed Дата: Среда, 29.06.2016, 13:08 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Всем здравствуйте,помогите пожалуйста подсчитать кол-во клиентов(а не товара)(по месяцам),учитывая ,что данные в объединенных ячейках,т.к разбиты по месяцам,плюс в некоторых товарах есть еще и графа "итого"...
подсчет непустых не позволяет этого сделать,сводную тоже не получается сформировать((.
Пример во вложении.

Заранее спасибо)
п.с или "ткните носом",где можно почитать...
К сообщению приложен файл: 4762317.xls(26Kb)


practice makes perfect
 
Ответить
СообщениеВсем здравствуйте,помогите пожалуйста подсчитать кол-во клиентов(а не товара)(по месяцам),учитывая ,что данные в объединенных ячейках,т.к разбиты по месяцам,плюс в некоторых товарах есть еще и графа "итого"...
подсчет непустых не позволяет этого сделать,сводную тоже не получается сформировать((.
Пример во вложении.

Заранее спасибо)
п.с или "ткните носом",где можно почитать...

Автор - NotAllowed
Дата добавления - 29.06.2016 в 13:08
pabchek Дата: Среда, 29.06.2016, 13:17 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 645
Репутация: 145 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте!
Так надо?
Код
=СЧЁТЕСЛИМН($C$2:$C$21;$J2;D$2:D$21;">0")


Добавлено
И моя СУММПРОИЗВ :)
Код
=СУММПРОИЗВ(($C$2:$C$21=$J10)*(D$2:D$21>0))
К сообщению приложен файл: 2908755.xls(22Kb)


"Учиться, учиться и еще раз учиться!"
WM: R399923528092


Сообщение отредактировал pabchek - Среда, 29.06.2016, 13:36
 
Ответить
СообщениеЗдравствуйте!
Так надо?
Код
=СЧЁТЕСЛИМН($C$2:$C$21;$J2;D$2:D$21;">0")


Добавлено
И моя СУММПРОИЗВ :)
Код
=СУММПРОИЗВ(($C$2:$C$21=$J10)*(D$2:D$21>0))

Автор - pabchek
Дата добавления - 29.06.2016 в 13:17
китин Дата: Среда, 29.06.2016, 13:19 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3413
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
и опять таки СУММПРОИЗВ :D
Код
=СУММПРОИЗВ((ЕЧИСЛО($D$2:$G$21))*($D$1:$G$1=K$1)*($J2=$C$2:$C$21))
К сообщению приложен файл: _4762317.xls(27Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Среда, 29.06.2016, 13:20
 
Ответить
Сообщениеи опять таки СУММПРОИЗВ :D
Код
=СУММПРОИЗВ((ЕЧИСЛО($D$2:$G$21))*($D$1:$G$1=K$1)*($J2=$C$2:$C$21))

Автор - китин
Дата добавления - 29.06.2016 в 13:19
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет клиентов по строкам и без учета итоговой ячейки (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!