Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Посчитать суммарный вес материала за определенную дату - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать суммарный вес материала за определенную дату (Формулы/Formulas)
Посчитать суммарный вес материала за определенную дату
lebensvoll Дата: Пятница, 08.07.2016, 12:43 | Сообщение № 1
Группа: Проверенные
Ранг: Ветеран
Сообщений: 645
Репутация: 2 ±
Замечаний: 60% ±

Excel 2010
Добрый день уважаемые форумчане!!!
Вынужден обратиться к вам снова в виду того что не могу понять что я сделал не так при расчете на листе ПЛАН ПО МАТЕРИАЛАМ:
имеются три условия, дата; вид материала "Цемент"; а также поставщик "ООО "Неруд Центр". Применил формулу:
Код
{=СУММПРОИЗВ(ИНДЕКС('Данные по материалам'!I:I;ПОИСКПОЗ('План по материалам'!E4:F4&'План по материалам'!B6:B8&'План по материалам'!C6;'Данные по материалам'!A:A&'Данные по материалам'!D:D&'Данные по материалам'!B:B;0)))}

А она почему то взяла лишь одно значение 21,38 но не просуммировала за всю эту дату (((((
Что это я сделал не так???
К сообщению приложен файл: 5981717.xlsx(50Kb)


Кто бы ты ни был, мир в твоих руках

Сообщение отредактировал Manyasha - Пятница, 08.07.2016, 13:42
 
Ответить
СообщениеДобрый день уважаемые форумчане!!!
Вынужден обратиться к вам снова в виду того что не могу понять что я сделал не так при расчете на листе ПЛАН ПО МАТЕРИАЛАМ:
имеются три условия, дата; вид материала "Цемент"; а также поставщик "ООО "Неруд Центр". Применил формулу:
Код
{=СУММПРОИЗВ(ИНДЕКС('Данные по материалам'!I:I;ПОИСКПОЗ('План по материалам'!E4:F4&'План по материалам'!B6:B8&'План по материалам'!C6;'Данные по материалам'!A:A&'Данные по материалам'!D:D&'Данные по материалам'!B:B;0)))}

А она почему то взяла лишь одно значение 21,38 но не просуммировала за всю эту дату (((((
Что это я сделал не так???

Автор - lebensvoll
Дата добавления - 08.07.2016 в 12:43
китин Дата: Пятница, 08.07.2016, 12:58 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3433
Репутация: 544 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ну так на вскидку диапазончики у вас кто в лес кто по дрова, а СУММПРИЗВ этого не любит.
Код
=СУММПРОИЗВ('Данные по материалам'!I4:I21*ПОИСКПОЗ('План по материалам'!E4&'План по материалам'!B6&'План по материалам'!C6;'Данные по материалам'!A4:A21&'Данные по материалам'!D4:D21&'Данные по материалам'!B4:B21;0))

вот так считает, но правильность не проверял .


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал Manyasha - Пятница, 08.07.2016, 13:43
 
Ответить
Сообщениену так на вскидку диапазончики у вас кто в лес кто по дрова, а СУММПРИЗВ этого не любит.
Код
=СУММПРОИЗВ('Данные по материалам'!I4:I21*ПОИСКПОЗ('План по материалам'!E4&'План по материалам'!B6&'План по материалам'!C6;'Данные по материалам'!A4:A21&'Данные по материалам'!D4:D21&'Данные по материалам'!B4:B21;0))

вот так считает, но правильность не проверял .

Автор - китин
Дата добавления - 08.07.2016 в 12:58
Stanislav0523 Дата: Пятница, 08.07.2016, 13:07 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 2 ±
Замечаний: 0% ±

Excel 2010
День добрый

ну так на вскидку диапазончики у вас кто в лес кто по дрова


Верно подмечено :D

А она почему то взяла лишь одно значение 21,38 но не просуммировала за всю эту дату (((((


Насколько я понимаю, сумма произведений Вам тут вовсе ни к чему, Вы ведь не перемножаете веса?
А если нужно просто сложить, то сумма по условию, пожалуй, подойдет.
Скрыто до исправления названия темы. Файл удалила.
открыла


Сообщение отредактировал Manyasha - Пятница, 08.07.2016, 13:45
 
Ответить
СообщениеДень добрый

ну так на вскидку диапазончики у вас кто в лес кто по дрова


Верно подмечено :D

А она почему то взяла лишь одно значение 21,38 но не просуммировала за всю эту дату (((((


Насколько я понимаю, сумма произведений Вам тут вовсе ни к чему, Вы ведь не перемножаете веса?
А если нужно просто сложить, то сумма по условию, пожалуй, подойдет.
Скрыто до исправления названия темы. Файл удалила.
открыла

Автор - Stanislav0523
Дата добавления - 08.07.2016 в 13:07
lebensvoll Дата: Пятница, 08.07.2016, 13:19 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 645
Репутация: 2 ±
Замечаний: 60% ±

Excel 2010
китин, я так понимаю что СУММПРОИЗВ не любит диапазон если указать I:I, правильно я понял нужно еще добавить и цифровые значения I4:I21.
При использовании вашей формулы:
Код
=СУММПРОИЗВ('Данные по материалам'!I4:I21*ПОИСКПОЗ('План по материалам'!E4&'План по материалам'!B6&'План по материалам'!C6;'Данные по материалам'!A4:A21&'Данные по материалам'!D4:D21&'Данные по материалам'!B4:B21;0))
сумма получилась 3352,51 ((((( а по сути должно было получиться 624,430.
Возможно я не ту формулу применяю ((((


Кто бы ты ни был, мир в твоих руках
 
Ответить
Сообщениекитин, я так понимаю что СУММПРОИЗВ не любит диапазон если указать I:I, правильно я понял нужно еще добавить и цифровые значения I4:I21.
При использовании вашей формулы:
Код
=СУММПРОИЗВ('Данные по материалам'!I4:I21*ПОИСКПОЗ('План по материалам'!E4&'План по материалам'!B6&'План по материалам'!C6;'Данные по материалам'!A4:A21&'Данные по материалам'!D4:D21&'Данные по материалам'!B4:B21;0))
сумма получилась 3352,51 ((((( а по сути должно было получиться 624,430.
Возможно я не ту формулу применяю ((((

Автор - lebensvoll
Дата добавления - 08.07.2016 в 13:19
Udik Дата: Пятница, 08.07.2016, 13:34 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1214
Репутация: 153 ±
Замечаний: 0% ±

Excel 2013
Может лучше напишите, что хотите суммировать.
пока так
Код

=СУММПРОИЗВ('Данные по материалам'!I10:I21*('Данные по материалам'!B10:B21=$C$6)*('Данные по материалам'!A10:A21=$G$25)*('Данные по материалам'!D21="Цемент"))
К сообщению приложен файл: 0t.xlsx(48Kb)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com


Сообщение отредактировал Udik - Пятница, 08.07.2016, 13:59
 
Ответить
СообщениеМожет лучше напишите, что хотите суммировать.
пока так
Код

=СУММПРОИЗВ('Данные по материалам'!I10:I21*('Данные по материалам'!B10:B21=$C$6)*('Данные по материалам'!A10:A21=$G$25)*('Данные по материалам'!D21="Цемент"))

Автор - Udik
Дата добавления - 08.07.2016 в 13:34
lebensvoll Дата: Пятница, 08.07.2016, 16:07 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 645
Репутация: 2 ±
Замечаний: 60% ±

Excel 2010
Udik, я суммирую значения по столбцу I на листе данные по материалам. Но расчет производится на листе ПЛАН ПО МАТЕРИАЛАМ на ячейке F30 (для примера) где имеются три условия дата (ячейка E4); материалы (ячейка B6); и поставщик ООО "Неруд Центр" (ячейка С6). формула должна была подсчитать сумму поставок согласно выбранным условиям: дата; материал; и поставщик; суммировать сумму этой поставки на эту дату данного материала этого поставщика


Кто бы ты ни был, мир в твоих руках
 
Ответить
СообщениеUdik, я суммирую значения по столбцу I на листе данные по материалам. Но расчет производится на листе ПЛАН ПО МАТЕРИАЛАМ на ячейке F30 (для примера) где имеются три условия дата (ячейка E4); материалы (ячейка B6); и поставщик ООО "Неруд Центр" (ячейка С6). формула должна была подсчитать сумму поставок согласно выбранным условиям: дата; материал; и поставщик; суммировать сумму этой поставки на эту дату данного материала этого поставщика

Автор - lebensvoll
Дата добавления - 08.07.2016 в 16:07
Udik Дата: Пятница, 08.07.2016, 16:12 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1214
Репутация: 153 ±
Замечаний: 0% ±

Excel 2013
тогда так
Код

=СУММПРОИЗВ('Данные по материалам'!I10:I21*('Данные по материалам'!B10:B21=$C$6)*('Данные по материалам'!A10:A21=$G$25)*('Данные по материалам'!D21=B6))

В первом посте был Цемент :) .
К сообщению приложен файл: 5182072.xlsx(48Kb)


вот вам барабан
яд 41001231307558 wm R419131876897
udik1968@gmail.com
 
Ответить
Сообщениетогда так
Код

=СУММПРОИЗВ('Данные по материалам'!I10:I21*('Данные по материалам'!B10:B21=$C$6)*('Данные по материалам'!A10:A21=$G$25)*('Данные по материалам'!D21=B6))

В первом посте был Цемент :) .

Автор - Udik
Дата добавления - 08.07.2016 в 16:12
lebensvoll Дата: Суббота, 09.07.2016, 13:22 | Сообщение № 8
Группа: Проверенные
Ранг: Ветеран
Сообщений: 645
Репутация: 2 ±
Замечаний: 60% ±

Excel 2010
Udik, да все верно, СПАСИБО ВСЕМ ОГРОМНОЕ!!!


Кто бы ты ни был, мир в твоих руках
 
Ответить
СообщениеUdik, да все верно, СПАСИБО ВСЕМ ОГРОМНОЕ!!!

Автор - lebensvoll
Дата добавления - 09.07.2016 в 13:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Посчитать суммарный вес материала за определенную дату (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!