Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/выбор значения по 2-м параметрами - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » выбор значения по 2-м параметрами (Формулы/Formulas)
выбор значения по 2-м параметрами
Serge1400 Дата: Пятница, 08.07.2016, 23:02 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 40% ±

Excel 2010
Всем добрый вечер! В очередной раз понадобилась помощь в решении задачи.
Суть проблемы:
Есть две таблицы. На основании двух параметров (залиты зеленым цветом) из левой таблицы нужно выбрать соотвествующее этим параметрам значение из колонки правой таблицы (залита желтым) и внести его в соотвествующую ячейку (залита желтым) левой таблицы.
Пробовал решить задачу при помощи ЕСЛИ, но получаются какие-то неработающие формулы-монстры. Бился два дня, но самостоятельно решить не получается - знаний явно не хватает.
Заранее благодарен за все советы и рекомендации.
К сообщению приложен файл: __.xlsx(12Kb)
 
Ответить
СообщениеВсем добрый вечер! В очередной раз понадобилась помощь в решении задачи.
Суть проблемы:
Есть две таблицы. На основании двух параметров (залиты зеленым цветом) из левой таблицы нужно выбрать соотвествующее этим параметрам значение из колонки правой таблицы (залита желтым) и внести его в соотвествующую ячейку (залита желтым) левой таблицы.
Пробовал решить задачу при помощи ЕСЛИ, но получаются какие-то неработающие формулы-монстры. Бился два дня, но самостоятельно решить не получается - знаний явно не хватает.
Заранее благодарен за все советы и рекомендации.

Автор - Serge1400
Дата добавления - 08.07.2016 в 23:02
krosav4ig Дата: Суббота, 09.07.2016, 00:03 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1420
Репутация: 585 ±
Замечаний: 0% ±

Excel 2007, 2013
так нужно?
Код
=ИНДЕКС({100;200;300;0:150;250;350;0:0;250;300;0:0;300;400;0:0;0;0;500};ПОИСКПОЗ(A7;{1:6:21:51:201});ПОИСКПОЗ(C7;{0;10000;20000;20001}))


(_)Õvõ(_)
 
Ответить
Сообщениетак нужно?
Код
=ИНДЕКС({100;200;300;0:150;250;350;0:0;250;300;0:0;300;400;0:0;0;0;500};ПОИСКПОЗ(A7;{1:6:21:51:201});ПОИСКПОЗ(C7;{0;10000;20000;20001}))

Автор - krosav4ig
Дата добавления - 09.07.2016 в 00:03
Serge1400 Дата: Суббота, 09.07.2016, 00:31 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 40% ±

Excel 2010
так нужно?

Спасибо за помощь!
Испытал
По алгоритму именно так как нужно, но формула работает на 50%.
Во всех диапазонах от 1-5 и выше, если итоговая сумма свыше 20000, в желтой ячейке левой таблицы (комиссия) появляется "0".
Также если сумма меньше 10000 то в диапазонах 21-50 и далее тоже вижу "0".


Сообщение отредактировал Serge1400 - Суббота, 09.07.2016, 00:59
 
Ответить
Сообщение
так нужно?

Спасибо за помощь!
Испытал
По алгоритму именно так как нужно, но формула работает на 50%.
Во всех диапазонах от 1-5 и выше, если итоговая сумма свыше 20000, в желтой ячейке левой таблицы (комиссия) появляется "0".
Также если сумма меньше 10000 то в диапазонах 21-50 и далее тоже вижу "0".

Автор - Serge1400
Дата добавления - 09.07.2016 в 00:31
krosav4ig Дата: Суббота, 09.07.2016, 05:17 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1420
Репутация: 585 ±
Замечаний: 0% ±

Excel 2007, 2013
упс, проглядел
Код
=ИНДЕКС({100;200;300;300:150;250;350;350:250;250;300;300:300;300;400;400:0;0;0;500};ПОИСКПОЗ(A7;{1:6:21:51:201});ПОИСКПОЗ(C7;{0;10000;20000;20001}))

или с доп. таблицей
Код
=ИНДЕКС(K2:N6;ПОИСКПОЗ(A7;J2:J6);ПОИСКПОЗ(C7;K1:N1))
К сообщению приложен файл: -4-.xlsx(12Kb)


(_)Õvõ(_)
 
Ответить
Сообщениеупс, проглядел
Код
=ИНДЕКС({100;200;300;300:150;250;350;350:250;250;300;300:300;300;400;400:0;0;0;500};ПОИСКПОЗ(A7;{1:6:21:51:201});ПОИСКПОЗ(C7;{0;10000;20000;20001}))

или с доп. таблицей
Код
=ИНДЕКС(K2:N6;ПОИСКПОЗ(A7;J2:J6);ПОИСКПОЗ(C7;K1:N1))

Автор - krosav4ig
Дата добавления - 09.07.2016 в 05:17
Serge1400 Дата: Суббота, 09.07.2016, 10:30 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 40% ±

Excel 2010
:yahoo:
С доп. таблицей самое оно!!! И формула коротенькая получается!
Ну , а красота и наглядность, в виде моей правой таблицы, на этом этапе вычислений нафиг не нужна: я ее вообще уберу и оставлю вместно нее доп.таблицу.

Еще раз спасибо за помощь! respect beer :yahoo:

P.S. Разместил доп таблицу на втором листе и уже оттуда всасывается нужный мне результат.
Красота! Жизнь начинает налаживаться!!! victory


Сообщение отредактировал Serge1400 - Суббота, 09.07.2016, 15:25
 
Ответить
Сообщение:yahoo:
С доп. таблицей самое оно!!! И формула коротенькая получается!
Ну , а красота и наглядность, в виде моей правой таблицы, на этом этапе вычислений нафиг не нужна: я ее вообще уберу и оставлю вместно нее доп.таблицу.

Еще раз спасибо за помощь! respect beer :yahoo:

P.S. Разместил доп таблицу на втором листе и уже оттуда всасывается нужный мне результат.
Красота! Жизнь начинает налаживаться!!! victory

Автор - Serge1400
Дата добавления - 09.07.2016 в 10:30
Serge1400 Дата: Среда, 13.07.2016, 23:57 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 40% ±

Excel 2010
В общем то и формула очень пригодилась!
С таблицей оно конечно все выглядит и элегантнее и нагляднее, но с формулой вариант погибче будет по возможностям, хотя и сложен для понимания обычным пользователм.
Скажем надо растиражировать таблицу на одном листе: сделать до 10 заготовок под расчеты. Формула сама себя обслуживает, а вот при доптаблице надо постоянно новые ячейки под другие результы добавлять с новые ячейки и рисовать новые адреса.
Так что в дело пошли оба варианта.

Еще раз спасибо за помощь! beer beer beer


Сообщение отредактировал Serge1400 - Среда, 13.07.2016, 23:59
 
Ответить
СообщениеВ общем то и формула очень пригодилась!
С таблицей оно конечно все выглядит и элегантнее и нагляднее, но с формулой вариант погибче будет по возможностям, хотя и сложен для понимания обычным пользователм.
Скажем надо растиражировать таблицу на одном листе: сделать до 10 заготовок под расчеты. Формула сама себя обслуживает, а вот при доптаблице надо постоянно новые ячейки под другие результы добавлять с новые ячейки и рисовать новые адреса.
Так что в дело пошли оба варианта.

Еще раз спасибо за помощь! beer beer beer

Автор - Serge1400
Дата добавления - 13.07.2016 в 23:57
Мир MS Excel » Вопросы и решения » Вопросы по Excel » выбор значения по 2-м параметрами (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!