Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/результат не должен превышать 60 - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » результат не должен превышать 60 (Формулы/Formulas)
результат не должен превышать 60
dv33 Дата: Вторник, 12.07.2016, 12:27 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 20% ±

Excel 2016
Приветствую!
Как дописать функцию если
Код
=ЕСЛИ(AN3/AM3*100>60;"60")
, мне нужно если AN3/AM3*100>60, то 60, а если меньше 60 остается, как есть.
Код
=ЕСЛИ(AN4/AM4*100>60;"60";ЕСЛИ(AN4/AM4*100<60;"AN3/AM3*100"))
, как то так, но не так...


Сообщение отредактировал dv33 - Вторник, 12.07.2016, 13:05
 
Ответить
СообщениеПриветствую!
Как дописать функцию если
Код
=ЕСЛИ(AN3/AM3*100>60;"60")
, мне нужно если AN3/AM3*100>60, то 60, а если меньше 60 остается, как есть.
Код
=ЕСЛИ(AN4/AM4*100>60;"60";ЕСЛИ(AN4/AM4*100<60;"AN3/AM3*100"))
, как то так, но не так...

Автор - dv33
Дата добавления - 12.07.2016 в 12:27
китин Дата: Вторник, 12.07.2016, 12:33 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3443
Репутация: 546 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
dv33, а как насчет использования тэгов?
Да и название как то никакое


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Вторник, 12.07.2016, 12:33
 
Ответить
Сообщениеdv33, а как насчет использования тэгов?
Да и название как то никакое

Автор - китин
Дата добавления - 12.07.2016 в 12:33
dv33 Дата: Вторник, 12.07.2016, 12:42 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 20% ±

Excel 2016
по названию не знал что придумать
тэгами не пользовался не когда, в эксель я пока еще дуб
 
Ответить
Сообщениепо названию не знал что придумать
тэгами не пользовался не когда, в эксель я пока еще дуб

Автор - dv33
Дата добавления - 12.07.2016 в 12:42
Pelena Дата: Вторник, 12.07.2016, 12:57 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9869
Репутация: 2262 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
по названию не знал что придумать

И всё-таки придётся придумать


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
по названию не знал что придумать

И всё-таки придётся придумать

Автор - Pelena
Дата добавления - 12.07.2016 в 12:57
Pelena Дата: Вторник, 12.07.2016, 14:04 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9869
Репутация: 2262 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Тут ЕСЛИ() и не нужна.
Код
=МИН(AN3/AM3*100;60)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеТут ЕСЛИ() и не нужна.
Код
=МИН(AN3/AM3*100;60)

Автор - Pelena
Дата добавления - 12.07.2016 в 14:04
dv33 Дата: Вторник, 12.07.2016, 14:07 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 0 ±
Замечаний: 20% ±

Excel 2016
спасибо
 
Ответить
Сообщениеспасибо

Автор - dv33
Дата добавления - 12.07.2016 в 14:07
_Boroda_ Дата: Вторник, 12.07.2016, 14:07 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9374
Репутация: 3947 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А если очень хочется с ЕСЛИ, то так
Код
=ЕСЛИ(AN4/AM4*100>60;60;AN4/AM4*100)

Добавлено
Исправил немного


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995


Сообщение отредактировал _Boroda_ - Вторник, 12.07.2016, 14:09
 
Ответить
СообщениеА если очень хочется с ЕСЛИ, то так
Код
=ЕСЛИ(AN4/AM4*100>60;60;AN4/AM4*100)

Добавлено
Исправил немного

Автор - _Boroda_
Дата добавления - 12.07.2016 в 14:07
китин Дата: Вторник, 12.07.2016, 14:09 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3443
Репутация: 546 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
[offtop]а с ТЕКСТ? а то как то не комильфо :D

Код
=ТЕКСТ(AN3/AM3*100;"[>60] ;60")
почему не работает?

К сообщению приложен файл: 4638105.gif(21Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Вторник, 12.07.2016, 14:16
 
Ответить
Сообщение[offtop]а с ТЕКСТ? а то как то не комильфо :D

Код
=ТЕКСТ(AN3/AM3*100;"[>60] ;60")
почему не работает?


Автор - китин
Дата добавления - 12.07.2016 в 14:09
Pelena Дата: Вторник, 12.07.2016, 14:15 | Сообщение № 9
Группа: Модераторы
Ранг: Экселист
Сообщений: 9869
Репутация: 2262 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Код
=--ТЕКСТ(A1;"[>60]6\0;Основной")

:D


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=--ТЕКСТ(A1;"[>60]6\0;Основной")

:D

Автор - Pelena
Дата добавления - 12.07.2016 в 14:15
_Boroda_ Дата: Вторник, 12.07.2016, 15:09 | Сообщение № 10
Группа: Модераторы
Ранг: Экселист
Сообщений: 9374
Репутация: 3947 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
"[>60] ;60")

Потому, что при больше 60 ты сказал ему писать пробел, а при меньше 60 - 6 и само число
Вот так можно
Код
=ТЕКСТ(AN3/AM3*100;"[>60]6\0;0")

Код
=--ТЕКСТ(AN3/AM3%;"[>60]6\0;0")

Тьфу! Наоборот! Поправил
И еще вариант
Код
=ТЕКСТ(AN3/AM3%-60;"\0;-0")+60


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
"[>60] ;60")

Потому, что при больше 60 ты сказал ему писать пробел, а при меньше 60 - 6 и само число
Вот так можно
Код
=ТЕКСТ(AN3/AM3*100;"[>60]6\0;0")

Код
=--ТЕКСТ(AN3/AM3%;"[>60]6\0;0")

Тьфу! Наоборот! Поправил
И еще вариант
Код
=ТЕКСТ(AN3/AM3%-60;"\0;-0")+60

Автор - _Boroda_
Дата добавления - 12.07.2016 в 15:09
китин Дата: Вторник, 12.07.2016, 15:29 | Сообщение № 11
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3443
Репутация: 546 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
интересно: вот такое вот
Код
=ТЕКСТ(AN3/AM3*100;"[>60]60;0")
при больше 60 просто ставит 6 перед числом а вот это
Код
=ТЕКСТ(AN3/AM3*100;"[>60]6\0;0")
ставит 60.Получается, что 0 обозначает само число, но , что бы поставить число 60, 70, 80 и т.д. надо ставить 8\0, 7\0 6\0. а числа 45 55 65 можно поставить без \ ???????


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеинтересно: вот такое вот
Код
=ТЕКСТ(AN3/AM3*100;"[>60]60;0")
при больше 60 просто ставит 6 перед числом а вот это
Код
=ТЕКСТ(AN3/AM3*100;"[>60]6\0;0")
ставит 60.Получается, что 0 обозначает само число, но , что бы поставить число 60, 70, 80 и т.д. надо ставить 8\0, 7\0 6\0. а числа 45 55 65 можно поставить без \ ???????

Автор - китин
Дата добавления - 12.07.2016 в 15:29
_Boroda_ Дата: Вторник, 12.07.2016, 15:40 | Сообщение № 12
Группа: Модераторы
Ранг: Экселист
Сообщений: 9374
Репутация: 3947 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Совершенно верно, я как раз об этом тебе и написал
при меньше 60 - 6 и само число

Или можно не 6\0, а "60", но в ТЕКСТ кавычки в кавычках - тот еще геморрой


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеСовершенно верно, я как раз об этом тебе и написал
при меньше 60 - 6 и само число

Или можно не 6\0, а "60", но в ТЕКСТ кавычки в кавычках - тот еще геморрой

Автор - _Boroda_
Дата добавления - 12.07.2016 в 15:40
китин Дата: Вторник, 12.07.2016, 15:45 | Сообщение № 13
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3443
Репутация: 546 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Спасибо Саша!
[offtop]
понятно, что я еще долго буду проспоривать ТЕКСТ(формула;"Коньяк")


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеСпасибо Саша!
[offtop]
понятно, что я еще долго буду проспоривать ТЕКСТ(формула;"Коньяк")

Автор - китин
Дата добавления - 12.07.2016 в 15:45
AlexM Дата: Вторник, 12.07.2016, 16:23 | Сообщение № 14
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3053
Репутация: 740 ±
Замечаний: 0% ±

такой еще не было
Код
=МИН(AN3/AM3%;60)


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщениетакой еще не было
Код
=МИН(AN3/AM3%;60)

Автор - AlexM
Дата добавления - 12.07.2016 в 16:23
Мир MS Excel » Вопросы и решения » Вопросы по Excel » результат не должен превышать 60 (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!