Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/выборка уникальных значений в строке - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » выборка уникальных значений в строке (Формулы/Formulas)
выборка уникальных значений в строке
Rasul Дата: Вторник, 12.07.2016, 14:17 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день, помогите пожалуйста решить не большую проблему. Голову сломал, но не смог решить. Итак, мне нужно с одной строки найти одинаковые значения (в моём случае это цифра 0) и с помощью этого 0 вытащить код продукта указанный сверху чисел.

Заранее спасибо.

PS файл в приложении
К сообщению приложен файл: 4026996.xlsx(12Kb)


МегаМозг
 
Ответить
СообщениеДобрый день, помогите пожалуйста решить не большую проблему. Голову сломал, но не смог решить. Итак, мне нужно с одной строки найти одинаковые значения (в моём случае это цифра 0) и с помощью этого 0 вытащить код продукта указанный сверху чисел.

Заранее спасибо.

PS файл в приложении

Автор - Rasul
Дата добавления - 12.07.2016 в 14:17
Pelena Дата: Вторник, 12.07.2016, 14:22 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9858
Репутация: 2254 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Здравствуйте.
Покажите в файле вручную, каким должен быть результат


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Покажите в файле вручную, каким должен быть результат

Автор - Pelena
Дата добавления - 12.07.2016 в 14:22
китин Дата: Вторник, 12.07.2016, 14:38 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3433
Репутация: 544 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
А вот как понял массивная
Код
=ЕСЛИОШИБКА(ИНДЕКС($F$5:$P$5;НАИМЕНЬШИЙ(ЕСЛИ($F6:$P6=0;СТОЛБЕЦ($F6:$P6)-5);СТОЛБЕЦ(A1)));"")
К сообщению приложен файл: 234.xlsx(13Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеА вот как понял массивная
Код
=ЕСЛИОШИБКА(ИНДЕКС($F$5:$P$5;НАИМЕНЬШИЙ(ЕСЛИ($F6:$P6=0;СТОЛБЕЦ($F6:$P6)-5);СТОЛБЕЦ(A1)));"")

Автор - китин
Дата добавления - 12.07.2016 в 14:38
Rasul Дата: Вторник, 12.07.2016, 14:42 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Да, пожалуйста ...
К сообщению приложен файл: 2646317.xlsx(13Kb)


МегаМозг
 
Ответить
СообщениеДа, пожалуйста ...

Автор - Rasul
Дата добавления - 12.07.2016 в 14:42
Rasul Дата: Вторник, 12.07.2016, 14:44 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
китин, Огромное спасибо , очень выручили hands


МегаМозг
 
Ответить
Сообщениекитин, Огромное спасибо , очень выручили hands

Автор - Rasul
Дата добавления - 12.07.2016 в 14:44
jakim Дата: Вторник, 12.07.2016, 16:23 | Сообщение № 6
Группа: Друзья
Ранг: Ветеран
Сообщений: 680
Репутация: 172 ±
Замечаний: 0% ±

Вы можете воспользоваться и такой формулой

Код
=IFERROR(INDEX($F$5:$P$5;AGGREGATE(15;6;COLUMN($A:$Q)/($F6:$P6=0);COLUMNS($C:C)));"")
К сообщению приложен файл: 9509758.xlsx(13Kb)
 
Ответить
Сообщение
Вы можете воспользоваться и такой формулой

Код
=IFERROR(INDEX($F$5:$P$5;AGGREGATE(15;6;COLUMN($A:$Q)/($F6:$P6=0);COLUMNS($C:C)));"")

Автор - jakim
Дата добавления - 12.07.2016 в 16:23
_Boroda_ Дата: Вторник, 12.07.2016, 18:11 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 9367
Репутация: 3940 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Тогда еще
Код
=ИНДЕКС($A$5:$Q$5;НАИМЕНЬШИЙ(ЕСЛИ($F6:$P6;17;СТОЛБЕЦ($F6:$P6));СТОЛБЕЦ(A1)))&""


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТогда еще
Код
=ИНДЕКС($A$5:$Q$5;НАИМЕНЬШИЙ(ЕСЛИ($F6:$P6;17;СТОЛБЕЦ($F6:$P6));СТОЛБЕЦ(A1)))&""

Автор - _Boroda_
Дата добавления - 12.07.2016 в 18:11
Мир MS Excel » Вопросы и решения » Вопросы по Excel » выборка уникальных значений в строке (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!