Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчёт выполненных трёх условий - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт выполненных трёх условий (Формулы/Formulas)
Подсчёт выполненных трёх условий
olenka1990 Дата: Суббота, 16.07.2016, 15:33 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте уважаемые форумчане. Возможно ли при помощи excel подсчитать, сколько раз в столбце А было выполнение трёх условий? Функция СЧЁТЕСЛИМН считает не так, как хотелось бы. Подробней в примере. Спасибо.
К сообщению приложен файл: 5446186.xls(26Kb)
 
Ответить
СообщениеЗдравствуйте уважаемые форумчане. Возможно ли при помощи excel подсчитать, сколько раз в столбце А было выполнение трёх условий? Функция СЧЁТЕСЛИМН считает не так, как хотелось бы. Подробней в примере. Спасибо.

Автор - olenka1990
Дата добавления - 16.07.2016 в 15:33
gling Дата: Суббота, 16.07.2016, 16:45 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1521
Репутация: 377 ±
Замечаний: 0% ±

2010
Здравствуйте. Попробуйте не коротенькую формулу.
Код
=СЧЁТЕСЛИ(ИНДЕКС(A1:A19;СУММПРОИЗВ(МАКС(((A1:A19>1,4)*(A1:A19>1,6)=0)*СТРОКА(A1:A19)))):A19;">1,6")
К сообщению приложен файл: 4386246.xls(26Kb)


Сообщение отредактировал gling - Суббота, 16.07.2016, 16:55
 
Ответить
СообщениеЗдравствуйте. Попробуйте не коротенькую формулу.
Код
=СЧЁТЕСЛИ(ИНДЕКС(A1:A19;СУММПРОИЗВ(МАКС(((A1:A19>1,4)*(A1:A19>1,6)=0)*СТРОКА(A1:A19)))):A19;">1,6")

Автор - gling
Дата добавления - 16.07.2016 в 16:45
olenka1990 Дата: Суббота, 16.07.2016, 17:28 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Gling, здравствуйте. Спасибо вам за ответ, но при замене в ячейке А3 на значение больше 1,4, уже не хочет считать. Да, извините, забыла добавить условия. Спасибо.
К сообщению приложен файл: 2002945.xls(26Kb)
 
Ответить
СообщениеGling, здравствуйте. Спасибо вам за ответ, но при замене в ячейке А3 на значение больше 1,4, уже не хочет считать. Да, извините, забыла добавить условия. Спасибо.

Автор - olenka1990
Дата добавления - 16.07.2016 в 17:28
gling Дата: Суббота, 16.07.2016, 17:41 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1521
Репутация: 377 ±
Замечаний: 0% ±

2010
но при замене в ячейке А3

Тогда я наверно не правильно понял логику Вашего подсчета. Ведь в ячейке А6; А17 ни одно из условий не выполняется, следовательно счет обнуляется. Или объясните логику подробнее. Какой результат должен быть в вновь вложенном файле? Третье условие зачеркивает предшествующие, так как 1,6>1,3 и 1,4 и если выполняется условие 3, следовательно выполняются условие 1 и условие 2. Для чего проверять первое и второе условие?


Сообщение отредактировал gling - Суббота, 16.07.2016, 17:58
 
Ответить
Сообщение
но при замене в ячейке А3

Тогда я наверно не правильно понял логику Вашего подсчета. Ведь в ячейке А6; А17 ни одно из условий не выполняется, следовательно счет обнуляется. Или объясните логику подробнее. Какой результат должен быть в вновь вложенном файле? Третье условие зачеркивает предшествующие, так как 1,6>1,3 и 1,4 и если выполняется условие 3, следовательно выполняются условие 1 и условие 2. Для чего проверять первое и второе условие?

Автор - gling
Дата добавления - 16.07.2016 в 17:41
olenka1990 Дата: Суббота, 16.07.2016, 18:56 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Начинаем с ячейки А1, условие 1>1,3 не выполнено (1,2), А2>1,3 (1,33) –условие 1 выполнено, А3>1.4 (1,25) –условие2 не выполнено, переходим к условию 1 начиная с А3>1,3 (1,25) - условие 1 не выполнено, А4>1,3 (2) –условие 1 выполнено, А5>1.4(2,2) –условие 2 выполнено, А6>1,6 (1,03) –условие 3 не выполнено, переходим к условию 1 начиная с А6>1,3 (1,03) –условие 1 не выполнено, А7>1,3 (1,11) –условие 1 не выполнено, А8>1,3 (1,35) –условие 1 выполнено, А9>1,4 (1,04) –условие 2 не выполнено, переходим к условию 1 начиная с А9>1,3 (1,04) - условие 1 не выполнено, А10>1,3 (1,05) - условие 1 не выполнено,А11>1,3 (1,22) - условие 1 не выполнено, А12>1,3(1,44) - условие 1 выполнено, А13>1,4 (1,34) –условие 2 не выполнено, переходим к условию 1 начиная с А13>1,3 (1,34) - условие 1 выполнено,А14>1,4 (2,1) - условие 2 выполнено, А15>1,6 (1,75) - условие 3 выполнено, переходим к условию 1 начиная с А15>1,3 (1,75) и т.д.
 
Ответить
СообщениеНачинаем с ячейки А1, условие 1>1,3 не выполнено (1,2), А2>1,3 (1,33) –условие 1 выполнено, А3>1.4 (1,25) –условие2 не выполнено, переходим к условию 1 начиная с А3>1,3 (1,25) - условие 1 не выполнено, А4>1,3 (2) –условие 1 выполнено, А5>1.4(2,2) –условие 2 выполнено, А6>1,6 (1,03) –условие 3 не выполнено, переходим к условию 1 начиная с А6>1,3 (1,03) –условие 1 не выполнено, А7>1,3 (1,11) –условие 1 не выполнено, А8>1,3 (1,35) –условие 1 выполнено, А9>1,4 (1,04) –условие 2 не выполнено, переходим к условию 1 начиная с А9>1,3 (1,04) - условие 1 не выполнено, А10>1,3 (1,05) - условие 1 не выполнено,А11>1,3 (1,22) - условие 1 не выполнено, А12>1,3(1,44) - условие 1 выполнено, А13>1,4 (1,34) –условие 2 не выполнено, переходим к условию 1 начиная с А13>1,3 (1,34) - условие 1 выполнено,А14>1,4 (2,1) - условие 2 выполнено, А15>1,6 (1,75) - условие 3 выполнено, переходим к условию 1 начиная с А15>1,3 (1,75) и т.д.

Автор - olenka1990
Дата добавления - 16.07.2016 в 18:56
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт выполненных трёх условий (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!