Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула вычисления без нуля на конце - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула вычисления без нуля на конце (Формулы/Formulas)
Формула вычисления без нуля на конце
Solo Дата: Воскресенье, 17.07.2016, 16:01 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Ребят,доброго дня. Подскажите пожалуйста - есть формула А1=В1*0.5, т.е грубо говоря в В1 вписую 1 в А1 мне выдаст 0,50 (после запятой 2 цифры) и мне нужно чтоб если последним числом был ноль,то добавляло 0,01 и получалось бы 0,051,ну а если там будет любая другая цифра на конце (допустим 0,49 0,51 ,052 и т.д.) то оставляло все как есть без изменения. Надеюсь получилось внятно объяснить )) Буду очень благодарен за помощь.
P\S Excel 2003-го г.
 
Ответить
СообщениеРебят,доброго дня. Подскажите пожалуйста - есть формула А1=В1*0.5, т.е грубо говоря в В1 вписую 1 в А1 мне выдаст 0,50 (после запятой 2 цифры) и мне нужно чтоб если последним числом был ноль,то добавляло 0,01 и получалось бы 0,051,ну а если там будет любая другая цифра на конце (допустим 0,49 0,51 ,052 и т.д.) то оставляло все как есть без изменения. Надеюсь получилось внятно объяснить )) Буду очень благодарен за помощь.
P\S Excel 2003-го г.

Автор - Solo
Дата добавления - 17.07.2016 в 16:01
Mark1976 Дата: Воскресенье, 17.07.2016, 16:02 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 328
Репутация: 0 ±
Замечаний: 40% ±

Excel 2007
Solo, без примера не помогут.
 
Ответить
СообщениеSolo, без примера не помогут.

Автор - Mark1976
Дата добавления - 17.07.2016 в 16:02
Michael_S Дата: Воскресенье, 17.07.2016, 16:11 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1687
Репутация: 327 ±
Замечаний: 0% ±

Excel2016
Код
=ЕСЛИ(ОСТАТ(A1*100;10);A1;A1+0,01)


ЯД: 41001136675053
WM: R389613894253
 
Ответить
Сообщение
Код
=ЕСЛИ(ОСТАТ(A1*100;10);A1;A1+0,01)

Автор - Michael_S
Дата добавления - 17.07.2016 в 16:11
Nic70y Дата: Воскресенье, 17.07.2016, 16:19 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3473
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Михаил, маленькая поправка
Код
=ЕСЛИ(ОСТАТ(B1*50;10);B1*0,5;B1*0,5+0,01)
Код
=ЕСЛИ(ОСТАТ(ОКРУГЛ(B1*50;);10);B1*0,5;B1*0,5+0,01)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Воскресенье, 17.07.2016, 16:25
 
Ответить
СообщениеМихаил, маленькая поправка
Код
=ЕСЛИ(ОСТАТ(B1*50;10);B1*0,5;B1*0,5+0,01)
Код
=ЕСЛИ(ОСТАТ(ОКРУГЛ(B1*50;);10);B1*0,5;B1*0,5+0,01)

Автор - Nic70y
Дата добавления - 17.07.2016 в 16:19
Solo Дата: Воскресенье, 17.07.2016, 17:16 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Ребят,спасибо большое за ответы и помощь! Подошла формула Nic70y:
Код
=ЕСЛИ(ОСТАТ(ОКРУГЛ(B1*50;);10);B1*0,5;B1*0,5+0,01)

Очень Благодарен!!! hands


Сообщение отредактировал Solo - Воскресенье, 17.07.2016, 17:17
 
Ответить
СообщениеРебят,спасибо большое за ответы и помощь! Подошла формула Nic70y:
Код
=ЕСЛИ(ОСТАТ(ОКРУГЛ(B1*50;);10);B1*0,5;B1*0,5+0,01)

Очень Благодарен!!! hands

Автор - Solo
Дата добавления - 17.07.2016 в 17:16
Nic70y Дата: Воскресенье, 17.07.2016, 18:51 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3473
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Подошла формула Nic70y
Ну вобще-то это формула Михаила, прост слегка мной модифицирована.


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Подошла формула Nic70y
Ну вобще-то это формула Михаила, прост слегка мной модифицирована.

Автор - Nic70y
Дата добавления - 17.07.2016 в 18:51
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула вычисления без нуля на конце (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!