Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Определение суммы нескольких ячеек массива по условиям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определение суммы нескольких ячеек массива по условиям (Формулы/Formulas)
Определение суммы нескольких ячеек массива по условиям
Olegq123 Дата: Понедельник, 18.07.2016, 11:48 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте форумчане.

Есть массив данных. Как найти сумму ячеек, когда нужно выбрать ячейки по определенному условию по строке и столбцу. Найти уникальное одно значение с помощью функций ИНДЕКС ПОИСКПОЗ я могу, а здесь получается несколько ячеек удовлетворяющих данному условию. Посчитать по каждому столбцу и потом просуммировать я могу, но если массив имеет много строк и столбцов, то это будет долго. Можно ли в одной ячейке написать формулы как то?(вычислить сумму в одной ячейке)

В данном примере проставляем в ячейку C16 значения например: "яблоки", либо "груши" и т.д., в ячейку C17: 1 канал, либо "2 канал" и т.д. А в ячейке C18 должна выйти эта сумма итоговая - всех ячеек на пересечении выбранных условий по строкам и столбцам.

Заранее весьма благодарен.
К сообщению приложен файл: __.xls(74Kb)
 
Ответить
СообщениеЗдравствуйте форумчане.

Есть массив данных. Как найти сумму ячеек, когда нужно выбрать ячейки по определенному условию по строке и столбцу. Найти уникальное одно значение с помощью функций ИНДЕКС ПОИСКПОЗ я могу, а здесь получается несколько ячеек удовлетворяющих данному условию. Посчитать по каждому столбцу и потом просуммировать я могу, но если массив имеет много строк и столбцов, то это будет долго. Можно ли в одной ячейке написать формулы как то?(вычислить сумму в одной ячейке)

В данном примере проставляем в ячейку C16 значения например: "яблоки", либо "груши" и т.д., в ячейку C17: 1 канал, либо "2 канал" и т.д. А в ячейке C18 должна выйти эта сумма итоговая - всех ячеек на пересечении выбранных условий по строкам и столбцам.

Заранее весьма благодарен.

Автор - Olegq123
Дата добавления - 18.07.2016 в 11:48
_Boroda_ Дата: Понедельник, 18.07.2016, 11:55 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9786
Репутация: 4135 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММПРОИЗВ(B2:L14*(A2:A14=C16)*(B1:L1=C17))
К сообщению приложен файл: -2-1.xls(79Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММПРОИЗВ(B2:L14*(A2:A14=C16)*(B1:L1=C17))

Автор - _Boroda_
Дата добавления - 18.07.2016 в 11:55
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определение суммы нескольких ячеек массива по условиям (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!