Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Использование регулярных выражения внутри формулы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Использование регулярных выражения внутри формулы (Формулы/Formulas)
Использование регулярных выражения внутри формулы
Endrus1 Дата: Понедельник, 18.07.2016, 19:52 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день, уважаемые эксперты!

Прошу помочь: Как в формулах ЕСЛИ использовать регулярные выражения? (Меня интересуют ячейки, которые можно найти с помощью регулярного выражения *щий)

Простенький пример прикрепил к сообщению (прошу заметить, пример не является конечной задачей, поэтому прошу не предлагать решение через "ИЛИ("Восходящий";"Нисходящий")

Другой вопрос - как в ЕСЛИ сформулировать условие "Любая непустая ячейка"? (<>0 не работает ((

Спасибо!
К сообщению приложен файл: 3351244.xlsx(10Kb)


Сообщение отредактировал Endrus1 - Понедельник, 18.07.2016, 19:53
 
Ответить
СообщениеДобрый день, уважаемые эксперты!

Прошу помочь: Как в формулах ЕСЛИ использовать регулярные выражения? (Меня интересуют ячейки, которые можно найти с помощью регулярного выражения *щий)

Простенький пример прикрепил к сообщению (прошу заметить, пример не является конечной задачей, поэтому прошу не предлагать решение через "ИЛИ("Восходящий";"Нисходящий")

Другой вопрос - как в ЕСЛИ сформулировать условие "Любая непустая ячейка"? (<>0 не работает ((

Спасибо!

Автор - Endrus1
Дата добавления - 18.07.2016 в 19:52
Pelena Дата: Понедельник, 18.07.2016, 20:09 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9840
Репутация: 2252 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
ячейки, которые можно найти с помощью регулярного выражения *щий

Для Вашего примера
Код
=СУММЕСЛИ($B$2:$B$8;"*щий";$A$2:$A$8)

Любая непустая ячейка

Код
=СУММЕСЛИ($B$2:$B$8;"<>";$A$2:$A$8)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
ячейки, которые можно найти с помощью регулярного выражения *щий

Для Вашего примера
Код
=СУММЕСЛИ($B$2:$B$8;"*щий";$A$2:$A$8)

Любая непустая ячейка

Код
=СУММЕСЛИ($B$2:$B$8;"<>";$A$2:$A$8)

Автор - Pelena
Дата добавления - 18.07.2016 в 20:09
Endrus1 Дата: Вторник, 19.07.2016, 14:51 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Для Вашего примера

Добрый день! Благодарю за ответ! Работает!

Позвольте последний вопрос - а как использовать то же самое регулярное выражение в формуле ИЛИ?

Код
=ИЛИ(A1=1;B1=2;C1="*щий")


Вот в таком виде, почему-то, не работает...
 
Ответить
Сообщение
Для Вашего примера

Добрый день! Благодарю за ответ! Работает!

Позвольте последний вопрос - а как использовать то же самое регулярное выражение в формуле ИЛИ?

Код
=ИЛИ(A1=1;B1=2;C1="*щий")


Вот в таком виде, почему-то, не работает...

Автор - Endrus1
Дата добавления - 19.07.2016 в 14:51
abtextime Дата: Вторник, 19.07.2016, 15:03 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 427
Репутация: 60 ±
Замечаний: 0% ±

Excel 2010
Код
=ИЛИ(A1=1;B1=2;ЕСЛИОШИБКА(НАЙТИ("щий";C1)>0);ЛОЖЬ))


или

Код
=ИЛИ(A1=1;B1=2;C1=ПОДСТАВИТЬ(C1;"щий";""))
 
Ответить
Сообщение
Код
=ИЛИ(A1=1;B1=2;ЕСЛИОШИБКА(НАЙТИ("щий";C1)>0);ЛОЖЬ))


или

Код
=ИЛИ(A1=1;B1=2;C1=ПОДСТАВИТЬ(C1;"щий";""))

Автор - abtextime
Дата добавления - 19.07.2016 в 15:03
Endrus1 Дата: Вторник, 19.07.2016, 15:06 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо! Работает :)
 
Ответить
СообщениеСпасибо! Работает :)

Автор - Endrus1
Дата добавления - 19.07.2016 в 15:06
китин Дата: Вторник, 19.07.2016, 15:11 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3413
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
и вдогонку тупая формула массива
Код
=СУММ(ЕСЛИ(ПРАВБ($B$2:$B$8;3)="щий";$A$2:$A$8))
:D


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Вторник, 19.07.2016, 15:11
 
Ответить
Сообщениеи вдогонку тупая формула массива
Код
=СУММ(ЕСЛИ(ПРАВБ($B$2:$B$8;3)="щий";$A$2:$A$8))
:D

Автор - китин
Дата добавления - 19.07.2016 в 15:11
Che79 Дата: Вторник, 19.07.2016, 16:16 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 177
Репутация: 22 ±
Замечаний: 0% ±

Excel 2007, Excel 2010
ну или так (тоже уже вне конкурса :) )
Код
=СУММПРОИЗВ($A$2:$A$8*ЕЧИСЛО(ПОИСК("*щий";$B$2:$B$8)))


Делай нормально и будет нормально!
 
Ответить
Сообщениену или так (тоже уже вне конкурса :) )
Код
=СУММПРОИЗВ($A$2:$A$8*ЕЧИСЛО(ПОИСК("*щий";$B$2:$B$8)))

Автор - Che79
Дата добавления - 19.07.2016 в 16:16
_Boroda_ Дата: Вторник, 19.07.2016, 16:39 | Сообщение № 8
Группа: Модераторы
Ранг: Экселист
Сообщений: 9347
Репутация: 3922 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Алексей, а зачем звездень вот здесь?
ПОИСК("*щий"

В ПОИСКПОЗ да, а ПОИСК все равно ищет позицию вхождения, поэтому звезда вначале ни на что не влияет. Вот так "?щий" да, ищем любой текст, в котором "щий" не первый. Кстати, насколько я понял, вот это
найти с помощью регулярного выражения *щий
означает, что нужно именно окончание на "щий". Тогда ПОИСК и НАЙТИ без уточнений позиции вообще не подойдут. Я, правда, так вот сходу не смог придумать слово, в котором "щий" в середине.


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеАлексей, а зачем звездень вот здесь?
ПОИСК("*щий"

В ПОИСКПОЗ да, а ПОИСК все равно ищет позицию вхождения, поэтому звезда вначале ни на что не влияет. Вот так "?щий" да, ищем любой текст, в котором "щий" не первый. Кстати, насколько я понял, вот это
найти с помощью регулярного выражения *щий
означает, что нужно именно окончание на "щий". Тогда ПОИСК и НАЙТИ без уточнений позиции вообще не подойдут. Я, правда, так вот сходу не смог придумать слово, в котором "щий" в середине.

Автор - _Boroda_
Дата добавления - 19.07.2016 в 16:39
Che79 Дата: Вторник, 19.07.2016, 16:53 | Сообщение № 9
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 177
Репутация: 22 ±
Замечаний: 0% ±

Excel 2007, Excel 2010
[offtop] Александр, на мой кажуЩИЙся :D взгляд звездень была нужна. Но перечитав Вас выше и справку по ПОИСК, понял, что явно погорячился...


Делай нормально и будет нормально!
 
Ответить
Сообщение[offtop] Александр, на мой кажуЩИЙся :D взгляд звездень была нужна. Но перечитав Вас выше и справку по ПОИСК, понял, что явно погорячился...

Автор - Che79
Дата добавления - 19.07.2016 в 16:53
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Использование регулярных выражения внутри формулы (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!