Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбрать ГОСТ согласно наименованию продукции - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбрать ГОСТ согласно наименованию продукции (Формулы/Formulas)
Выбрать ГОСТ согласно наименованию продукции
lebensvoll Дата: Среда, 27.07.2016, 14:41 | Сообщение № 1
Группа: Проверенные
Ранг: Ветеран
Сообщений: 672
Репутация: 2 ±
Замечаний: 20% ±

Excel 2010
Добрый день уважаемые форумчане!!!
Чет я ни как не могу сообразить (((( хотя мне _Boroda_, мне объяснял подобную тему. Но видать память моя девичья (((( и в виду того что тема обсуждения не была мною ни где применена в работе ((( так она и схоронилась где на моих полках...
Суть моей проблемы на листе "Номенклатура ГОСТ" есть перечень номенклатуры в столбце "С" должно было отобразиться № ГОСТ (которые я прописал в столбцах О:Р) я попытался сделать так вот:
Код
=ЕСЛИ(B2="";"";ВПР(ПСТР("Добавка";ПОИСК("Добавка";B2;1);1+999);$O$2:$P$5;2;0))

Но потом посидел подумал и что!? а если там будет другая номенклатура (наименование) то снова меняй в формуле наименование поиска ((((( какой то бред....
И тут я потерялся ((( как сделать чтоб в формуле было сравнение 1-й позиции текста со списком в столбцах "О:Р" и согласно этому прописывался ГОСТ такой то
К сообщению приложен файл: _--3.xlsb(29Kb)


Кто бы ты ни был, мир в твоих руках
 
Ответить
СообщениеДобрый день уважаемые форумчане!!!
Чет я ни как не могу сообразить (((( хотя мне _Boroda_, мне объяснял подобную тему. Но видать память моя девичья (((( и в виду того что тема обсуждения не была мною ни где применена в работе ((( так она и схоронилась где на моих полках...
Суть моей проблемы на листе "Номенклатура ГОСТ" есть перечень номенклатуры в столбце "С" должно было отобразиться № ГОСТ (которые я прописал в столбцах О:Р) я попытался сделать так вот:
Код
=ЕСЛИ(B2="";"";ВПР(ПСТР("Добавка";ПОИСК("Добавка";B2;1);1+999);$O$2:$P$5;2;0))

Но потом посидел подумал и что!? а если там будет другая номенклатура (наименование) то снова меняй в формуле наименование поиска ((((( какой то бред....
И тут я потерялся ((( как сделать чтоб в формуле было сравнение 1-й позиции текста со списком в столбцах "О:Р" и согласно этому прописывался ГОСТ такой то

Автор - lebensvoll
Дата добавления - 27.07.2016 в 14:41
buchlotnik Дата: Среда, 27.07.2016, 14:47 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3005
Репутация: 839 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
вариант:
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК($O$2:$O$5;B2);$P$2:$P$5);"")
К сообщению приложен файл: -3.xlsb(24Kb)


каждому For - Next!
платная помощь:
ЯД: 410012595572239
buchlotnik@mail.ru
 
Ответить
Сообщениевариант:
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-ПОИСК($O$2:$O$5;B2);$P$2:$P$5);"")

Автор - buchlotnik
Дата добавления - 27.07.2016 в 14:47
lebensvoll Дата: Среда, 27.07.2016, 14:49 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 672
Репутация: 2 ±
Замечаний: 20% ±

Excel 2010
buchlotnik, да все так как нужно, спасибо!!!


Кто бы ты ни был, мир в твоих руках
 
Ответить
Сообщениеbuchlotnik, да все так как нужно, спасибо!!!

Автор - lebensvoll
Дата добавления - 27.07.2016 в 14:49
AlexM Дата: Среда, 27.07.2016, 15:36 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3585
Репутация: 902 ±
Замечаний: 0% ±

Excel 2003
Еще вариант
Код
=ЕСЛИОШИБКА(ВПР(ЛЕВБ(B2;5)&"*";O$2:P$5;2;);"")



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеЕще вариант
Код
=ЕСЛИОШИБКА(ВПР(ЛЕВБ(B2;5)&"*";O$2:P$5;2;);"")

Автор - AlexM
Дата добавления - 27.07.2016 в 15:36
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбрать ГОСТ согласно наименованию продукции (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!