Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как разделить текст из ячейки по нескольким - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как разделить текст из ячейки по нескольким (Формулы/Formulas)
Как разделить текст из ячейки по нескольким
REA Дата: Четверг, 28.07.2016, 01:01 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Есть ячейки с текстом. Отформатированные так, как отформатированы.
Нужно С15 разложить поячеечно так, как ниже сделано для образца.
Лучше с помощью формул в этих ячейках. Но макрос наверное тоже возможен.
Если кто сталкивался с подобным, пож, окажите помощь!
Там есть заготовки. Но они не полностью закрывают вопрос. (((
Спасибо умельцам!
[moder]Нрушение п.2 Правил форума. Исправляйте[/moder]
К сообщению приложен файл: ___.xlsx(82Kb)


Процветайте и преуспевайте!

Сообщение отредактировал REA - Четверг, 28.07.2016, 10:09
 
Ответить
СообщениеЕсть ячейки с текстом. Отформатированные так, как отформатированы.
Нужно С15 разложить поячеечно так, как ниже сделано для образца.
Лучше с помощью формул в этих ячейках. Но макрос наверное тоже возможен.
Если кто сталкивался с подобным, пож, окажите помощь!
Там есть заготовки. Но они не полностью закрывают вопрос. (((
Спасибо умельцам!
[moder]Нрушение п.2 Правил форума. Исправляйте[/moder]

Автор - REA
Дата добавления - 28.07.2016 в 01:01
buchlotnik Дата: Четверг, 28.07.2016, 01:08 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
а вот за такое название темы Вам скоро модераторы влепят замечание - переименуйте в соответствии с правилами форума


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщениеа вот за такое название темы Вам скоро модераторы влепят замечание - переименуйте в соответствии с правилами форума

Автор - buchlotnik
Дата добавления - 28.07.2016 в 01:08
китин Дата: Четверг, 28.07.2016, 08:08 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3413
Репутация: 543 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
[offtop]Михаил ну просто провидец и предсказатель!!!!! :D


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение[offtop]Михаил ну просто провидец и предсказатель!!!!! :D

Автор - китин
Дата добавления - 28.07.2016 в 08:08
ShAM Дата: Четверг, 28.07.2016, 12:08 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1233
Репутация: 209 ±
Замечаний: 0% ±

Excel 2010
Так подойдет?
Код
=СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(СИМВОЛ(10)&C$15;СИМВОЛ(10);ПОВТОР(" ";999));СТРОКА(C1)*999;999))

ЗЫ: Стырил наглым образом у Александра (_Boroda_) из этой темы.
ЗЫ2: Цитата из той темы:
Кстати, а что мы вообще ищем? Перенос строки? А почему тогда тема называется Неразрывный пробел?
А я ее (тему) нашел как раз через поиск "Неразрывный пробел". :D
К сообщению приложен файл: REA.xlsx(87Kb)
 
Ответить
СообщениеТак подойдет?
Код
=СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(СИМВОЛ(10)&C$15;СИМВОЛ(10);ПОВТОР(" ";999));СТРОКА(C1)*999;999))

ЗЫ: Стырил наглым образом у Александра (_Boroda_) из этой темы.
ЗЫ2: Цитата из той темы:
Кстати, а что мы вообще ищем? Перенос строки? А почему тогда тема называется Неразрывный пробел?
А я ее (тему) нашел как раз через поиск "Неразрывный пробел". :D

Автор - ShAM
Дата добавления - 28.07.2016 в 12:08
REA Дата: Четверг, 28.07.2016, 12:42 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
ShAM, Спасибо. Еще не разбирался, но выглядит приемлемо. Только плюсики, то автоматически не ставит (


Процветайте и преуспевайте!
 
Ответить
СообщениеShAM, Спасибо. Еще не разбирался, но выглядит приемлемо. Только плюсики, то автоматически не ставит (

Автор - REA
Дата добавления - 28.07.2016 в 12:42
ShAM Дата: Четверг, 28.07.2016, 13:09 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1233
Репутация: 209 ±
Замечаний: 0% ±

Excel 2010
А где у Вас до этого про плюсики написано было?
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК(D$16;$C18));"+";"")
К сообщению приложен файл: REA_1.xlsx(87Kb)
 
Ответить
СообщениеА где у Вас до этого про плюсики написано было?
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК(D$16;$C18));"+";"")

Автор - ShAM
Дата добавления - 28.07.2016 в 13:09
REA Дата: Пятница, 29.07.2016, 00:36 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
ShAM, Круто! Спасибо огромное - Вы мне очень помогли! Все работает и я даже разобрался!!! ))) Успехов!


Процветайте и преуспевайте!
 
Ответить
СообщениеShAM, Круто! Спасибо огромное - Вы мне очень помогли! Все работает и я даже разобрался!!! ))) Успехов!

Автор - REA
Дата добавления - 29.07.2016 в 00:36
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как разделить текст из ячейки по нескольким (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!