Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула умножения по услов. в одной ячейке без доп.столбцов. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула умножения по услов. в одной ячейке без доп.столбцов. (Формулы/Formulas)
Формула умножения по услов. в одной ячейке без доп.столбцов.
Leanna Дата: Четверг, 28.07.2016, 10:37 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 185
Репутация: 78 ±
Замечаний: 0% ±

excel 2010
Здравствуйте вы такие чудеса формулами творите, может вы и мне сможете помочь.

Можно ли избавиться от доп столбца и сделать так, чтобы расчет происходил в одной ячейке?

Пример во вложении с нужным расчетом.
К сообщению приложен файл: 8089855.xlsx(11Kb)


Лучше день потерять, потом за пять минут долететь!
 
Ответить
СообщениеЗдравствуйте вы такие чудеса формулами творите, может вы и мне сможете помочь.

Можно ли избавиться от доп столбца и сделать так, чтобы расчет происходил в одной ячейке?

Пример во вложении с нужным расчетом.

Автор - Leanna
Дата добавления - 28.07.2016 в 10:37
buchlotnik Дата: Четверг, 28.07.2016, 10:49 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
вот такая массивка вышла:
Код
=СУММ(B4:B33*ЕСЛИ(ЕПУСТО(C4:C33);C3;C4:C33))

или чуть проще
Код
=СУММ(B4:B33*ЕСЛИ(C4:C33;C4:C33;C3))
К сообщению приложен файл: 6375935.xlsx(12Kb)


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Четверг, 28.07.2016, 10:53
 
Ответить
Сообщениевот такая массивка вышла:
Код
=СУММ(B4:B33*ЕСЛИ(ЕПУСТО(C4:C33);C3;C4:C33))

или чуть проще
Код
=СУММ(B4:B33*ЕСЛИ(C4:C33;C4:C33;C3))

Автор - buchlotnik
Дата добавления - 28.07.2016 в 10:49
_Boroda_ Дата: Четверг, 28.07.2016, 10:53 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 9354
Репутация: 3924 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Или так
Код
=СУММ(B4:B33*ЕСЛИ(C4:C33;C4:C33;C3))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеИли так
Код
=СУММ(B4:B33*ЕСЛИ(C4:C33;C4:C33;C3))

Автор - _Boroda_
Дата добавления - 28.07.2016 в 10:53
Leanna Дата: Четверг, 28.07.2016, 10:54 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 185
Репутация: 78 ±
Замечаний: 0% ±

excel 2010
buchlotnik, Спасибо большое! то что надо!


Лучше день потерять, потом за пять минут долететь!
 
Ответить
Сообщениеbuchlotnik, Спасибо большое! то что надо!

Автор - Leanna
Дата добавления - 28.07.2016 в 10:54
buchlotnik Дата: Четверг, 28.07.2016, 10:54 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
_Boroda_, Александр, ну с языка снял :D


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru
 
Ответить
Сообщение_Boroda_, Александр, ну с языка снял :D

Автор - buchlotnik
Дата добавления - 28.07.2016 в 10:54
_Boroda_ Дата: Четверг, 28.07.2016, 11:00 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 9354
Репутация: 3924 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Ну и немассивка + извращение с ТЕКСТ
Код
=СУММПРОИЗВ(ТЕКСТ(C4:C33;"0;;"&C3)*B4:B33)
К сообщению приложен файл: 8089855_1.xlsx(11Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНу и немассивка + извращение с ТЕКСТ
Код
=СУММПРОИЗВ(ТЕКСТ(C4:C33;"0;;"&C3)*B4:B33)

Автор - _Boroda_
Дата добавления - 28.07.2016 в 11:00
Manyasha Дата: Четверг, 28.07.2016, 11:01 | Сообщение № 7
Группа: Модераторы
Ранг: Старожил
Сообщений: 1586
Репутация: 662 ±
Замечаний: 0% ±

Excel 2007, 2010
еще вариант, обычная:
Код
=СУММПРОИЗВ(B4:B33*((C4:C33=0)*C3+C4:C33))
К сообщению приложен файл: 8089855-2.xlsx(12Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
Сообщениееще вариант, обычная:
Код
=СУММПРОИЗВ(B4:B33*((C4:C33=0)*C3+C4:C33))

Автор - Manyasha
Дата добавления - 28.07.2016 в 11:01
buchlotnik Дата: Четверг, 28.07.2016, 11:04 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 2049
Репутация: 613 ±
Замечаний: 0% ±

2010, 2013, 2016 RUS / ENG
Да что за день-то :D
Код
=СУММПРОИЗВ(B4:B33*ТЕКСТ(C4:C33;"[=0]"&C3&";0,00"))
ТЕКСТ - это не извращение...


платная помощь:
ЯД: 410012595572239; WM: 311017577133
buchlotnik@mail.ru


Сообщение отредактировал buchlotnik - Четверг, 28.07.2016, 11:04
 
Ответить
СообщениеДа что за день-то :D
Код
=СУММПРОИЗВ(B4:B33*ТЕКСТ(C4:C33;"[=0]"&C3&";0,00"))
ТЕКСТ - это не извращение...

Автор - buchlotnik
Дата добавления - 28.07.2016 в 11:04
_Boroda_ Дата: Четверг, 28.07.2016, 11:09 | Сообщение № 9
Группа: Модераторы
Ранг: Экселист
Сообщений: 9354
Репутация: 3924 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
ТЕКСТ - это не извращение...
И Ви таки мине ето будите говорить?

Еще вариант
Код
=СУММЕСЛИ(C4:C33;"=";B4:B33)*C3+СУММПРОИЗВ(B4:B33;C4:C33)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
ТЕКСТ - это не извращение...
И Ви таки мине ето будите говорить?

Еще вариант
Код
=СУММЕСЛИ(C4:C33;"=";B4:B33)*C3+СУММПРОИЗВ(B4:B33;C4:C33)

Автор - _Boroda_
Дата добавления - 28.07.2016 в 11:09
Leanna Дата: Четверг, 28.07.2016, 11:46 | Сообщение № 10
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 185
Репутация: 78 ±
Замечаний: 0% ±

excel 2010
Вау сколько вариантов!
Мне с СУММПРОИЗВ от Manyasha очень ещё понравилось.
А можно расшифровать её? Суммпроизв знаю и пользую. Интересует эта часть ((C4:C33=0)*C3+C4:C33)


Лучше день потерять, потом за пять минут долететь!
 
Ответить
СообщениеВау сколько вариантов!
Мне с СУММПРОИЗВ от Manyasha очень ещё понравилось.
А можно расшифровать её? Суммпроизв знаю и пользую. Интересует эта часть ((C4:C33=0)*C3+C4:C33)

Автор - Leanna
Дата добавления - 28.07.2016 в 11:46
Manyasha Дата: Четверг, 28.07.2016, 12:01 | Сообщение № 11
Группа: Модераторы
Ранг: Старожил
Сообщений: 1586
Репутация: 662 ±
Замечаний: 0% ±

Excel 2007, 2010
Leanna, (C4:C33=0) вернет массив из 1 и 0, полученный массив умножается на значение C3, в итоге получим массив из нулей и C3.
Т.е., для пустых строк в столбце С вернется значение С3, а для заполненных - 0. Чтобы вместо нуля для этих ячеек вернулись значения столбца С прибавим +C4:C33

Если не очень понятно объяснила, можно по F9 в формуле посмотреть)) (выделить кусочек формулы и нажать f9)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804


Сообщение отредактировал Manyasha - Четверг, 28.07.2016, 12:02
 
Ответить
СообщениеLeanna, (C4:C33=0) вернет массив из 1 и 0, полученный массив умножается на значение C3, в итоге получим массив из нулей и C3.
Т.е., для пустых строк в столбце С вернется значение С3, а для заполненных - 0. Чтобы вместо нуля для этих ячеек вернулись значения столбца С прибавим +C4:C33

Если не очень понятно объяснила, можно по F9 в формуле посмотреть)) (выделить кусочек формулы и нажать f9)

Автор - Manyasha
Дата добавления - 28.07.2016 в 12:01
Leanna Дата: Четверг, 28.07.2016, 12:11 | Сообщение № 12
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 185
Репутация: 78 ±
Замечаний: 0% ±

excel 2010
Manyasha, всё очень понятно! спасибо! мне очень нравится такое решение, думала без формулы массива (в которых я не очень понимаю) тут никак.


Лучше день потерять, потом за пять минут долететь!
 
Ответить
СообщениеManyasha, всё очень понятно! спасибо! мне очень нравится такое решение, думала без формулы массива (в которых я не очень понимаю) тут никак.

Автор - Leanna
Дата добавления - 28.07.2016 в 12:11
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула умножения по услов. в одной ячейке без доп.столбцов. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!