Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск ячейки в диапазоне и вывод соседней на лист - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск ячейки в диапазоне и вывод соседней на лист (Формулы/Formulas)
Поиск ячейки в диапазоне и вывод соседней на лист
REA Дата: Пятница, 29.07.2016, 01:42 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Есть Лист1, где есть диапазоны.
На листе 2 в а1 вводится код и в ячейку в1 нужно вывести содержание ячейки, отстоящей на несколько от той, где найден этот код на Листе1.
Минимассивов много, поэтому формулу подобрать не смог.
Если так нельзя - за простенький макрос буду признателен.
К сообщению приложен файл: 12.xlsx(10Kb)


Процветайте и преуспевайте!
 
Ответить
СообщениеЕсть Лист1, где есть диапазоны.
На листе 2 в а1 вводится код и в ячейку в1 нужно вывести содержание ячейки, отстоящей на несколько от той, где найден этот код на Листе1.
Минимассивов много, поэтому формулу подобрать не смог.
Если так нельзя - за простенький макрос буду признателен.

Автор - REA
Дата добавления - 29.07.2016 в 01:42
_Boroda_ Дата: Пятница, 29.07.2016, 01:52 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9377
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ИНДЕКС(Лист1!C1:Z99;СУММПРОИЗВ(СТРОКА(Лист1!1:99)*(Лист1!A1:X99=A1));СУММПРОИЗВ(СТОЛБЕЦ(Лист1!A:X)*(Лист1!A1:X99=A1)))
К сообщению приложен файл: 468467_1.xlsx(10Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ИНДЕКС(Лист1!C1:Z99;СУММПРОИЗВ(СТРОКА(Лист1!1:99)*(Лист1!A1:X99=A1));СУММПРОИЗВ(СТОЛБЕЦ(Лист1!A:X)*(Лист1!A1:X99=A1)))

Автор - _Boroda_
Дата добавления - 29.07.2016 в 01:52
REA Дата: Пятница, 29.07.2016, 02:31 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
_Boroda_, Не понял ничегошеньки в отношении суммпроизв. Но... РАБОТАЕТ ЖЕ )))
Спасибо. А я думал в макросы придется лезть...

НО КАК? В описании функции совсем иначе форма функции выглядит!!! Чего я не вижу и не понимаю?!

И если говорить о полном варианте, то может и он не так невозможен. Выводить бы хорошо по названию Поля. И оно на разном расстоянии от кодов. (
Я первый то вариант писал без какой-либо надежды! )))
К сообщению приложен файл: 2545658.xlsx(11Kb)


Процветайте и преуспевайте!

Сообщение отредактировал REA - Пятница, 29.07.2016, 02:49
 
Ответить
Сообщение_Boroda_, Не понял ничегошеньки в отношении суммпроизв. Но... РАБОТАЕТ ЖЕ )))
Спасибо. А я думал в макросы придется лезть...

НО КАК? В описании функции совсем иначе форма функции выглядит!!! Чего я не вижу и не понимаю?!

И если говорить о полном варианте, то может и он не так невозможен. Выводить бы хорошо по названию Поля. И оно на разном расстоянии от кодов. (
Я первый то вариант писал без какой-либо надежды! )))

Автор - REA
Дата добавления - 29.07.2016 в 02:31
_Boroda_ Дата: Пятница, 29.07.2016, 09:13 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9377
Репутация: 3950 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вот я почему-то именно так и подумал еще с самого начала.
если говорить о полном варианте
, то выложите его полностью ИМЕННО В ТОМ ВИДЕ, В КОТОРОМ ОН ЕСТЬ. Конф. информацию замените на нейтральную. Именно замените, а не сотрите.
А играть в игру "Как все здорово, только у меня в файле все иначе" желающих не так уж и много найдется.


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВот я почему-то именно так и подумал еще с самого начала.
если говорить о полном варианте
, то выложите его полностью ИМЕННО В ТОМ ВИДЕ, В КОТОРОМ ОН ЕСТЬ. Конф. информацию замените на нейтральную. Именно замените, а не сотрите.
А играть в игру "Как все здорово, только у меня в файле все иначе" желающих не так уж и много найдется.

Автор - _Boroda_
Дата добавления - 29.07.2016 в 09:13
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск ячейки в диапазоне и вывод соседней на лист (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!