Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автоматическое заполнение данных при вводе парт-номера... - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическое заполнение данных при вводе парт-номера... (Формулы/Formulas)
Автоматическое заполнение данных при вводе парт-номера...
ssam_AleX Дата: Воскресенье, 31.07.2016, 17:26 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Приветствую всех!

Долго искал решение своей проблемы. Таки не нашёл решения, но набрёл на данный форум.

Мне необходимо по работе вводить полученные зап.части в excel, для их последующего учёта.
Списки получаю большие, хотя зап.части по большому счёту, одинаковые и присутствуют в списках по несколько раз.

Необходимо, чтоб при вводе только парт-номера зап.части - автоматом заполнялись следующие правые две ячейки с описанием самой зап.части и номером модели, для которого предназначена сия зап.часть, из списка выше либо другого источника.
Имеется вручную уже созданный список парт-номеров с соответствующим им описаниям и моделям.

В примере показано конкретней, что именно требуется.

Пользуюсь MS Office 2013
К сообщению приложен файл: 9886477.xls(39Kb)


Сообщение отредактировал ssam_AleX - Воскресенье, 31.07.2016, 17:26
 
Ответить
СообщениеПриветствую всех!

Долго искал решение своей проблемы. Таки не нашёл решения, но набрёл на данный форум.

Мне необходимо по работе вводить полученные зап.части в excel, для их последующего учёта.
Списки получаю большие, хотя зап.части по большому счёту, одинаковые и присутствуют в списках по несколько раз.

Необходимо, чтоб при вводе только парт-номера зап.части - автоматом заполнялись следующие правые две ячейки с описанием самой зап.части и номером модели, для которого предназначена сия зап.часть, из списка выше либо другого источника.
Имеется вручную уже созданный список парт-номеров с соответствующим им описаниям и моделям.

В примере показано конкретней, что именно требуется.

Пользуюсь MS Office 2013

Автор - ssam_AleX
Дата добавления - 31.07.2016 в 17:26
Nic70y Дата: Воскресенье, 31.07.2016, 17:52 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3481
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
Так штоль:
Код
=ВПР($E91;$E$71:$G$89;СТОЛБЕЦ(B1);)
К сообщению приложен файл: 3204115.xls(41Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
СообщениеТак штоль:
Код
=ВПР($E91;$E$71:$G$89;СТОЛБЕЦ(B1);)

Автор - Nic70y
Дата добавления - 31.07.2016 в 17:52
AlexM Дата: Воскресенье, 31.07.2016, 17:52 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3053
Репутация: 740 ±
Замечаний: 0% ±

Формула для F91
Код
=ЕСЛИОШИБКА(ВПР($E91;$E$2:$G90;2;);"")
Для G91 в формуле помениять 2 на 3.
Функция ЕСЛИОШИБКА() использована на случай ввода нового номера ПАРТ-НОМЕР, для которого нет описания


Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Воскресенье, 31.07.2016, 22:53
 
Ответить
СообщениеФормула для F91
Код
=ЕСЛИОШИБКА(ВПР($E91;$E$2:$G90;2;);"")
Для G91 в формуле помениять 2 на 3.
Функция ЕСЛИОШИБКА() использована на случай ввода нового номера ПАРТ-НОМЕР, для которого нет описания

Автор - AlexM
Дата добавления - 31.07.2016 в 17:52
ssam_AleX Дата: Воскресенье, 31.07.2016, 20:07 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
СПАСИБО Вам, за ВПР!

Разобрался, что да как и переделал под себя формулу, предварительно создав дополнительный лист со списком всех парт-номеров с их описаниями и моделями для источника ВПР.

По данной формуле заполняется описание зап.части
Код
=ЕСЛИОШИБКА(ВПР(E915;'Samsung Парт-Номера'!$A$1:$C$274;2;ЛОЖЬ);"не найден")


По этой - модель сей зап.части
Код
=ЕСЛИОШИБКА(ВПР(E915;'Samsung Парт-Номера'!$A$1:$C$274;3;ЛОЖЬ);"не найден")


Соответственно, если не найдено соответствие - то выходит надпись "не найден"

Ещё раз всем спасибо.
 
Ответить
СообщениеСПАСИБО Вам, за ВПР!

Разобрался, что да как и переделал под себя формулу, предварительно создав дополнительный лист со списком всех парт-номеров с их описаниями и моделями для источника ВПР.

По данной формуле заполняется описание зап.части
Код
=ЕСЛИОШИБКА(ВПР(E915;'Samsung Парт-Номера'!$A$1:$C$274;2;ЛОЖЬ);"не найден")


По этой - модель сей зап.части
Код
=ЕСЛИОШИБКА(ВПР(E915;'Samsung Парт-Номера'!$A$1:$C$274;3;ЛОЖЬ);"не найден")


Соответственно, если не найдено соответствие - то выходит надпись "не найден"

Ещё раз всем спасибо.

Автор - ssam_AleX
Дата добавления - 31.07.2016 в 20:07
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическое заполнение данных при вводе парт-номера... (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!