Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/индекс поискпоз по 2 столбцам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » индекс поискпоз по 2 столбцам (Формулы/Formulas)
индекс поискпоз по 2 столбцам
miha_ Дата: Воскресенье, 31.07.2016, 19:11 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день, уважаемые форумчане.
Столкнулся с трудностью. При использовании формул индекс и поискпоз, не могу добиться требуемого результата. А именно поиска не по одному столбцу, а по двум.
Может что то не так делаю?
Пример во вложении.
Спасибо.
К сообщению приложен файл: 2154305.xls(24Kb)
 
Ответить
СообщениеДобрый день, уважаемые форумчане.
Столкнулся с трудностью. При использовании формул индекс и поискпоз, не могу добиться требуемого результата. А именно поиска не по одному столбцу, а по двум.
Может что то не так делаю?
Пример во вложении.
Спасибо.

Автор - miha_
Дата добавления - 31.07.2016 в 19:11
Pelena Дата: Воскресенье, 31.07.2016, 19:17 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9890
Репутация: 2269 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Здравствуйте.
Как вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС(D$3:D$7;ПОИСКПОЗ($H$3;$A$3:$A$7;0));ИНДЕКС(D$3:D$7;ПОИСКПОЗ($H$3;$B$3:$B$7;0)))
К сообщению приложен файл: 3755082.xls(25Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Как вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС(D$3:D$7;ПОИСКПОЗ($H$3;$A$3:$A$7;0));ИНДЕКС(D$3:D$7;ПОИСКПОЗ($H$3;$B$3:$B$7;0)))

Автор - Pelena
Дата добавления - 31.07.2016 в 19:17
miha_ Дата: Воскресенье, 31.07.2016, 19:25 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Pelena, Спасибо.
То,что нужно.
 
Ответить
СообщениеPelena, Спасибо.
То,что нужно.

Автор - miha_
Дата добавления - 31.07.2016 в 19:25
_Boroda_ Дата: Воскресенье, 31.07.2016, 20:35 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 9381
Репутация: 3951 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще похожее
Код
=ИНДЕКС(D3:D7;ЕСЛИОШИБКА(ПОИСКПОЗ($H3;$A3:$A7;);ПОИСКПОЗ($H3;$B3:$B7;)))

И немного другое
Код
=ПРОСМОТР(;-1/(($A3:$A7=$H3)+($B3:$B7=$H3));D3:D7)

И формула массива (вводится одновременным нажатием Контрл Шифт Ентер)
Код
=ИНДЕКС(D3:D7;ПОИСКПОЗ("*"&$H3&"*";$A3:$A7&$B3:$B7;))
К сообщению приложен файл: 2154305_1.xls(29Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще похожее
Код
=ИНДЕКС(D3:D7;ЕСЛИОШИБКА(ПОИСКПОЗ($H3;$A3:$A7;);ПОИСКПОЗ($H3;$B3:$B7;)))

И немного другое
Код
=ПРОСМОТР(;-1/(($A3:$A7=$H3)+($B3:$B7=$H3));D3:D7)

И формула массива (вводится одновременным нажатием Контрл Шифт Ентер)
Код
=ИНДЕКС(D3:D7;ПОИСКПОЗ("*"&$H3&"*";$A3:$A7&$B3:$B7;))

Автор - _Boroda_
Дата добавления - 31.07.2016 в 20:35
miha_ Дата: Воскресенье, 31.07.2016, 20:42 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, Спасибо.
 
Ответить
Сообщение_Boroda_, Спасибо.

Автор - miha_
Дата добавления - 31.07.2016 в 20:42
jakim Дата: Воскресенье, 31.07.2016, 21:37 | Сообщение № 6
Группа: Друзья
Ранг: Ветеран
Сообщений: 683
Репутация: 172 ±
Замечаний: 0% ±

Для Вашего офиса ещё одна формула.

Код
=INDEX(D3:D300;AGGREGATE(15;6;ROW($1:$300)/($A$3:$B$300=$H$3);1))

и ещё попроще

Код
=AGGREGATE(15;6;D$3:D$7/($A$3:$B$7=$H$3);1)


Сообщение отредактировал jakim - Воскресенье, 31.07.2016, 21:49
 
Ответить
Сообщение
Для Вашего офиса ещё одна формула.

Код
=INDEX(D3:D300;AGGREGATE(15;6;ROW($1:$300)/($A$3:$B$300=$H$3);1))

и ещё попроще

Код
=AGGREGATE(15;6;D$3:D$7/($A$3:$B$7=$H$3);1)

Автор - jakim
Дата добавления - 31.07.2016 в 21:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » индекс поискпоз по 2 столбцам (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!