Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование ячеек, соответсвующих определенному условию. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование ячеек, соответсвующих определенному условию. (Формулы/Formulas)
Суммирование ячеек, соответсвующих определенному условию.
Shtein Дата: Суббота, 06.08.2016, 00:05 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Всем привет.

Возникла задача, никак не могу понять, с какого бока подойти, прикладываю файл.
Нужно, чтобы в ячейке Н2 подсчитывались все цифры с диапазона С2:E6, но не всех строк, а только тех, где в столбце В стоит "Да".
В ячейке Н3, нужно чтобы посчитывались точно также, из то-го же диапазона, но только из тех строк, где в столбце В указано "Нет".

Количество таких строк с городами может быть сотни, это я для примера 5 ввел. Пробовал разные варианты с формулами СУММЕСЛИ, СЧЕТЕСЛИ, но что-то все мимо.
Если есть идеи, буду премного благодарен.
К сообщению приложен файл: 6672906.xlsx(9Kb)


"В мире давным давно все известно, главное знать у кого спросить"
Рэй Бредбери.


Сообщение отредактировал Shtein - Суббота, 06.08.2016, 00:05
 
Ответить
СообщениеВсем привет.

Возникла задача, никак не могу понять, с какого бока подойти, прикладываю файл.
Нужно, чтобы в ячейке Н2 подсчитывались все цифры с диапазона С2:E6, но не всех строк, а только тех, где в столбце В стоит "Да".
В ячейке Н3, нужно чтобы посчитывались точно также, из то-го же диапазона, но только из тех строк, где в столбце В указано "Нет".

Количество таких строк с городами может быть сотни, это я для примера 5 ввел. Пробовал разные варианты с формулами СУММЕСЛИ, СЧЕТЕСЛИ, но что-то все мимо.
Если есть идеи, буду премного благодарен.

Автор - Shtein
Дата добавления - 06.08.2016 в 00:05
gling Дата: Суббота, 06.08.2016, 00:19 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1392
Репутация: 341 ±
Замечаний: 0% ±

2010
Здравствуйте. Попробуйте такую
Код
=СУММПРОИЗВ(($B$2:$B$6="да")*$C$2:$E$6)
или сумму по строкам в доп столбце и суммесли по доп столбцу.
 
Ответить
СообщениеЗдравствуйте. Попробуйте такую
Код
=СУММПРОИЗВ(($B$2:$B$6="да")*$C$2:$E$6)
или сумму по строкам в доп столбце и суммесли по доп столбцу.

Автор - gling
Дата добавления - 06.08.2016 в 00:19
Shtein Дата: Суббота, 06.08.2016, 10:35 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
gling,

Спасибо, формула, самое то, работает как нужно (правда не совсем пойму синтаксис, зачем там * - знак умножения, ну да ладно) victory
А если чуть-чуть усложнить, и чтобы суммировало по 2-условия? Пример во вложении. Пробовал как то функцию И внедрить в Вашу формулу, не принимается.
К сообщению приложен файл: 3896669.xlsx(9Kb)


"В мире давным давно все известно, главное знать у кого спросить"
Рэй Бредбери.
 
Ответить
Сообщениеgling,

Спасибо, формула, самое то, работает как нужно (правда не совсем пойму синтаксис, зачем там * - знак умножения, ну да ладно) victory
А если чуть-чуть усложнить, и чтобы суммировало по 2-условия? Пример во вложении. Пробовал как то функцию И внедрить в Вашу формулу, не принимается.

Автор - Shtein
Дата добавления - 06.08.2016 в 10:35
Pelena Дата: Суббота, 06.08.2016, 10:43 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 10391
Репутация: 2353 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Так можно
Код
=СУММПРОИЗВ(($B$2:$B$6="Бензин")*($C$2:$C$6="да")*$D$2:$F$6)

А если немного по-другому оформить, то можно и протягиваемую формулу соорудить (см. файл)
К сообщению приложен файл: 3047376.xlsx(9Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеТак можно
Код
=СУММПРОИЗВ(($B$2:$B$6="Бензин")*($C$2:$C$6="да")*$D$2:$F$6)

А если немного по-другому оформить, то можно и протягиваемую формулу соорудить (см. файл)

Автор - Pelena
Дата добавления - 06.08.2016 в 10:43
Shtein Дата: Суббота, 06.08.2016, 11:33 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Ухх, спасибо Вам, побежал прикручивать )))

П.С. возникла небольшая проблема(
формулу =СУММПРОИЗВ(($E$9:$E$10="Да")*$H$9:$I$10) мне нужно было прикрутить на другой лист.
То есть на Лист1 формула должна находиться и показывать результат, но должна тянуть диапазон с другого листа (Лист2), но при вставке на Лист1 формула не вставляется.. я уже добавлял Лист1! в начале ее..

И еще такой момент, если мне нужно заранее указать более большой диапазон, чем есть строк, на перспективу (как сейчас в ячейке I3) - формула тоже выдает ошибку, получается нужно строго, чтобы весь диапазон был заполнен данными?
К сообщению приложен файл: 9926976.xlsx(10Kb)


"В мире давным давно все известно, главное знать у кого спросить"
Рэй Бредбери.


Сообщение отредактировал Shtein - Суббота, 06.08.2016, 12:05
 
Ответить
СообщениеУхх, спасибо Вам, побежал прикручивать )))

П.С. возникла небольшая проблема(
формулу =СУММПРОИЗВ(($E$9:$E$10="Да")*$H$9:$I$10) мне нужно было прикрутить на другой лист.
То есть на Лист1 формула должна находиться и показывать результат, но должна тянуть диапазон с другого листа (Лист2), но при вставке на Лист1 формула не вставляется.. я уже добавлял Лист1! в начале ее..

И еще такой момент, если мне нужно заранее указать более большой диапазон, чем есть строк, на перспективу (как сейчас в ячейке I3) - формула тоже выдает ошибку, получается нужно строго, чтобы весь диапазон был заполнен данными?

Автор - Shtein
Дата добавления - 06.08.2016 в 11:33
gling Дата: Суббота, 06.08.2016, 12:15 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1392
Репутация: 341 ±
Замечаний: 0% ±

2010
Должно быть так
Код
=СУММПРОИЗВ((Лист2!$C$2:$C$6="нЕт")*Лист2!$D$2:$F$6)
 
Ответить
СообщениеДолжно быть так
Код
=СУММПРОИЗВ((Лист2!$C$2:$C$6="нЕт")*Лист2!$D$2:$F$6)

Автор - gling
Дата добавления - 06.08.2016 в 12:15
Shtein Дата: Суббота, 06.08.2016, 12:45 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
gling, да, так работает, благодарю.

Не сочтите за назойливость, а можно ли сделать как-то, чтобы аналогичная какая-то формула считала в диапазоне D2:F6 не по наличию в ячейке цифры 1, а по наличию какого-либо текста (например "Да"). Формула в ячейке I2 на Лист3. По сути тоже самое, только вместо 1, будет "Да", результат подсчета в I2 должен быть 5.

Я пробовал скомбинировать с СЧЕТЕСЛИ, но не срабатывает, руки у меня наверное не из того места..
К сообщению приложен файл: 6324514.xlsx(11Kb)


"В мире давным давно все известно, главное знать у кого спросить"
Рэй Бредбери.
 
Ответить
Сообщениеgling, да, так работает, благодарю.

Не сочтите за назойливость, а можно ли сделать как-то, чтобы аналогичная какая-то формула считала в диапазоне D2:F6 не по наличию в ячейке цифры 1, а по наличию какого-либо текста (например "Да"). Формула в ячейке I2 на Лист3. По сути тоже самое, только вместо 1, будет "Да", результат подсчета в I2 должен быть 5.

Я пробовал скомбинировать с СЧЕТЕСЛИ, но не срабатывает, руки у меня наверное не из того места..

Автор - Shtein
Дата добавления - 06.08.2016 в 12:45
Nic70y Дата: Суббота, 06.08.2016, 12:50 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3656
Репутация: 752 ±
Замечаний: 0% ±

Excel 2013
Код
=СУММПРОИЗВ(($B$2:$B$6=H5)*($C$2:$C$6=G5)*($D$2:$F$6="да"))


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(($B$2:$B$6=H5)*($C$2:$C$6=G5)*($D$2:$F$6="да"))

Автор - Nic70y
Дата добавления - 06.08.2016 в 12:50
Shtein Дата: Суббота, 06.08.2016, 12:55 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 46
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Спасибо ребята, вы даже не представлятете, как облегчили мою жизнь, поставил Спасибо, сколько система дала.


"В мире давным давно все известно, главное знать у кого спросить"
Рэй Бредбери.
 
Ответить
СообщениеСпасибо ребята, вы даже не представлятете, как облегчили мою жизнь, поставил Спасибо, сколько система дала.

Автор - Shtein
Дата добавления - 06.08.2016 в 12:55
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование ячеек, соответсвующих определенному условию. (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!