Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/поиск рядов положительных чисел и вычисление среднего кол-в - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » поиск рядов положительных чисел и вычисление среднего кол-в (Формулы/Formulas)
поиск рядов положительных чисел и вычисление среднего кол-в
linkod Дата: Воскресенье, 07.08.2016, 11:57 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac
в большом массиве данных надо найти подряд идущие ряды чисел положительных и найти среднее количество ячеек в них. как это сделать? всю голову уже сломал.
 
Ответить
Сообщениев большом массиве данных надо найти подряд идущие ряды чисел положительных и найти среднее количество ячеек в них. как это сделать? всю голову уже сломал.

Автор - linkod
Дата добавления - 07.08.2016 в 11:57
Manyasha Дата: Понедельник, 08.08.2016, 13:33 | Сообщение № 2
Группа: Модераторы
Ранг: Старожил
Сообщений: 1832
Репутация: 766 ±
Замечаний: 0% ±

Excel 2007, 2010
linkod, так пойдет?
Код
=СРЗНАЧ(ЕСЛИ(ЧАСТОТА(СТРОКА(A1:A21)+1;СТРОКА(A2:A21)*(A2:A21<=0))>1;ЧАСТОТА(СТРОКА(A1:A21)+1;СТРОКА(A2:A21)*(A2:A21<=0))-1))

формула массива, вводится через ctrl+shift+enter.

Если не подходит, прикладывайте пример в файле и показывайте, каким должен быть результат.
К сообщению приложен файл: test.xlsx(9Kb)


marinamorozova_box@mail.ru
ЯД: 410013299366744 WM: R193491431804
 
Ответить
Сообщениеlinkod, так пойдет?
Код
=СРЗНАЧ(ЕСЛИ(ЧАСТОТА(СТРОКА(A1:A21)+1;СТРОКА(A2:A21)*(A2:A21<=0))>1;ЧАСТОТА(СТРОКА(A1:A21)+1;СТРОКА(A2:A21)*(A2:A21<=0))-1))

формула массива, вводится через ctrl+shift+enter.

Если не подходит, прикладывайте пример в файле и показывайте, каким должен быть результат.

Автор - Manyasha
Дата добавления - 08.08.2016 в 13:33
Мир MS Excel » Вопросы и решения » Вопросы по Excel » поиск рядов положительных чисел и вычисление среднего кол-в (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2017 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!