Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Функция ВПР не корректно обрабатывает значение - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Функция ВПР не корректно обрабатывает значение (Формулы/Formulas)
Функция ВПР не корректно обрабатывает значение
vorm Дата: Вторник, 09.08.2016, 14:31 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день. Столкнулся с проблемой, Функция ВПР не корректно обрабатывает значение, все видно в приложенном файле, в 1 строке. Видимо содержимое A1 имеет или не верный формат, или лишние символы, но понять что именно я не могу, ошибка плавающая и к одинаковому виду необходимо привести более 100к строк. В чем может быть проблема?

Заранее огромное спасибо!
К сообщению приложен файл: 7431807.xlsx(10Kb)


Сообщение отредактировал vorm - Вторник, 09.08.2016, 14:45
 
Ответить
СообщениеДобрый день. Столкнулся с проблемой, Функция ВПР не корректно обрабатывает значение, все видно в приложенном файле, в 1 строке. Видимо содержимое A1 имеет или не верный формат, или лишние символы, но понять что именно я не могу, ошибка плавающая и к одинаковому виду необходимо привести более 100к строк. В чем может быть проблема?

Заранее огромное спасибо!

Автор - vorm
Дата добавления - 09.08.2016 в 14:31
Pelena Дата: Вторник, 09.08.2016, 14:48 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 9890
Репутация: 2269 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Здравствуйте.
У Вас там в конце появляется лишний символ с кодом 13.
Можно формулу немного подкорректировать. Вводится как формула массива Ctrl+Shift+Enter
Код
=ВПР(ПЕЧСИМВ(A2);ПЕЧСИМВ('112'!A1:A3);1;0)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
У Вас там в конце появляется лишний символ с кодом 13.
Можно формулу немного подкорректировать. Вводится как формула массива Ctrl+Shift+Enter
Код
=ВПР(ПЕЧСИМВ(A2);ПЕЧСИМВ('112'!A1:A3);1;0)

Автор - Pelena
Дата добавления - 09.08.2016 в 14:48
vorm Дата: Вторник, 09.08.2016, 15:00 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Огромное вам спасибо! Помогло!
 
Ответить
СообщениеОгромное вам спасибо! Помогло!

Автор - vorm
Дата добавления - 09.08.2016 в 15:00
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Функция ВПР не корректно обрабатывает значение (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!