Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/РАНГ по времени, распределение мест по времени - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » РАНГ по времени, распределение мест по времени (Формулы/Formulas)
РАНГ по времени, распределение мест по времени
PavelP Дата: Суббота, 13.08.2016, 20:19 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте!

Подскажите пожалуйста, есть протокол который будет использоваться на соревнованиях, для удобства подсчета решили внедрить пару формул: 1 расчет времени, 2 распределение мест. С первой все работает, а вот со второй получается - 1) либо ставит на первое место самое большое значение времени 2) учитывает самое меньшее время, затрачено на дистанцию и делает его лучшим но из 25 строк а участников 11 получается идет учет нулевых значений.

Количество строк уменьшать не могу т.к. в день гонки могут зарегистрироваться еще участники и при добавлении новых строк про формулы можно забыть.

Необходимо чтобы excel распределял места на основании "Чистого времени", чем меньше время тем выше ранг и при этом не учитывал строк где нет участников!

Возможно такое сделать?

Спасибо!
К сообщению приложен файл: ___14.08.2016.xlsx(61Kb)
 
Ответить
СообщениеЗдравствуйте!

Подскажите пожалуйста, есть протокол который будет использоваться на соревнованиях, для удобства подсчета решили внедрить пару формул: 1 расчет времени, 2 распределение мест. С первой все работает, а вот со второй получается - 1) либо ставит на первое место самое большое значение времени 2) учитывает самое меньшее время, затрачено на дистанцию и делает его лучшим но из 25 строк а участников 11 получается идет учет нулевых значений.

Количество строк уменьшать не могу т.к. в день гонки могут зарегистрироваться еще участники и при добавлении новых строк про формулы можно забыть.

Необходимо чтобы excel распределял места на основании "Чистого времени", чем меньше время тем выше ранг и при этом не учитывал строк где нет участников!

Возможно такое сделать?

Спасибо!

Автор - PavelP
Дата добавления - 13.08.2016 в 20:19
krosav4ig Дата: Суббота, 13.08.2016, 21:16 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1362
Репутация: 548 ±
Замечаний: 0% ±

Excel 2007, 2013
Здравствуйте.
Код
=ЕСЛИОШИБКА(РАНГ(H3;H$3:ИНДЕКС(H:H;ПРОСМОТР("яяя";B:B;A:A)+2);1);"")
или
Код
=ЕСЛИОШИБКА(РАНГ(H3;H$3:ИНДЕКС(H:H;ПОИСКПОЗ(;H:H;)-1);1);"")


(_)Õvõ(_)

Сообщение отредактировал krosav4ig - Суббота, 13.08.2016, 21:18
 
Ответить
СообщениеЗдравствуйте.
Код
=ЕСЛИОШИБКА(РАНГ(H3;H$3:ИНДЕКС(H:H;ПРОСМОТР("яяя";B:B;A:A)+2);1);"")
или
Код
=ЕСЛИОШИБКА(РАНГ(H3;H$3:ИНДЕКС(H:H;ПОИСКПОЗ(;H:H;)-1);1);"")

Автор - krosav4ig
Дата добавления - 13.08.2016 в 21:16
PavelP Дата: Суббота, 13.08.2016, 22:37 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Странно вставляю формулу, вообще ни чего не происходит?
 
Ответить
СообщениеСтранно вставляю формулу, вообще ни чего не происходит?

Автор - PavelP
Дата добавления - 13.08.2016 в 22:37
gling Дата: Суббота, 13.08.2016, 22:50 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1352
Репутация: 326 ±
Замечаний: 0% ±

2010
Здравствуйте. Выше прописанные формулы должны работать. Возможно отключен автопересчет формул. Вот еще вариант, немного переделал Вашу.
Код
=ЕСЛИ(H3;РАНГ(H3;$H$3:$H$27;1)-(МАКС($A$3:$A$27)-СЧЁТЗ($B$3:$B$27));"")


Сообщение отредактировал gling - Воскресенье, 14.08.2016, 13:29
 
Ответить
СообщениеЗдравствуйте. Выше прописанные формулы должны работать. Возможно отключен автопересчет формул. Вот еще вариант, немного переделал Вашу.
Код
=ЕСЛИ(H3;РАНГ(H3;$H$3:$H$27;1)-(МАКС($A$3:$A$27)-СЧЁТЗ($B$3:$B$27));"")

Автор - gling
Дата добавления - 13.08.2016 в 22:50
PavelP Дата: Воскресенье, 14.08.2016, 04:08 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Всем большое спасибо! Все работает! Воспользовался крайней формулой!
 
Ответить
СообщениеВсем большое спасибо! Все работает! Воспользовался крайней формулой!

Автор - PavelP
Дата добавления - 14.08.2016 в 04:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » РАНГ по времени, распределение мест по времени (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!