Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Зависимые списки с несколькими словами и симв. в 1-ом уровне - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
Страница 1 из 11
Модератор форума: _Boroda_, Pelena, Manyasha, SLAVICK 
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Зависимые списки с несколькими словами и симв. в 1-ом уровне (Формулы/Formulas)
Зависимые списки с несколькими словами и симв. в 1-ом уровне
Leprotto Дата: Понедельник, 15.08.2016, 17:50 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 78
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Добрый день, форумчане!
Пытаюсь организовать трехуровневый список. В сети куча примеров, все понятно, но в них используются простые односложные слова.
А у меня первый уровень списка — это названия фирм с кавычками, пробелами и несколькими словами. Соответственно я не могу задать такие имена диапазонам.
Подскажите, как это обойти?
Пример приложил.
P.S. на втором уровне тоже встречаются кавычки и несколько слов.
К сообщению приложен файл: spiski.xlsx(9Kb)
 
Ответить
СообщениеДобрый день, форумчане!
Пытаюсь организовать трехуровневый список. В сети куча примеров, все понятно, но в них используются простые односложные слова.
А у меня первый уровень списка — это названия фирм с кавычками, пробелами и несколькими словами. Соответственно я не могу задать такие имена диапазонам.
Подскажите, как это обойти?
Пример приложил.
P.S. на втором уровне тоже встречаются кавычки и несколько слов.

Автор - Leprotto
Дата добавления - 15.08.2016 в 17:50
Nic70y Дата: Понедельник, 15.08.2016, 18:03 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3477
Репутация: 722 ±
Замечаний: 0% ±

Excel 2013
трехуровневый
в примере не нашел.
если сильно не заморачиваться, продукт=
Код
=ИНДЕКС(A2:B4;;ПОИСКПОЗ(K2;A1:B1;))
К сообщению приложен файл: 4738271.xlsx(10Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
трехуровневый
в примере не нашел.
если сильно не заморачиваться, продукт=
Код
=ИНДЕКС(A2:B4;;ПОИСКПОЗ(K2;A1:B1;))

Автор - Nic70y
Дата добавления - 15.08.2016 в 18:03
Leprotto Дата: Вторник, 16.08.2016, 09:15 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 78
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
в примере не нашел.

1-фирма
2-продукт
3-сорт

Nic70y,
если сильно не заморачиваться, продукт=

Спасибо, но так не очень подходит, т.к. у некоторых фирм 2-3 продукта, у других 15-20, т.е. будут списки с множеством пустых строк :(
 
Ответить
Сообщение
в примере не нашел.

1-фирма
2-продукт
3-сорт

Nic70y,
если сильно не заморачиваться, продукт=

Спасибо, но так не очень подходит, т.к. у некоторых фирм 2-3 продукта, у других 15-20, т.е. будут списки с множеством пустых строк :(

Автор - Leprotto
Дата добавления - 16.08.2016 в 09:15
Leprotto Дата: Вторник, 16.08.2016, 16:45 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 78
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Других предложений нет? :'(
 
Ответить
СообщениеДругих предложений нет? :'(

Автор - Leprotto
Дата добавления - 16.08.2016 в 16:45
Pelena Дата: Вторник, 16.08.2016, 16:59 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 9850
Репутация: 2254 ±
Замечаний: 0% ±

Excel 2010 & Mac Excel 2011
Может, так подойдёт?
К сообщению приложен файл: 0363660.xlsx(10Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеМожет, так подойдёт?

Автор - Pelena
Дата добавления - 16.08.2016 в 16:59
gling Дата: Вторник, 16.08.2016, 17:18 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1351
Репутация: 325 ±
Замечаний: 0% ±

2010
Еще вариант с формулой в именованном диапазоне
Код
=ИНДЕКС(Лист1!$A$2:$H$2;ПОИСКПОЗ(Лист1!$K2;Лист1!$A$1:$H$1;)):ИНДЕКС(Лист1!$A$2:$H$8;ПОИСКПОЗ("яяя";ИНДЕКС(Лист1!$A$2:$H$8;;ПОИСКПОЗ(Лист1!$K2;Лист1!$A$1:$H$1;));1);ПОИСКПОЗ(Лист1!$K2;Лист1!$A$1:$H$1;))
К сообщению приложен файл: 8940654.xlsx(10Kb)


Сообщение отредактировал gling - Вторник, 16.08.2016, 17:51
 
Ответить
СообщениеЕще вариант с формулой в именованном диапазоне
Код
=ИНДЕКС(Лист1!$A$2:$H$2;ПОИСКПОЗ(Лист1!$K2;Лист1!$A$1:$H$1;)):ИНДЕКС(Лист1!$A$2:$H$8;ПОИСКПОЗ("яяя";ИНДЕКС(Лист1!$A$2:$H$8;;ПОИСКПОЗ(Лист1!$K2;Лист1!$A$1:$H$1;));1);ПОИСКПОЗ(Лист1!$K2;Лист1!$A$1:$H$1;))

Автор - gling
Дата добавления - 16.08.2016 в 17:18
Zdx Дата: Среда, 17.08.2016, 01:32 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 4 ±
Замечаний: 0% ±

2010
Еще вариант.
К сообщению приложен файл: 6699396.xlsx(10Kb)


Неизлечимых болезней нет, есть неизлечимые люди.
 
Ответить
СообщениеЕще вариант.

Автор - Zdx
Дата добавления - 17.08.2016 в 01:32
Leprotto Дата: Среда, 17.08.2016, 09:21 | Сообщение № 8
Группа: Пользователи
Ранг: Участник
Сообщений: 78
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Nic70y, Pelena, gling, Zdx, СПАСИБО БОЛЬШОЕ !!!
 
Ответить
СообщениеNic70y, Pelena, gling, Zdx, СПАСИБО БОЛЬШОЕ !!!

Автор - Leprotto
Дата добавления - 17.08.2016 в 09:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Зависимые списки с несколькими словами и симв. в 1-ом уровне (Формулы/Formulas)
Страница 1 из 11
Поиск:

Яндекс цитирования
© 2010-2016 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!